From: Gustavo Padovan <gustavo@padovan.org>
To: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
Cc: "Greg Kroah-Hartman" <gregkh@linuxfoundation.org>,
linux-kernel@vger.kernel.org, devel@driverdev.osuosl.org,
dri-devel@lists.freedesktop.org,
"Daniel Stone" <daniels@collabora.com>,
"Arve Hjønnevåg" <arve@android.com>,
"Riley Andrews" <riandrews@android.com>,
"Daniel Vetter" <daniel.vetter@ffwll.ch>,
"Rob Clark" <robdclark@gmail.com>,
"Greg Hackmann" <ghackmann@google.com>,
"John Harrison" <John.C.Harrison@Intel.com>,
"Gustavo Padovan" <gustavo.padovan@collabora.co.uk>
Subject: Re: [PATCH v2 08/11] staging/android: make info->len return only the size of fence_infos
Date: Tue, 2 Feb 2016 16:46:00 -0200 [thread overview]
Message-ID: <20160202184600.GB29160@joana> (raw)
In-Reply-To: <56B0BAC6.30506@linux.intel.com>
2016-02-02 Maarten Lankhorst <maarten.lankhorst@linux.intel.com>:
> Op 02-02-16 om 14:23 schreef Gustavo Padovan:
> > From: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
> >
> > The len member of struct sync_file_info was returning the size of the whole
> > buffer (struct sync_file_info + fence_infos at the of it). This commit
> > change it to return only the size of the array of fence_infos.
> >
> > It also moves len to be right before the fences_infos struct.
> >
> > Signed-off-by: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
> > ---
> > drivers/staging/android/sync.c | 16 +++++++++++-----
> > drivers/staging/android/uapi/sync.h | 7 +++----
> > 2 files changed, 14 insertions(+), 9 deletions(-)
> >
> > diff --git a/drivers/staging/android/sync.c b/drivers/staging/android/sync.c
> > index ba7d461..e5fbf5a 100644
> > --- a/drivers/staging/android/sync.c
> > +++ b/drivers/staging/android/sync.c
> > @@ -502,14 +502,19 @@ static int sync_fill_fence_info(struct fence *fence, void *data, int size)
> > static long sync_file_ioctl_fence_info(struct sync_file *sync_file,
> > unsigned long arg)
> > {
> > - struct sync_file_info *info;
> > + struct sync_file_info in, *info;
> > __u32 size;
> > - __u32 len = 0;
> > + __u32 b_len, len = 0;
> > int ret, i;
> >
> > - if (copy_from_user(&size, (void __user *)arg, sizeof(size)))
> > + if (copy_from_user(&in, (void __user *)arg, sizeof(*info)))
> > return -EFAULT;
> >
> > + if (in.name || in.status || in.num_fences || in.fence_info)
> > + return -EFAULT;
> >
> Did you test this? I think in.name is always true..
Ugh, no! These checks were last change I made so I think I forgot to
test them properly.
Gustavo
next prev parent reply other threads:[~2016-02-02 18:46 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-02-02 13:23 [PATCH v2 00/11] android sync framework: clean up IOCTLs and ABI Gustavo Padovan
2016-02-02 13:23 ` [PATCH v2 01/11] staging/android: remove SYNC_WAIT ioctl Gustavo Padovan
2016-02-02 13:23 ` [PATCH v2 02/11] staging/android: rename sync_pt_info to fence_info Gustavo Padovan
2016-02-02 14:19 ` Maarten Lankhorst
2016-02-02 13:23 ` [PATCH v2 03/11] staging/android: rename sync_file_info_data to sync_file_info Gustavo Padovan
2016-02-02 13:23 ` [PATCH v2 04/11] staging/android: remove driver_data from struct fence_info Gustavo Padovan
2016-02-02 13:23 ` [PATCH v2 05/11] staging/android: remove len field " Gustavo Padovan
2016-02-02 13:23 ` [PATCH v2 06/11] staging/android: turn fence_info into a __u64 pointer Gustavo Padovan
2016-02-02 14:16 ` Maarten Lankhorst
2016-02-02 20:28 ` Gustavo Padovan
2016-02-03 8:32 ` Maarten Lankhorst
2016-02-02 15:28 ` Emil Velikov
2016-02-02 13:23 ` [PATCH v2 07/11] staging/android: add num_fences field to struct sync_file_info Gustavo Padovan
2016-02-02 13:23 ` [PATCH v2 08/11] staging/android: make info->len return only the size of fence_infos Gustavo Padovan
2016-02-02 14:18 ` Maarten Lankhorst
2016-02-02 18:46 ` Gustavo Padovan [this message]
2016-02-02 13:23 ` [PATCH v2 09/11] staging/android: rename SYNC_IOC_FENCE_INFO Gustavo Padovan
2016-02-02 13:23 ` [PATCH v2 10/11] staging/android: add flags member to sync ioctl structs Gustavo Padovan
2016-02-02 13:23 ` [PATCH v2 11/11] staging/android: remove redundant comments on sync_merge_data Gustavo Padovan
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20160202184600.GB29160@joana \
--to=gustavo@padovan.org \
--cc=John.C.Harrison@Intel.com \
--cc=arve@android.com \
--cc=daniel.vetter@ffwll.ch \
--cc=daniels@collabora.com \
--cc=devel@driverdev.osuosl.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=ghackmann@google.com \
--cc=gregkh@linuxfoundation.org \
--cc=gustavo.padovan@collabora.co.uk \
--cc=linux-kernel@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=riandrews@android.com \
--cc=robdclark@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox