From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756426AbcBDFPi (ORCPT ); Thu, 4 Feb 2016 00:15:38 -0500 Received: from mail-am1on0147.outbound.protection.outlook.com ([157.56.112.147]:60864 "EHLO emea01-am1-obe.outbound.protection.outlook.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1755080AbcBDFPg convert rfc822-to-8bit (ORCPT ); Thu, 4 Feb 2016 00:15:36 -0500 From: "Gujulan Elango, Hari Prasath (H.)" To: "gregkh@linuxfoundation.org" CC: "johnny.kim@atmel.com" , "austin.shin@atmel.com" , "chris.park@atmel.com" , "tony.cho@atmel.com" , "glen.lee@atmel.com" , "leo.kim@atmel.com" , "devel@driverdev.osuosl.org" , "linux-wireless@vger.kernel.org" , "linux-kernel@vger.kernel.org" Subject: Re: [PATCH] staging: wilc1000: Move Macro definition Thread-Topic: [PATCH] staging: wilc1000: Move Macro definition Thread-Index: AQHRUfYW1EtAP3sxpUqH+W9IhE2eH58bDtUAgABfhoA= Date: Thu, 4 Feb 2016 05:00:33 +0000 Message-ID: <20160204050143.GB9343@IND12F0122> References: <20160118134339.GA16263@IND12F0122> <20160203231950.GA6765@kroah.com> In-Reply-To: <20160203231950.GA6765@kroah.com> Accept-Language: en-US Content-Language: en-US X-MS-Has-Attach: X-MS-TNEF-Correlator: authentication-results: linuxfoundation.org; dkim=none (message not signed) header.d=none;linuxfoundation.org; dmarc=none action=none header.from=visteon.com; x-ms-exchange-messagesentrepresentingtype: 1 x-originating-ip: [91.212.132.118] x-microsoft-exchange-diagnostics: 1;DB5PR06MB1574;5:Vgi/hsuSS4UG+3b9vJLJAHyyM8xNe8xzvetGI46KFmWDCKgEDVc+Zy+Ci5DYb9/yWtWsiOGQ3fAvuXcYHXo7a1gELlRho111LLV7uv/cA+q55S7L4ocEKeoH1916AyTg1ci+Ay2pIYrkeXUWNtIc2Q==;24:givxXOFg3MHLO0jNs9F6cY74p0lxcUStp+g6gzsnwg5Lc0SU2C4aKtHyxj4M5+91tN8TGlkTl1F+K+YW8xUk3flzENo8NFD6EUJBmgtmChk= x-microsoft-antispam: UriScan:;BCL:0;PCL:0;RULEID:;SRVR:DB5PR06MB1574; x-ms-office365-filtering-correlation-id: d956c1bb-d039-485a-df79-08d32d201c91 x-microsoft-antispam-prvs: x-exchange-antispam-report-test: UriScan:(208512329853888); x-exchange-antispam-report-cfa-test: BCL:0;PCL:0;RULEID:(601004)(2401047)(8121501046)(5005006)(3002001)(10201501046);SRVR:DB5PR06MB1574;BCL:0;PCL:0;RULEID:;SRVR:DB5PR06MB1574; x-forefront-prvs: 084285FC5C x-forefront-antispam-report: SFV:NSPM;SFS:(10019020)(6009001)(24454002)(1730700002)(76176999)(54356999)(2900100001)(2351001)(77096005)(2501003)(2950100001)(11100500001)(33656002)(33716001)(10400500002)(5001960100002)(189998001)(3660700001)(106116001)(5008740100001)(3280700002)(110136002)(50986999)(87936001)(2906002)(92566002)(66066001)(5004730100002)(122556002)(586003)(19580405001)(1096002)(1076002)(86362001)(19580395003)(102836003)(3846002)(6116002)(40100003)(5002640100001)(4326007)(1220700001);DIR:OUT;SFP:1102;SCL:1;SRVR:DB5PR06MB1574;H:DB5PR06MB1573.eurprd06.prod.outlook.com;FPR:;SPF:None;MLV:sfv;LANG:en; spamdiagnosticoutput: 1:23 spamdiagnosticmetadata: NSPM Content-Type: text/plain; charset="us-ascii" Content-ID: <06691EDF24675E458350719C723D1520@eurprd06.prod.outlook.com> Content-Transfer-Encoding: 8BIT MIME-Version: 1.0 X-OriginatorOrg: visteon.com X-MS-Exchange-CrossTenant-originalarrivaltime: 04 Feb 2016 05:00:33.0115 (UTC) X-MS-Exchange-CrossTenant-fromentityheader: Hosted X-MS-Exchange-CrossTenant-id: 7a147aaf-01ec-498c-80a1-e34a8c63c548 X-MS-Exchange-Transport-CrossTenantHeadersStamped: DB5PR06MB1574 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, Feb 03, 2016 at 03:19:50PM -0800, gregkh@linuxfoundation.org wrote: > On Mon, Jan 18, 2016 at 01:42:35PM +0000, Gujulan Elango, Hari Prasath (H.) wrote: > > From: Hari Prasath Gujulan Elango > > > > This patch move's a macro defined in the middle of a structure > > definition to make it more readable. > > > > Signed-off-by: Hari Prasath Gujulan Elango > > --- > > drivers/staging/wilc1000/wilc_sdio.c | 2 +- > > 1 file changed, 1 insertion(+), 1 deletion(-) > > > > diff --git a/drivers/staging/wilc1000/wilc_sdio.c b/drivers/staging/wilc1000/wilc_sdio.c > > index e961b50..875ea68 100644 > > --- a/drivers/staging/wilc1000/wilc_sdio.c > > +++ b/drivers/staging/wilc1000/wilc_sdio.c > > @@ -29,12 +29,12 @@ static const struct sdio_device_id wilc_sdio_ids[] = { > > }; > > > > #define WILC_SDIO_BLOCK_SIZE 512 > > +#define MAX_NUN_INT_THRPT_ENH2 (5) /* Max num interrupts allowed in registers 0xf7, 0xf8 */ > > > > typedef struct { > > bool irq_gpio; > > u32 block_size; > > int nint; > > -#define MAX_NUN_INT_THRPT_ENH2 (5) /* Max num interrupts allowed in registers 0xf7, 0xf8 */ > > No, this is a very common way to show that this define is for this field > in the structure, please don't change that. > > sorry, > > greg k-h Thanks Greg,I got the message clear.Please discard this patch. Regards, Hari