From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754321AbcBVKpz (ORCPT ); Mon, 22 Feb 2016 05:45:55 -0500 Received: from mail-pf0-f178.google.com ([209.85.192.178]:34692 "EHLO mail-pf0-f178.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753358AbcBVKpy (ORCPT ); Mon, 22 Feb 2016 05:45:54 -0500 Date: Mon, 22 Feb 2016 16:15:34 +0530 From: Viresh Kumar To: "Rafael J. Wysocki" Cc: Juri Lelli , Srinivas Pandruvada , "Rafael J. Wysocki" , Linux PM list , Peter Zijlstra , Ingo Molnar , Linux Kernel Mailing List , Steve Muckle , Thomas Gleixner Subject: Re: [PATCH v10 1/3] cpufreq: Add mechanism for registering utilization update callbacks Message-ID: <20160222104534.GM28226@vireshk-i7> References: <3071836.JbNxX8hU6x@vostro.rjw.lan> <1455900129.7375.231.camel@linux.intel.com> <20160219172545.GA27380@e106622-lin> <1882532.OhsNMeyWOd@vostro.rjw.lan> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1882532.OhsNMeyWOd@vostro.rjw.lan> User-Agent: Mutt/1.5.23 (2014-03-12) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 19-02-16, 23:26, Rafael J. Wysocki wrote: > From: Rafael J. Wysocki > Subject: [PATCH] cpufreq: Rework the scheduler hooks for triggering updates > > Commit fe7034338ba0 (cpufreq: Add mechanism for registering > utilization update callbacks) added cpufreq_update_util() to be > called by the scheduler (from the CFS part) on utilization updates. > The goal was to allow CFS to pass utilization information to cpufreq > and to trigger it to evaluate the frequency/voltage configuration > (P-state) of every CPU on a regular basis. > > However, the last two arguments of that function are never used by > the current code, so CFS might simply call cpufreq_trigger_update() > instead of it. > > For this reason, drop the last two arguments of cpufreq_update_util(), > rename it to cpufreq_trigger_update() and modify CFS to call it. > > Moreover, since the utilization is not involved in that now, rename > data types, functions and variables related to cpufreq_trigger_update() > to reflect that (eg. struct update_util_data becomes struct > freq_update_hook and so on). > > Signed-off-by: Rafael J. Wysocki > --- > drivers/cpufreq/cpufreq.c | 48 ++++++++++++++++++++++--------------- > drivers/cpufreq/cpufreq_governor.c | 27 ++++++++++---------- > drivers/cpufreq/cpufreq_governor.h | 2 - > drivers/cpufreq/intel_pstate.c | 15 +++++------ > include/linux/cpufreq.h | 32 +++--------------------- > kernel/sched/deadline.c | 2 - > kernel/sched/fair.c | 13 +--------- > kernel/sched/rt.c | 2 - > 8 files changed, 58 insertions(+), 83 deletions(-) Acked-by: Viresh Kumar -- viresh