From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932236AbcFINdj (ORCPT ); Thu, 9 Jun 2016 09:33:39 -0400 Received: from gum.cmpxchg.org ([85.214.110.215]:58794 "EHLO gum.cmpxchg.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932167AbcFINdh (ORCPT ); Thu, 9 Jun 2016 09:33:37 -0400 Date: Thu, 9 Jun 2016 09:33:31 -0400 From: Johannes Weiner To: Michal Hocko Cc: linux-mm@kvack.org, linux-kernel@vger.kernel.org, Andrew Morton , Rik van Riel , Mel Gorman , Andrea Arcangeli , Andi Kleen , Tim Chen , kernel-team@fb.com Subject: Re: [PATCH 07/10] mm: base LRU balancing on an explicit cost model Message-ID: <20160609133331.GB11719@cmpxchg.org> References: <20160606194836.3624-1-hannes@cmpxchg.org> <20160606194836.3624-8-hannes@cmpxchg.org> <20160608125137.GH22570@dhcp22.suse.cz> <20160608161605.GF6727@cmpxchg.org> <20160609121802.GD24777@dhcp22.suse.cz> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20160609121802.GD24777@dhcp22.suse.cz> User-Agent: Mutt/1.6.1 (2016-04-27) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, Jun 09, 2016 at 02:18:02PM +0200, Michal Hocko wrote: > On Wed 08-06-16 12:16:05, Johannes Weiner wrote: > > On Wed, Jun 08, 2016 at 02:51:37PM +0200, Michal Hocko wrote: > > > On Mon 06-06-16 15:48:33, Johannes Weiner wrote: > > > > Rename struct zone_reclaim_stat to struct lru_cost, and move from two > > > > separate value ratios for the LRU lists to a relative LRU cost metric > > > > with a shared denominator. > > > > > > I just do not like the too generic `number'. I guess cost or price would > > > fit better and look better in the code as well. Up you though... > > > > Yeah, I picked it as a pair, numerator and denominator. But as Minchan > > points out, denom is superfluous in the final version of the patch, so > > I'm going to remove it and give the numerators better names. > > > > anon_cost and file_cost? > > Yes that is much more descriptive and easier to grep for. I didn't > propose that because I thought you would want to preserve the array > definition for an easier code to update them. It'll be slightly more verbose, but that's probably a good thing. Especially for readability in get_scan_count().