From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751517AbcGRNJP (ORCPT ); Mon, 18 Jul 2016 09:09:15 -0400 Received: from mx1.redhat.com ([209.132.183.28]:46433 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750965AbcGRNJO (ORCPT ); Mon, 18 Jul 2016 09:09:14 -0400 Date: Mon, 18 Jul 2016 08:09:10 -0500 From: Josh Poimboeuf To: Byungchul Park Cc: Frederic Weisbecker , Ingo Molnar , peterz@infradead.org, linux-kernel@vger.kernel.org, walken@google.com, Peter Zijlstra Subject: Re: [PATCH 1/2] x86/dumpstack: Optimize save_stack_trace Message-ID: <20160718130910.vmyvadh5arurxptv@treble> References: <1467628075-7289-1-git-send-email-byungchul.park@lge.com> <20160707101740.GF2279@X58A-UD3R> <20160708100819.GA17300@gmail.com> <20160708142929.lvxgapbxfv5wfbk2@treble> <20160708150231.GH30200@lerouge> <20160708152246.hgoisxhhtzeehrht@treble> <20160718031422.GN2279@X58A-UD3R> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline In-Reply-To: <20160718031422.GN2279@X58A-UD3R> User-Agent: Mutt/1.6.0.1 (2016-04-01) X-Greylist: Sender IP whitelisted, not delayed by milter-greylist-4.5.16 (mx1.redhat.com [10.5.110.31]); Mon, 18 Jul 2016 13:09:13 +0000 (UTC) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, Jul 18, 2016 at 12:14:22PM +0900, Byungchul Park wrote: > On Fri, Jul 08, 2016 at 10:22:46AM -0500, Josh Poimboeuf wrote: > > > > > Also, could you please rename the _norm names to _fast or so, to signal that this > > > > > is a faster but less reliable method to get a stack dump? Nobody knows what > > > > > '_norm' means, but '_fast' is pretty self-explanatory. > > > > > > > > Hm, but is print_context_stack_bp() variant really less reliable? From > > > > what I can tell, its only differences vs print_context_stack() are: > > > > > > > > - It doesn't scan the stack for "guesses" (which are 'unreliable' and > > > > are ignored by the ops->address() callback anyway). > > > > > > > > - It stops if ops->address() returns an error (which in this case means > > > > the array is full anyway). > > > > > > > > - It stops if the address isn't a kernel text address. I think this > > > > shouldn't normally be possible unless there's some generated code like > > > > bpf on the stack. Maybe it could be slightly improved for this case. > > > > > > > > So instead of adding a new save_stack_trace_fast() variant, why don't we > > > > just modify the existing save_stack_trace() to use > > > > print_context_stack_bp()? > > > > > > I'm not sure this is a good idea. First of all if the kernel isn't built with > > > frame pointers, all you have is wild walk guesses. > > > > True, though I'd argue that if frame pointers are disabled then > > save_stack_trace() should return an empty trace. But admittedly, that > > As Frederic said, I think, some save_stack_trace() users may want to > check the 'guesses', in other words, it's not good idea for > save_stack_trace() to return an empty trace when frame pointers are > disabled. No? With frame pointers disabled, yes, maybe guesses are better than nothing. > > > There are several different users of save_stack_trace() in the kernel, we can't > > > be sure that all of them are interested in dropping those guesses. > > > > > > So I'd rather advocate in favour of a new seperate helper. > > > > So how about we change save_stack_trace() to use print_context_stack() > > for CONFIG_FRAME_POINTER=n and print_context_stack_bp() for > > CONFIG_FRAME_POINTER=y? That would preserve the existing behavior, no? > > Even if CONFIG_FRAME_POINTER=y, someone may want to guess, doesn't they? For CONFIG_FRAME_POINTER=y, the guesses are ignored by __save_stack_address() and only the reliable addresses are saved. We shouldn't change that behavior, unless you actually know of a caller who wants the guesses. And even then the "guess" variation should be named accordingly to make it clear that it's not a "reliable" stack trace, even though frame pointers are enabled. -- Josh