From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752396AbcHAJ3B (ORCPT ); Mon, 1 Aug 2016 05:29:01 -0400 Received: from mail-wm0-f46.google.com ([74.125.82.46]:36152 "EHLO mail-wm0-f46.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751026AbcHAJ2l (ORCPT ); Mon, 1 Aug 2016 05:28:41 -0400 Date: Mon, 1 Aug 2016 10:28:58 +0100 From: Lee Jones To: torvalds@linux-foundation.org Cc: linux-kernel@vger.kernel.org Subject: [GIT PULL] MFD for v4.8 Message-ID: <20160801092858.GB5243@dell> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline Content-Transfer-Encoding: 8bit User-Agent: Mutt/1.6.2 (2016-07-01) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi Linus, The following changes since commit af8c34ce6ae32addda3788d54a7e340cad22516b: Linux 4.7-rc2 (2016-06-05 14:31:26 -0700) are available in the git repository at: git://git.kernel.org/pub/scm/linux/kernel/git/lee/mfd.git tags/mfd-for-linus-4.8 for you to fetch changes up to f37be01e6dc606f2fcc5e95c9933d948ce19bd35: mfd: qcom_rpm: Parametrize also ack selector size (2016-06-29 10:16:47 +0100) ---------------------------------------------------------------- - Core Frameworks - New API to call bespoke pre/post IRQ handlers; Regmap - New Device Support - Add support for RN5T567 to rn5t618 - Add support for COMe-cSL6 and COMe-mAL10 to kempld-core - New Functionality - Add support for USB Power Supply to axp20x - Add support for Power Key to hi655x-pmic - Fix-ups - Update MAINTAINERS; Dialog, Altera - Remove module support; max77843, max77620, max8998, max8997, max8925-i2c - Add module support; max14577 - Constifying; max77620 - Allow bespoke IRQ masking/unmasking; max77620 - Remove superfluous code; arizona, qcom_rpm, smsc-ece1099 - Power Management fixups; arizona-core - Error-path improvement; twl-core, dm355evm_msp, smsc-ece1099, hi655x - Clocking fixups; twl6040 - Trivial (spelling, headers, coding-style, whitespace, (re)naming); si476x-i2c, omap-usb-tll, ti_am335x_tscadc, tps6507, hi655x-pmic - Bug Fixes - Fix offset error for MSM8660; qcom_rpm - Fix possible spurious IRQs; arizona, hi655x-pmic ---------------------------------------------------------------- Andrew F. Davis (5): mfd: ti_am335x_tscadc: Use variable name for sizeof() operator mfd: ti_am335x_tscadc: Remove use of single line functions mfd: ti_am335x_tscadc: Use SIMPLE_DEV_PM_OPS helper macro mfd: ti_am335x_tscadc: Unify variable naming when referencing ti_tscadc_dev mfd: ti_am335x_tscadc: Rename regmap_tscadc to regmap Axel Lin (1): mfd: max77620: Constify resources tables Ben Copeland (1): mfd: tps6507: Fix white space warnings reported by checkpatch Ben Dooks (1): mfd: omap-usb-tll: Include omap-usb.h Charles Keepax (2): mfd: arizona: Remove some duplicate defines mfd: arizona: Add missing disable of PM runtime on probe error path Colin Ian King (1): mfd: si476x-i2c: Fix spelling mistake "comptible" -> "compatible" Hans de Goede (3): mfd: axp20x: Extend axp22x_volatile_ranges mfd: axp20x: Add a 500ms delay at the end of axp20x_power_off mfd: axp20x: Add axp20x-usb-power-supply for axp22x pmics Javier Martinez Canillas (2): mfd: max14577: Use module_init() instead of subsys_initcall() mfd: max14577: Allow driver to be built as a module John Stultz (3): mfd: hi655x-pmic: Fixup issue with un-acked interrupts mfd: hi655x-pmic: Rename some interrupt macro names mfd: hi655x-pmic: Add powerkey device to hi655x PMIC driver Laxman Dewangan (2): regmap: irq: Add support to call client specific pre/post interrupt service mfd: max77620: Mask/unmask interrupt before/after servicing it Lee Jones (1): Merge branches 'ib-mfd-regmap-4.8' and 'ib-mfd-regulator-arm-4.8' into ibs-for-mfd-merged Linus Walleij (4): mfd: qcom_rpm: Fix offset error for msm8660 mfd: qcom_rpm: Remove unused define mfd: stmpe: Move platform data into MFD driver mfd: qcom_rpm: Parametrize also ack selector size Markus Elfring (5): mfd: twl-core: Return directly after a failed platform_device_alloc() in add_numbered_child() mfd: twl-core: Refactoring for add_numbered_child() mfd: dm355evm_msp: Return directly after a failed platform_device_alloc() in add_child() mfd: smsc-ece1099: Delete an unnecessary variable initialisation in smsc_i2c_probe() mfd: smsc-ece1099: Return directly after a function failure in smsc_i2c_probe() Michael Brunner (1): mfd: Add support for COMe-cSL6 and COMe-mAL10 to Kontron PLD driver Paul Gortmaker (5): mfd: max77843: Make it explicitly non-modular mfd: max77620: Make it explicitly non-modular mfd: max8998: Make it explicitly non-modular mfd: max8997: Make it explicitly non-modular mfd: max8925-i2c: Make it explicitly non-modular Peter Ujfalusi (1): mfd: twl6040: Handle mclk used for HPPLL and optional internal clock source Richard Fitzgerald (1): mfd: arizona: Check if AOD interrupts are pending before dispatching Stefan Agner (5): ARM: dts: meson: minix-neo-x8: define PMIC as power controller mfd: rn5t618: Add Ricoh RN5T567 PMIC support regulator: rn5t618: Add RN5T567 PMIC support mfd: rn5t618: Register power off callback optionally mfd: rn5t618: Register restart handler Steve Twiss (2): MAINTAINERS: Add Dialog PMIC search terms for missing documentation and header files MAINTAINERS: Add Dialog PMIC search terms for missing documentation and header files Thor Thayer (2): MAINTAINERS: Add Altera Arria10 System Resource Chip mfd: altr_a10sr: Add Altera Arria10 DevKit System Resource Chip Wei Yongjun (1): mfd: hi655x: Fix return value check in hi655x_pmic_probe() Documentation/devicetree/bindings/mfd/rn5t618.txt | 19 ++- Documentation/devicetree/bindings/mfd/twl6040.txt | 4 +- MAINTAINERS | 11 ++ arch/arm/boot/dts/meson8-minix-neo-x8.dts | 1 + drivers/base/regmap/regmap-irq.c | 15 +- drivers/mfd/Kconfig | 24 ++- drivers/mfd/Makefile | 2 + drivers/mfd/altera-a10sr.c | 169 ++++++++++++++++++++++ drivers/mfd/arizona-core.c | 4 +- drivers/mfd/arizona-irq.c | 16 +- drivers/mfd/axp20x.c | 17 +++ drivers/mfd/dm355evm_msp.c | 7 +- drivers/mfd/hi655x-pmic.c | 59 +++++--- drivers/mfd/kempld-core.c | 16 ++ drivers/mfd/max14577.c | 2 +- drivers/mfd/max77620.c | 75 +++++++--- drivers/mfd/max77843.c | 24 +-- drivers/mfd/max8925-i2c.c | 14 +- drivers/mfd/max8997.c | 30 +--- drivers/mfd/max8998.c | 27 +--- drivers/mfd/omap-usb-tll.c | 2 + drivers/mfd/qcom_rpm.c | 57 ++++++-- drivers/mfd/rn5t618.c | 70 +++++++-- drivers/mfd/si476x-i2c.c | 2 +- drivers/mfd/smsc-ece1099.c | 11 +- drivers/mfd/stmpe.c | 40 +++-- drivers/mfd/ti_am335x_tscadc.c | 135 +++++++---------- drivers/mfd/tps6507x.c | 4 +- drivers/mfd/twl-core.c | 28 ++-- drivers/mfd/twl6040.c | 41 ++++-- drivers/regulator/Kconfig | 5 +- drivers/regulator/rn5t618-regulator.c | 40 ++++- include/linux/mfd/altera-a10sr.h | 85 +++++++++++ include/linux/mfd/arizona/registers.h | 6 - include/linux/mfd/hi655x-pmic.h | 25 +++- include/linux/mfd/rn5t618.h | 13 ++ include/linux/mfd/stmpe.h | 22 +-- include/linux/mfd/ti_am335x_tscadc.h | 2 +- include/linux/mfd/twl6040.h | 5 +- include/linux/regmap.h | 10 ++ 40 files changed, 782 insertions(+), 357 deletions(-) create mode 100644 drivers/mfd/altera-a10sr.c create mode 100644 include/linux/mfd/altera-a10sr.h -- Lee Jones Linaro STMicroelectronics Landing Team Lead Linaro.org │ Open source software for ARM SoCs Follow Linaro: Facebook | Twitter | Blog