From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756067AbcHBOPz (ORCPT ); Tue, 2 Aug 2016 10:15:55 -0400 Received: from mail-pa0-f68.google.com ([209.85.220.68]:33471 "EHLO mail-pa0-f68.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755628AbcHBOPk (ORCPT ); Tue, 2 Aug 2016 10:15:40 -0400 Date: Tue, 2 Aug 2016 23:14:11 +0900 From: Namhyung Kim To: Jiri Olsa Cc: Steven Rostedt , Jiri Olsa , Arnaldo Carvalho de Melo , lkml , David Ahern , Ingo Molnar , Peter Zijlstra Subject: Re: [RFC 0/4] tools lib traceevent: Install fixes Message-ID: <20160802141411.GC6968@danjae.aot.lge.com> References: <1470073292-18114-1-git-send-email-jolsa@kernel.org> <20160802031055.GB25068@danjae.aot.lge.com> <20160802093134.GB2036@krava> <20160802094823.4a58b42f@gandalf.local.home> <20160802140144.GA18401@krava> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline In-Reply-To: <20160802140144.GA18401@krava> User-Agent: Mutt/1.6.2 (2016-07-01) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, Aug 02, 2016 at 04:01:44PM +0200, Jiri Olsa wrote: > On Tue, Aug 02, 2016 at 09:48:23AM -0400, Steven Rostedt wrote: > > SNIP > > > > > > > > > > > > > Also I think it'd be better for libtraceevent has dependency to libdl > > > > explicitly so that we can get rid of -ldl at the end. > > > > > > agreed, I'll queue your patch if v2 is needed > > > > > > > BTW, before we start making this ready for their own libraries, I'd > > like to make some changes with the naming convention. Mainly with > > event_format and format_field. > > > > Perhaps we should change them to pevent_event and pevent_field? > > right, it does not have any global prefix for public symbols > > I'd actualy expect something like 'traceevent_', > but 'pevent' is ok as well I guess The 'pevent' prefix would be more consistent to similar APIs IMHO. Maybe it's worth splitting public header and internal header files? Thanks, Namhyung