From: Lee Jones <lee.jones@linaro.org>
To: 冯锐 <rui_feng@realsil.com.cn>
Cc: "Ulf Hansson" <ulf.hansson@linaro.org>,
"Greg KH" <gregkh@linuxfoundation.org>,
"arnd@arndb.de" <arnd@arndb.de>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"吳昊澄 Ricky" <ricky_wu@realtek.com>
Subject: Re: 答复: 答复: 答复: [PATCH] mfd: rtsx: Add support for RTS5260
Date: Fri, 13 Oct 2017 10:32:57 +0100 [thread overview]
Message-ID: <20171013093257.lsyrht5ajjsgwe5m@dell> (raw)
In-Reply-To: <2A308283684ECD4B896628E09AF5361E01A73765@RS-MBS01.realsil.com.cn>
On Thu, 12 Oct 2017, 冯锐 wrote:
> > On Fri, 29 Sep 2017, 冯锐 wrote:
> > > > On Fri, 22 Sep 2017, 冯锐 wrote:
> > > >
> > > > > > On Fri, Sep 22, 2017 at 05:36:24PM +0800, rui_feng@realsil.com.cn
> > wrote:
> > > > > > > From: rui_feng <rui_feng@realsil.com.cn>
> > > > > > >
> > > > > > > Add support for new chip rts5260.
> > > > > > > In order to support rts5260,the definitions of some internal
> > > > > > > registers and workflow have to be modified and are different
> > > > > > > from its predecessors. So we need this patch to ensure RTS5260 can
> > work.
> > > > > > >
> > > > > > > Signed-off-by: Rui Feng <rui_feng@realsil.com.cn>
> > > > > >
> > > > > > Nit, this name needs to match your "From:" line. It almost does
> > > > > > :)
> > > > > >
> > > > > > Why is this a drivers/misc/ driver?
> > > > > >
> > > > > I want to put this driver in mfd because other drivers like
> > > > > rts5249,rts5227 and so on are in mfd, but lee jones said " There
> > > > > is way too
> > > > much code in this file to be an MFD driver.
> > > >
> > > > There's more to it than that.
> > > >
> > > > It's not an MFD driver because it's a card reader an nothing else.
> > > >
> > > > MFDs cross subsystem boundaries, whereas this is just a card reader.
> > > >
> > > > MFD isn't a dumping ground for devices which don't belong anywhere else.
> > >
> > > The functions in rts5260.c are called by
> > > drivers/mmc/host/rtsx_pci_sdmmc.c, it cross
> >
> > What subsystem boundary does it cross? MMC and ... ?
> >
> Rts5260 support SD card and memstick, it cross mmc and memstick,
> and it's a multifunction device, so I think put it in mfd is OK.
You're persistent, I'll give you that.
I already know you think it's okay. But I don't think it is.
There is wayyyyyy to much actual functionality contained in this
driver to be an MFD, and it's all related to reading block devices.
It sounds like there should be somewhere for MMC and Memstick to place
shared code. MFD is not that place however.
> > > Because many other similar drivers are in mfd, if relocate rts5260 now
> > > will lead to a much bigger modification,
> >
> > Totally fine.
> >
> > > and customer is in need of this patch. I think put rts5260 in mfd is
> > > better now.
> >
> > The upstream kernel is not customer focused.
> >
> > > If mfd is really not the right place,
> >
> > MFD is not the right place.
> >
> > > I will relocate it later not in this patch.
> > > Greg, what do you think of putting rts5260 in mfd?
> >
> > Trying to leap-frog me will only seek to annoy and will not help your cause.
> >
> > > > > So I put it here.
> > > >
> > > > Without creating a new subsystem, I can't think of a better place for it
> > either.
> > > >
> > > > > > > --- /dev/null
> > > > > > > +++ b/drivers/misc/rts5260.c
> > > > > > > @@ -0,0 +1,590 @@
> > > > > > > +/* Driver for Realtek PCI-Express card reader
> > > > > > > + *
> > > > > > > + * Copyright(c) 2016-2017 Realtek Semiconductor Corp. All
> > > > > > > +rights
> > > > reserved.
> > > > > > > + *
> > > > > > > + * This program is free software; you can redistribute it
> > > > > > > +and/or modify it
> > > > > > > + * under the terms of the GNU General Public License as
> > > > > > > +published by the
> > > > > > > + * Free Software Foundation; either version 2, or (at your
> > > > > > > +option) any
> > > > > > > + * later version.
> > > > > >
> > > > > > Do you really mean "any later version"? (I have to ask...)
> > > > > >
> > > > > > > + *
> > > > > > > + * This program is distributed in the hope that it will be
> > > > > > > + useful, but
> > > > > > > + * WITHOUT ANY WARRANTY; without even the implied warranty of
> > > > > > > + * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
> > See
> > > > the
> > > > > > GNU
> > > > > > > + * General Public License for more details.
> > > > > > > + *
> > > > > > > + * You should have received a copy of the GNU General Public
> > > > > > > + License along
> > > > > > > + * with this program; if not, see <http://www.gnu.org/licenses/>.
> > > > > > > + *
> > > > > > > + * Author:
> > > > > > > + * Steven FENG <steven_feng@realsil.com.cn>
> > > > > > > + * Rui FENG <rui_feng@realsil.com.cn>
> > > > > > > + * Wei WANG <wei_wang@realsil.com.cn>
> > > > > > > + */
> > > > > > > +
> > > > > > > +#include <linux/module.h>
> > > > > > > +#include <linux/delay.h>
> > > > > > > +#include <linux/mfd/rtsx_pci.h>
> > > > > > > +
> > > > > > > +#include "../mfd/rtsx_pcr.h"
> > > > > >
> > > > > > That looks "odd" :(
> > > >
> > > > This is odd.
> > > >
> > > > You should move that file into include/.
> > > >
> >
--
Lee Jones
Linaro STMicroelectronics Landing Team Lead
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog
prev parent reply other threads:[~2017-10-13 9:33 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-09-22 9:36 [PATCH] mfd: rtsx: Add support for RTS5260 rui_feng
2017-09-22 9:54 ` Greg KH
2017-09-22 10:02 ` 答复: " 冯锐
2017-09-22 12:02 ` Lee Jones
2017-09-29 9:26 ` 答复: " 冯锐
2017-10-04 11:15 ` Lee Jones
2017-10-12 9:29 ` 答复: " 冯锐
2017-10-13 9:32 ` Lee Jones [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20171013093257.lsyrht5ajjsgwe5m@dell \
--to=lee.jones@linaro.org \
--cc=arnd@arndb.de \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=ricky_wu@realtek.com \
--cc=rui_feng@realsil.com.cn \
--cc=ulf.hansson@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox