From: Dan Carpenter <dan.carpenter@oracle.com>
To: Marcus Wolf <marcus.wolf@smarthome-wolf.de>
Cc: devel@driverdev.osuosl.org, gregkh@linuxfoundation.org,
linux@Wolf-Entwicklungen.de, linux-kernel@vger.kernel.org,
"Simon Sandström" <simon@nikanor.nu>
Subject: Re: [PATCH 4/6] staging: pi433: Rename enum optionOnOff in rf69_enum.h
Date: Tue, 5 Dec 2017 16:03:08 +0300 [thread overview]
Message-ID: <20171205130308.ifapjzngjisfx4p2@mwanda> (raw)
In-Reply-To: <56c0844b-5797-1fc5-551d-f464963fbc43@smarthome-wolf.de>
On Tue, Dec 05, 2017 at 01:40:02PM +0100, Marcus Wolf wrote:
> > It's not the greatest, but it's not the worst... The configuration for
> > ->enable_sync is a bit spread out and it might be nice to move it all to
> > one function?
> >
> > I liked Simon's naming scheme and I thought it was clear what the
> > rf69_set_sync(spi, false) function would do.
> ^^^^^^^^^^^^^^^^^^^^^^^^^
> >
Simon's liked splitting it up but he also proposed this alternative:
rf69_set_sync_operation(spi, true/false);
but I removed the "_operation" because I think it doesn't add anything.
> > Simon, it seems like Marcus and I both are Ok with your style choices.
> > Do whatever seems best when you implement the code. If it's awkward to
> > break up the functions then don't.
> >
> > regards,
> > dan carpenter
> >
>
> Hi Dan,
>
> now I am a bit confused.
>
> My favourit:
> ------------
> rf69_set_sync_enable(spi, false)
> rf69_set_amp_enable(spi, false)
> rf69_set_crc_enable(spi, false)
>
> I prefer to keep the enable (or comparable), because it shows, what the
> function is doing. For sync, for example, there are several setter:
> size, tolerance, values ... AND enable (or comparable).
To me it's just weird that "_enable" disables anything. I really
prefer just splitting it up. I don't think it will bloat the code.
But I'm also fine with:
rf69_set_sync(spi, true/false)
rf69_set_amp(spi, true/false)
rf69_set_crc(spi, true/false)
Anyway, I feel like I'll like whatever Simon does. Some of these
things, you can't tell how they'll look until the end until you try.
Let's wait until we see a patch before we debate any more.
regards,
dan carpenter
next prev parent reply other threads:[~2017-12-05 13:03 UTC|newest]
Thread overview: 32+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-12-03 15:17 [PATCH 0/6] Fix indentation and CamelCase issues in staging/pi433 Simon Sandström
2017-12-03 15:17 ` [PATCH 1/6] staging: pi433: Fix indentation in rf69_enum.h Simon Sandström
2017-12-03 15:17 ` [PATCH 2/6] staging: pi433: Capitalize constant definitions Simon Sandström
2017-12-03 15:17 ` [PATCH 3/6] staging: pi433: Rename variable in struct pi433_rx_cfg Simon Sandström
2017-12-03 15:17 ` [PATCH 4/6] staging: pi433: Rename enum optionOnOff in rf69_enum.h Simon Sandström
2017-12-03 16:49 ` Marcus Wolf
2017-12-04 10:04 ` Simon Sandström
2017-12-04 10:17 ` Dan Carpenter
2017-12-04 10:37 ` Dan Carpenter
2017-12-04 18:37 ` Marcus Wolf
2017-12-04 19:15 ` Dan Carpenter
2017-12-04 19:22 ` Marcus Wolf
2017-12-04 19:42 ` Simon Sandström
2017-12-04 19:59 ` Marcus Wolf
2017-12-04 20:05 ` Simon Sandström
2017-12-05 12:06 ` Marcus Wolf
2017-12-05 12:16 ` Dan Carpenter
2017-12-05 12:40 ` Marcus Wolf
2017-12-05 13:03 ` Dan Carpenter [this message]
2017-12-03 15:17 ` [PATCH 5/6] staging: pi433: Rename enum dataMode " Simon Sandström
2017-12-04 10:24 ` Dan Carpenter
2017-12-04 19:12 ` Marcus Wolf
2017-12-04 19:21 ` Dan Carpenter
2017-12-04 19:31 ` Marcus Wolf
2017-12-04 19:56 ` Dan Carpenter
2017-12-04 20:21 ` Marcus Wolf
2017-12-03 15:17 ` [PATCH 6/6] staging: pi433: Rename enum modShaping " Simon Sandström
2017-12-04 10:33 ` Dan Carpenter
2017-12-04 18:59 ` Marcus Wolf
2017-12-04 19:18 ` Dan Carpenter
2017-12-04 19:41 ` Marcus Wolf
2017-12-17 17:13 ` Marcus Wolf
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20171205130308.ifapjzngjisfx4p2@mwanda \
--to=dan.carpenter@oracle.com \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@Wolf-Entwicklungen.de \
--cc=marcus.wolf@smarthome-wolf.de \
--cc=simon@nikanor.nu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox