From: Juri Lelli <juri.lelli@gmail.com>
To: "Christopher Díaz Riveros" <chrisadr@gentoo.org>
Cc: Peter Zijlstra <peterz@infradead.org>,
mingo@redhat.com, linux-kernel@vger.kernel.org,
kernel-janitors@vger.kernel.org
Subject: Re: [PATCH-next] sched/headers: Clean up <linux/sched.h>
Date: Wed, 21 Feb 2018 09:09:44 +0100 [thread overview]
Message-ID: <20180221080944.GB8032@localhost.localdomain> (raw)
In-Reply-To: <1518787521.2464.20.camel@gentoo.org>
On 16/02/18 08:25, Christopher Díaz Riveros wrote:
> El vie, 16-02-2018 a las 10:44 +0100, Juri Lelli escribió:
> > On 15/02/18 17:52, Peter Zijlstra wrote:
> > > On Thu, Feb 15, 2018 at 10:43:18AM -0500, Christopher Diaz Riveros
> > > wrote:
> >
> > [...]
> >
> > > > @@ -437,20 +437,28 @@ struct sched_dl_entity {
> > > > * during sched_setattr(), they will remain the same
> > > > until
> > > > * the next sched_setattr().
> > > > */
> > > > - u64 dl_runtime; /*
> > > > Maximum runtime for each instance */
> > > > - u64 dl_deadline; /
> > > > * Relative deadline of each instance */
> > > > - u64 dl_period; /*
> > > > Separation of two instances (period) */
> > > > - u64 dl_bw;
> > > > /* dl_runtime / dl_period */
> > > > - u64 dl_density; /*
> > > > dl_runtime / dl_deadline */
> > > > + /* Maximum runtime for each instance */
> > > > + u64 dl_runtime;
> > > > + /* Relative deadline of each instance */
> > > > + u64 dl_deadline;
> > > > + /* Separation of two instances (period) */
> > > > + u64 dl_period;
> > > > + /* dl_runtime / dl_period */
> > > > + u64 dl_bw;
> > > > + /* dl_runtime / dl_deadline */
> > > > + u64 dl_density;
> > >
> > > That's a whole lot less readable :/
> >
> > Yep. :(
>
> Thank you all for the feedback, I'll consider this patch as NACK. Sorry
> for wasting time in a low quality patch. I'll prepare a better one
> next time :)
No problem, thanks actually to seeing if things can be cleaned up. :)
While going through that struct again I was thinking that we might want
to completely remove inline comments and put them in the above comment
block(s), as we already have for bool flags:
/*
* Some bool flags:
*
* @dl_throttled tells if we exhausted the runtime. If so, the
* task has to wait for a replenishment to be performed at the
* next firing of dl_timer.
[...]
Would it be OK and any better?
Thanks,
- Juri
next prev parent reply other threads:[~2018-02-21 8:09 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-02-15 15:43 [PATCH-next] sched/headers: Clean up <linux/sched.h> Christopher Diaz Riveros
2018-02-15 16:52 ` Peter Zijlstra
2018-02-15 17:10 ` Christopher Díaz Riveros
2018-02-16 9:44 ` Juri Lelli
2018-02-16 13:25 ` Christopher Díaz Riveros
2018-02-21 8:09 ` Juri Lelli [this message]
2018-02-21 16:56 ` [RFC] sched/headers: comments clean " Christopher Diaz Riveros
2018-02-15 17:49 ` [PATCH-next] sched/headers: Clean " Randy Dunlap
2018-02-15 18:10 ` Christopher Díaz Riveros
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180221080944.GB8032@localhost.localdomain \
--to=juri.lelli@gmail.com \
--cc=chrisadr@gentoo.org \
--cc=kernel-janitors@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=peterz@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox