From: "Du, Changbin" <changbin.du@intel.com>
To: "Rafael J. Wysocki" <rafael.j.wysocki@intel.com>
Cc: "Du, Changbin" <changbin.du@intel.com>,
"Rafael J. Wysocki" <rafael@kernel.org>,
Linux PM <linux-pm@vger.kernel.org>,
Steven Rostedt <rostedt@goodmis.org>,
Ingo Molnar <mingo@redhat.com>,
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v2] tracing/power: Polish the tracepoints cpu_idle and cpu_frequency
Date: Fri, 2 Mar 2018 18:50:18 +0800 [thread overview]
Message-ID: <20180302105018.sllck7elmime6h7i@intel.com> (raw)
In-Reply-To: <242e7e1f-c880-31fa-2db6-c03988a183b6@intel.com>
On Fri, Mar 02, 2018 at 11:39:16AM +0100, Rafael J. Wysocki wrote:
> On 3/2/2018 11:15 AM, Du, Changbin wrote:
> > On Fri, Mar 02, 2018 at 11:18:10AM +0100, Rafael J. Wysocki wrote:
> > > On Fri, Mar 2, 2018 at 10:41 AM, Du, Changbin <changbin.du@intel.com> wrote:
> > > > > > > That rather isn't the case if negative values are ever passed to the
> > > > > > > tracepoint, right?
> > > > > > >
> > > > > > yes.
> > > > > > > Which seems to be the reason why you want to make this change, isn't it?
> > > > > > >
> > > > > > yes, to improve readability.
> > > > > >
> > > > > > > So maybe fix the code using the tracepoint(s) to avoid passing
> > > > > > > negative values to it(them)?
> > > > > > For cpu_idle event, [0, CPUIDLE_STATE_MAX) are used to index the idle state arrary,
> > > > > > so I think a appropriate value for PWR_EVENT_EXIT is -1 (defined in include/trace/events/power.h).
> > > > > > Or do you have a better idea? Thanks!
> > > > > Sorry, I'm not sure what you mean.
> > > > >
> > > > > I'm saying that the code using the CPU PM tracepoints is not expected
> > > > > to pass -1 as the CPU number to them. IOW, neither -1 nor its UL
> > > > > representation should ever appear in the output of these tracepoints.
> > > > > If that happens, it is a problem with the code using the tracepoints
> > > > > which needs to be fixed. Users should not see any of these values.
> > > > This patch only changed 'state' field but cpuid. For cpu_idle event, 'state' is
> > > > singned value, but for cpu_frequency it is unsinged.
> > > > The cpuid is always unsinged value. So no one passes -1 as CPU number.
> > > You are right, 'state' not 'cpuid', sorry.
> > >
> > > Negative 'state' should not be passed to these tracepoints too, though.
> > The current situtation is that 'state' can be negative for event cpu_idle :(. This
> > is why I made this change.
> >
> And which is why I said that IMO it would be better to change the current
> situation.
>
> Your patch makes the results of it slightly less confusing to a human reader
> of the tracepoint output, but the situation is still unchanged after it.
>
> And what if someone has a script built around these tracepoints that knows
> how to handle the UL representation of -1, but doesn't know how to parse
> "-1"? They would need to update the script after your change, wouldn't
> they? And why would it be OK to inflict that work on them just to improve
> the readability of the output for humans?
>
yeah, I can guarantee all in kernel tools updated but people's private script.
For me, I just read the raw event for debug purpose. It is fair enough that leave
code as it was considering users' private tool based on this event.
>
>
--
Thanks,
Changbin Du
next prev parent reply other threads:[~2018-03-02 10:59 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <1519809638-24248-1-git-send-email-changbin.du@intel.com>
[not found] ` <CAJZ5v0jqG0pcqOuvAVoP7sNKoOe+3ByMk4X5AZASp84OPcrgPg@mail.gmail.com>
[not found] ` <20180301022719.xyfcu5tpmadjxbut@intel.com>
2018-03-02 9:24 ` [PATCH v2] tracing/power: Polish the tracepoints cpu_idle and cpu_frequency Rafael J. Wysocki
2018-03-02 9:41 ` Du, Changbin
2018-03-02 10:18 ` Rafael J. Wysocki
2018-03-02 10:15 ` Du, Changbin
2018-03-02 10:39 ` Rafael J. Wysocki
2018-03-02 10:50 ` Du, Changbin [this message]
[not found] <1518576038-16198-1-git-send-email-changbin.du@intel.com>
2018-02-14 15:19 ` Steven Rostedt
[not found] ` <20180214095440.2debdbba@gandalf.local.home>
[not found] ` <20180227093526.z7gxg2nk7xmfk2oi@intel.com>
[not found] ` <20180227173938.0826ed9b@vmware.local.home>
2018-02-28 2:45 ` Du, Changbin
2018-02-28 9:14 ` Rafael J. Wysocki
2018-02-28 9:07 ` Du, Changbin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180302105018.sllck7elmime6h7i@intel.com \
--to=changbin.du@intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=rafael.j.wysocki@intel.com \
--cc=rafael@kernel.org \
--cc=rostedt@goodmis.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox