The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Borislav Petkov <bp@alien8.de>
To: "Ghannam, Yazen" <Yazen.Ghannam@amd.com>
Cc: "linux-edac@vger.kernel.org" <linux-edac@vger.kernel.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"tony.luck@intel.com" <tony.luck@intel.com>,
	"x86@kernel.org" <x86@kernel.org>,
	"rafal@milecki.pl" <rafal@milecki.pl>,
	"clemej@gmail.com" <clemej@gmail.com>
Subject: Re: [PATCH v3 2/3] x86/MCE/AMD: Don't report L1 BTB MCA errors on some Family 17h models
Date: Fri, 22 Mar 2019 21:55:00 +0100	[thread overview]
Message-ID: <20190322205500.GP12472@zn.tnic> (raw)
In-Reply-To: <bbcce693-496e-0ab9-f01e-66bc67347715@amd.com>

On Fri, Mar 22, 2019 at 08:37:08PM +0000, Ghannam, Yazen wrote:
> Sorry, I forgot to mention this. I went with "filter_mce_amd" because
> amd_filter_mce() is already defined in edac/mce_amd.c and there was
> a conflict when building. Is there another way to avoid these naming
> conflicts?

Yuck, we're clearly filtering too much. :)

So let's rename that amd_filter_mce() to something else since it is
static and only used in that file. Maybe something like

        if (ignore_mce(m))
                return NOTIFY_STOP;

so that we can keep the "filter" notion all reserved to the core MCA
code and there's no confusion.

And then amd_filter_mce() is free to be used in the core code.

Thx.

-- 
Regards/Gruss,
    Boris.

Good mailing practices for 400: avoid top-posting and trim the reply.

  reply	other threads:[~2019-03-22 20:55 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-03-22 20:28 [PATCH v3 1/3] x86/MCE: Add function to allow filtering of MCA errors Ghannam, Yazen
2019-03-22 20:28 ` [PATCH v3 2/3] x86/MCE/AMD: Don't report L1 BTB MCA errors on some Family 17h models Ghannam, Yazen
2019-03-22 20:37   ` Ghannam, Yazen
2019-03-22 20:55     ` Borislav Petkov [this message]
2019-03-22 21:35       ` Ghannam, Yazen
2019-03-22 22:20         ` Borislav Petkov
2019-03-22 20:29 ` [PATCH v3 3/3] x86/MCE: Group AMD function prototypes in <asm/mce.h> Ghannam, Yazen
2019-03-24 10:28   ` [tip:ras/core] " tip-bot for Yazen Ghannam

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190322205500.GP12472@zn.tnic \
    --to=bp@alien8.de \
    --cc=Yazen.Ghannam@amd.com \
    --cc=clemej@gmail.com \
    --cc=linux-edac@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rafal@milecki.pl \
    --cc=tony.luck@intel.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox