From: Oded Gabbay <oded.gabbay@gmail.com>
To: gregkh@linuxfoundation.org
Cc: linux-kernel@vger.kernel.org
Subject: [git pull] habanalabs next second pull for 5.2
Date: Fri, 3 May 2019 10:36:21 +0300 [thread overview]
Message-ID: <20190503073621.GA6992@ogabbay-VM> (raw)
Hi Greg,
This is the second pull request of habanalabs driver for kernel 5.2.
As the tag describes, all of the changes are either bug fixes or simple
re-factoring of existing code, so they should all be relatively low-risk.
Thanks,
Oded
The following changes since commit 78e6427b4e7b017951785982f7f97cf64e2d624b:
coresight: funnel: Support static funnel (2019-05-02 19:12:21 +0200)
are available in the Git repository at:
git://people.freedesktop.org/~gabbayo/linux tags/misc-habanalabs-next-2019-05-03
for you to fetch changes up to 9f832fda79eb6e4f8ebde8d77eb442b95bf6b08a:
habanalabs: Update CPU DMA memory label name (2019-05-02 15:37:19 +0300)
----------------------------------------------------------------
This tag contains further changes for kernel 5.2.
The changes are either bug fixes or simple re-factoring of existing code.
The notable changes are:
- Add missing fields in the bmon structure that is passed in the debug
IOCTL when the user wants to configure the bus monitor.
- Use the dedicated device-CPU accessible memory pool for all host memory
allocations that are accessible directly by the embedded CPU. This is
needed to enforce certain restrictions we have due to the embedded CPU's
architecture.
- Manipulate DMA addresses only inside ASIC-specific files. This is needed
to better support future ASICs code.
Other minor changes include:
- Move pr_fmt() to c files to avoid dependency in include order.
- Remove call to CS parsing function for workloads that originates from
the driver and remove dead code as a result from this change.
- Update names of structure members and labels to better reflect their
usage.
- When moving the dram PCI bar aperture, return the old aperture address
range instead of error code. This will allow us to restore the old
address range in a simpler fashion.
----------------------------------------------------------------
Dalit Ben Zoor (4):
habanalabs: remove call to cs_parser()
habanalabs: remove redundant member from parser struct
habanalabs: remove condition that is always true
habanalabs: increase timeout if working with simulator
Oded Gabbay (6):
habanalabs: re-factor goya_parse_cb_no_ext_queue()
uapi/habanalabs: add missing fields in bmon params
habanalabs: use ASIC functions interface for rreg/wreg
habanalabs: rename restore to ctx_switch when appropriate
habanalabs: return old dram bar address upon change
habanalabs: rename functions to improve code readability
Tomer Tayar (5):
habanalabs: Cancel pr_fmt() definition dependency on includes order
habanalabs: Use single pool for CPU accessible host memory
habanalabs: Manipulate DMA addresses in ASIC functions
habanalabs: Update CPU DMA pool label name
habanalabs: Update CPU DMA memory label name
drivers/misc/habanalabs/command_buffer.c | 6 +-
drivers/misc/habanalabs/command_submission.c | 17 +-
drivers/misc/habanalabs/context.c | 4 +-
drivers/misc/habanalabs/device.c | 16 +-
drivers/misc/habanalabs/firmware_if.c | 7 +-
drivers/misc/habanalabs/goya/goya.c | 347 +++++++++++++-------------
drivers/misc/habanalabs/goya/goyaP.h | 40 ++-
drivers/misc/habanalabs/goya/goya_coresight.c | 16 +-
drivers/misc/habanalabs/habanalabs.h | 116 +++++----
drivers/misc/habanalabs/habanalabs_drv.c | 2 +
drivers/misc/habanalabs/hw_queue.c | 46 ++--
drivers/misc/habanalabs/include/armcp_if.h | 8 -
drivers/misc/habanalabs/irq.c | 14 +-
drivers/misc/habanalabs/memory.c | 4 -
drivers/misc/habanalabs/pci.c | 16 +-
include/uapi/misc/habanalabs.h | 9 +-
16 files changed, 368 insertions(+), 300 deletions(-)
next reply other threads:[~2019-05-03 7:36 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-05-03 7:36 Oded Gabbay [this message]
2019-05-03 7:51 ` [git pull] habanalabs next second pull for 5.2 Greg KH
2019-05-03 7:53 ` Oded Gabbay
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20190503073621.GA6992@ogabbay-VM \
--to=oded.gabbay@gmail.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox