From: Jiri Olsa <jolsa@redhat.com>
To: Adrian Hunter <adrian.hunter@intel.com>
Cc: Peter Zijlstra <peterz@infradead.org>,
Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
"H . Peter Anvin" <hpa@zytor.com>,
x86@kernel.org, Mark Rutland <mark.rutland@arm.com>,
Alexander Shishkin <alexander.shishkin@linux.intel.com>,
Mathieu Poirier <mathieu.poirier@linaro.org>,
Leo Yan <leo.yan@linaro.org>,
Arnaldo Carvalho de Melo <acme@kernel.org>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH RFC 3/6] perf dso: Add dso__data_write_cache_addr()
Date: Mon, 28 Oct 2019 16:45:03 +0100 [thread overview]
Message-ID: <20191028154503.GB15449@krava> (raw)
In-Reply-To: <20191025130000.13032-4-adrian.hunter@intel.com>
On Fri, Oct 25, 2019 at 03:59:57PM +0300, Adrian Hunter wrote:
SNIP
>
> -static ssize_t data_read_offset(struct dso *dso, struct machine *machine,
> - u64 offset, u8 *data, ssize_t size)
> +static ssize_t data_read_write_offset(struct dso *dso, struct machine *machine,
> + u64 offset, u8 *data, ssize_t size,
> + bool out)
> {
> if (dso__data_file_size(dso, machine))
> return -1;
> @@ -1034,7 +1037,7 @@ static ssize_t data_read_offset(struct dso *dso, struct machine *machine,
> if (offset + size < offset)
> return -1;
>
> - return cached_read(dso, machine, offset, data, size);
> + return cached_io(dso, machine, offset, data, size, out);
you renamed the function as _read_write_ so the bool choosing
the opration should be named either read or write.. I had to
go all the way down to find out what 'out' means ;-)
jirka
next prev parent reply other threads:[~2019-10-28 15:45 UTC|newest]
Thread overview: 34+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-10-25 12:59 [PATCH RFC 0/6] perf/x86: Add perf text poke event Adrian Hunter
2019-10-25 12:59 ` [PATCH RFC 1/6] " Adrian Hunter
2019-10-30 10:47 ` Leo Yan
2019-10-30 12:46 ` Peter Zijlstra
2019-10-30 14:19 ` Leo Yan
2019-10-30 15:00 ` Mike Leach
2019-10-30 16:23 ` Peter Zijlstra
2019-10-31 7:31 ` Leo Yan
2019-11-01 10:04 ` Peter Zijlstra
2019-11-01 10:09 ` Peter Zijlstra
2019-11-04 2:23 ` Leo Yan
2019-11-08 15:05 ` Leo Yan
2019-11-11 14:46 ` Peter Zijlstra
2019-11-11 15:39 ` Will Deacon
2019-11-11 16:05 ` Peter Zijlstra
2019-11-11 17:29 ` Will Deacon
2019-11-11 20:32 ` Peter Zijlstra
[not found] ` <CAJ9a7VgZH7g=rFDpKf=FzEcyBVLS_WjqbrqtRnjOi7WOY4st+w@mail.gmail.com>
2019-11-01 10:06 ` Peter Zijlstra
2019-11-04 10:40 ` Peter Zijlstra
2019-11-04 12:32 ` Adrian Hunter
2019-10-25 12:59 ` [PATCH RFC 2/6] perf dso: Refactor dso_cache__read() Adrian Hunter
2019-10-25 14:54 ` Arnaldo Carvalho de Melo
2019-10-28 15:39 ` Jiri Olsa
2019-10-29 9:19 ` Adrian Hunter
2019-11-12 11:18 ` [tip: perf/core] " tip-bot2 for Adrian Hunter
2019-10-25 12:59 ` [PATCH RFC 3/6] perf dso: Add dso__data_write_cache_addr() Adrian Hunter
2019-10-28 15:45 ` Jiri Olsa [this message]
2019-10-29 9:20 ` Adrian Hunter
2019-11-12 11:18 ` [tip: perf/core] " tip-bot2 for Adrian Hunter
2019-10-25 12:59 ` [PATCH RFC 4/6] perf tools: Add support for PERF_RECORD_TEXT_POKE Adrian Hunter
2019-10-25 12:59 ` [PATCH RFC 5/6] perf auxtrace: Add auxtrace_cache__remove() Adrian Hunter
2019-10-25 14:48 ` Arnaldo Carvalho de Melo
2019-11-12 11:18 ` [tip: perf/core] " tip-bot2 for Adrian Hunter
2019-10-25 13:00 ` [PATCH RFC 6/6] perf intel-pt: Add support for text poke events Adrian Hunter
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20191028154503.GB15449@krava \
--to=jolsa@redhat.com \
--cc=acme@kernel.org \
--cc=adrian.hunter@intel.com \
--cc=alexander.shishkin@linux.intel.com \
--cc=bp@alien8.de \
--cc=hpa@zytor.com \
--cc=leo.yan@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mark.rutland@arm.com \
--cc=mathieu.poirier@linaro.org \
--cc=mingo@redhat.com \
--cc=peterz@infradead.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox