The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Vinod Koul <vkoul@kernel.org>
To: Elliot Berman <eberman@codeaurora.org>
Cc: bjorn.andersson@linaro.org, saiprakash.ranjan@codeaurora.org,
	agross@kernel.org, tsoni@codeaurora.org, sidgup@codeaurora.org,
	psodagud@codeaurora.org, linux-arm-msm@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 03/17] firmware: qcom_scm: Order functions, definitions by service/command
Date: Thu, 7 Nov 2019 22:20:58 +0530	[thread overview]
Message-ID: <20191107165058.GP952516@vkoul-mobl> (raw)
In-Reply-To: <1572917256-24205-4-git-send-email-eberman@codeaurora.org>

On 04-11-19, 17:27, Elliot Berman wrote:
> Definitions throughout qcom_scm are loosely grouped and loosely ordered.
> Sort all the functions/definitions by service ID/command ID to improve
> sanity when needing to add new functionality to this driver.

Reviewed-by: Vinod Koul <vkoul@kernel.org>

-- 
~Vinod

  parent reply	other threads:[~2019-11-07 16:51 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-11-05  1:27 [PATCH 00/17] Restructure, improve target support for qcom_scm driver Elliot Berman
2019-11-05  1:27 ` [PATCH 01/17] firmware: qcom_scm: Rename macros and structures Elliot Berman
2019-11-07 16:22   ` Vinod Koul
2019-11-05  1:27 ` [PATCH 02/17] firmware: qcom_scm: Apply consistent naming scheme to command IDs Elliot Berman
2019-11-06  6:02   ` Bjorn Andersson
2019-11-07 16:42   ` Vinod Koul
2019-11-05  1:27 ` [PATCH 03/17] firmware: qcom_scm: Order functions, definitions by service/command Elliot Berman
2019-11-06  6:05   ` Bjorn Andersson
2019-11-07 16:50   ` Vinod Koul [this message]
2019-11-08 22:03   ` Bjorn Andersson
2019-11-05  1:27 ` [PATCH 04/17] firmware: qcom_scm: Remove unused qcom_scm_get_version Elliot Berman
2019-11-06  6:06   ` Bjorn Andersson
2019-11-08  4:36   ` Vinod Koul
2019-11-05  1:27 ` [PATCH 05/17] firmware: qcom_scm-64: Move svc/cmd/owner into qcom_scm_desc Elliot Berman
2019-11-08  6:04   ` Vinod Koul
2019-11-05  1:27 ` [PATCH 06/17] firmware: qcom_scm-64: Add SCM results to descriptor Elliot Berman
2019-11-08  6:09   ` Vinod Koul
2019-11-05  1:27 ` [PATCH 07/17] firmware: qcom_scm-64: Remove qcom_scm_call_do_smccc Elliot Berman
2019-11-05  1:27 ` [PATCH 08/17] firmware: qcom_scm-64: Move SMC register filling to qcom_scm_call_smccc Elliot Berman
2019-11-05  1:27 ` [PATCH 09/17] firmware: qcom_scm-64: Improve SMC convention detection Elliot Berman
2019-11-07 19:18   ` Bjorn Andersson
2019-11-07 20:20     ` eberman
2019-11-07 23:44       ` Bjorn Andersson
2019-11-05  1:27 ` [PATCH 10/17] firmware: qcom_scm-32: Use SMC arch wrappers Elliot Berman
2019-11-08  0:05   ` Bjorn Andersson
2019-11-05  1:27 ` [PATCH 11/17] firmware: qcom_scm-32: Use qcom_scm_desc in non-atomic calls Elliot Berman
2019-11-05  1:27 ` [PATCH 12/17] firmware: qcom_scm-32: Move SMCCC register filling to qcom_scm_call Elliot Berman
2019-11-05  1:27 ` [PATCH 13/17] firmware: qcom_scm-32: Create common legacy atomic call Elliot Berman
2019-11-05  1:27 ` [PATCH 14/17] firmware: qcom_scm-32: Add device argument to atomic calls Elliot Berman
2019-11-05  1:27 ` [PATCH 15/17] firmware: qcom_scm: Merge legacy and SMCCC conventions Elliot Berman
2019-11-05  1:27 ` [PATCH 16/17] firmware: qcom_scm: Enable legacy calling convention in qcom_scm-64.c Elliot Berman
2019-11-05  1:27 ` [PATCH 17/17] firmware: qcom_scm: Rename -64 -> -smc, remove -32 Elliot Berman
2019-11-08  0:20   ` Bjorn Andersson
2019-11-05  2:14 ` [PATCH 00/17] Restructure, improve target support for qcom_scm driver Sai Prakash Ranjan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20191107165058.GP952516@vkoul-mobl \
    --to=vkoul@kernel.org \
    --cc=agross@kernel.org \
    --cc=bjorn.andersson@linaro.org \
    --cc=eberman@codeaurora.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=psodagud@codeaurora.org \
    --cc=saiprakash.ranjan@codeaurora.org \
    --cc=sidgup@codeaurora.org \
    --cc=tsoni@codeaurora.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox