The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Ira Weiny <ira.weiny@intel.com>
To: Jan Kara <jack@suse.cz>
Cc: linux-kernel@vger.kernel.org, linux-xfs@vger.kernel.org,
	"Darrick J. Wong" <darrick.wong@oracle.com>,
	Al Viro <viro@zeniv.linux.org.uk>,
	Dan Williams <dan.j.williams@intel.com>,
	Dave Chinner <david@fromorbit.com>,
	Christoph Hellwig <hch@lst.de>,
	"Theodore Y. Ts'o" <tytso@mit.edu>,
	Jeff Moyer <jmoyer@redhat.com>,
	linux-ext4@vger.kernel.org, linux-fsdevel@vger.kernel.org
Subject: Re: [PATCH V9 09/11] fs: Introduce DCACHE_DONTCACHE
Date: Wed, 22 Apr 2020 08:19:20 -0700	[thread overview]
Message-ID: <20200422151920.GI3372712@iweiny-DESK2.sc.intel.com> (raw)
In-Reply-To: <20200422084647.GC8775@quack2.suse.cz>

On Wed, Apr 22, 2020 at 10:46:47AM +0200, Jan Kara wrote:
> On Tue 21-04-20 12:17:51, ira.weiny@intel.com wrote:
> > From: Ira Weiny <ira.weiny@intel.com>
> > 
> > DCACHE_DONTCACHE indicates a dentry should not be cached on final
> > dput().
> > 
> > Also add a helper function to mark DCACHE_DONTCACHE on all dentries
> > pointing to a specific inode when that inode is being set I_DONTCACHE.
> > 
> > This facilitates dropping dentry references to inodes sooner which
> > require eviction to swap S_DAX mode.
> > 
> > Cc: Al Viro <viro@zeniv.linux.org.uk>
> > Signed-off-by: Ira Weiny <ira.weiny@intel.com>
> > 
> > ---
> > Changes from V8:
> > 	Update commit message
> > 	Use mark_inode_dontcache in XFS
> > 	Fix locking...  can't use rcu here.
> > 	Change name to mark_inode_dontcache
> > ---
> >  fs/dcache.c            |  4 ++++
> >  fs/inode.c             | 15 +++++++++++++++
> >  fs/xfs/xfs_icache.c    |  2 +-
> >  include/linux/dcache.h |  2 ++
> >  include/linux/fs.h     |  1 +
> >  5 files changed, 23 insertions(+), 1 deletion(-)
> > 
> > diff --git a/fs/dcache.c b/fs/dcache.c
> > index b280e07e162b..0030fabab2c4 100644
> > --- a/fs/dcache.c
> > +++ b/fs/dcache.c
> > @@ -647,6 +647,10 @@ static inline bool retain_dentry(struct dentry *dentry)
> >  		if (dentry->d_op->d_delete(dentry))
> >  			return false;
> >  	}
> > +
> > +	if (unlikely(dentry->d_flags & DCACHE_DONTCACHE))
> > +		return false;
> > +
> >  	/* retain; LRU fodder */
> >  	dentry->d_lockref.count--;
> >  	if (unlikely(!(dentry->d_flags & DCACHE_LRU_LIST)))
> > diff --git a/fs/inode.c b/fs/inode.c
> > index 93d9252a00ab..da7f3c4926cd 100644
> > --- a/fs/inode.c
> > +++ b/fs/inode.c
> > @@ -1526,6 +1526,21 @@ int generic_delete_inode(struct inode *inode)
> >  }
> >  EXPORT_SYMBOL(generic_delete_inode);
> >  
> > +void mark_inode_dontcache(struct inode *inode)
> > +{
> > +	struct dentry *de;
> > +
> > +	spin_lock(&inode->i_lock);
> > +	hlist_for_each_entry(de, &inode->i_dentry, d_u.d_alias) {
> > +		spin_lock(&de->d_lock);
> > +		de->d_flags |= DCACHE_DONTCACHE;
> > +		spin_unlock(&de->d_lock);
> > +	}
> > +	spin_unlock(&inode->i_lock);
> > +	inode->i_state |= I_DONTCACHE;
> 
> Modification of i_state should happen under i_lock.

Done.

> 
> > +}
> > +EXPORT_SYMBOL(mark_inode_dontcache);
> > +
> >  /*
> >   * Called when we're dropping the last reference
> >   * to an inode.
> > diff --git a/fs/xfs/xfs_icache.c b/fs/xfs/xfs_icache.c
> > index de76f7f60695..3c8f44477804 100644
> > --- a/fs/xfs/xfs_icache.c
> > +++ b/fs/xfs/xfs_icache.c
> > @@ -559,7 +559,7 @@ xfs_iget_cache_miss(
> >  	 */
> >  	iflags = XFS_INEW;
> >  	if (flags & XFS_IGET_DONTCACHE)
> > -		VFS_I(ip)->i_state |= I_DONTCACHE;
> > +		mark_inode_dontcache(VFS_I(ip));
> 
> And I know here modification of i_state didn't happen under i_lock but
> that's a special case because we are just instantiating the inode so it was
> not a real issue.

Thanks!
Ira

> 
> 								Honza
> -- 
> Jan Kara <jack@suse.com>
> SUSE Labs, CR

  reply	other threads:[~2020-04-22 15:19 UTC|newest]

Thread overview: 36+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-21 19:17 [PATCH V9 00/11] XFS - Enable per-file/per-directory DAX operations V9 ira.weiny
2020-04-21 19:17 ` [PATCH V9 01/11] fs/xfs: Remove unnecessary initialization of i_rwsem ira.weiny
2020-04-21 19:17 ` [PATCH V9 02/11] fs: Remove unneeded IS_DAX() check in io_is_direct() ira.weiny
2020-04-21 20:13   ` Darrick J. Wong
2020-04-22  8:37   ` Jan Kara
2020-04-21 19:17 ` [PATCH V9 03/11] fs/stat: Define DAX statx attribute ira.weiny
2020-04-22 16:29   ` Darrick J. Wong
2020-04-22 18:51     ` Ira Weiny
2020-04-23  8:24       ` Jan Kara
2020-04-21 19:17 ` [PATCH V9 04/11] fs/xfs: Change XFS_MOUNT_DAX to XFS_MOUNT_DAX_ALWAYS ira.weiny
2020-04-21 19:17 ` [PATCH V9 05/11] fs/xfs: Make DAX mount option a tri-state ira.weiny
2020-04-21 20:16   ` Darrick J. Wong
2020-04-21 21:06     ` Ira Weiny
2020-04-21 19:17 ` [PATCH V9 06/11] fs/xfs: Create function xfs_inode_should_enable_dax() ira.weiny
2020-04-21 19:17 ` [PATCH V9 07/11] fs/xfs: Combine xfs_diflags_to_linux() and xfs_diflags_to_iflags() ira.weiny
2020-04-21 19:17 ` [PATCH V9 08/11] fs: Lift XFS_IDONTCACNE to the VFS layer ira.weiny
2020-04-21 20:23   ` Darrick J. Wong
2020-04-21 21:12     ` Ira Weiny
2020-04-22  8:41   ` Jan Kara
2020-04-21 19:17 ` [PATCH V9 09/11] fs: Introduce DCACHE_DONTCACHE ira.weiny
2020-04-21 20:25   ` Darrick J. Wong
2020-04-21 21:15     ` Ira Weiny
2020-04-22  2:34     ` Al Viro
2020-04-22  3:46       ` Ira Weiny
2020-04-22  8:46   ` Jan Kara
2020-04-22 15:19     ` Ira Weiny [this message]
2020-04-21 19:17 ` [PATCH V9 10/11] fs/xfs: Update xfs_ioctl_setattr_dax_invalidate() ira.weiny
2020-04-21 20:31   ` Darrick J. Wong
2020-04-21 21:30     ` Dave Chinner
2020-04-21 21:43       ` Ira Weiny
2020-04-21 23:13         ` Dave Chinner
2020-04-21 23:24           ` Ira Weiny
2020-04-21 19:17 ` [PATCH V9 11/11] Documentation/dax: Update Usage section ira.weiny
2020-04-21 20:34   ` Darrick J. Wong
2020-04-21 21:49     ` Ira Weiny
2020-04-22  9:47   ` Jan Kara

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200422151920.GI3372712@iweiny-DESK2.sc.intel.com \
    --to=ira.weiny@intel.com \
    --cc=dan.j.williams@intel.com \
    --cc=darrick.wong@oracle.com \
    --cc=david@fromorbit.com \
    --cc=hch@lst.de \
    --cc=jack@suse.cz \
    --cc=jmoyer@redhat.com \
    --cc=linux-ext4@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-xfs@vger.kernel.org \
    --cc=tytso@mit.edu \
    --cc=viro@zeniv.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox