The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Wang YanQing <udknight@gmail.com>
To: Markus Elfring <Markus.Elfring@web.de>
Cc: Joe Perches <joe@perches.com>, Andy Whitcroft <apw@canonical.com>,
	kernel-janitors@vger.kernel.org, linux-kernel@vger.kernel.org,
	Alexei Starovoitov <alexei.starovoitov@gmail.com>,
	Matteo Croce <mcroce@redhat.com>
Subject: Re: [PATCH v3] checkpatch: add dedicated checker for 'Fixes:' tag
Date: Wed, 29 Apr 2020 00:18:31 +0800	[thread overview]
Message-ID: <20200428161831.GB30042@udknight> (raw)
In-Reply-To: <38e1a926-53a6-bda6-cb07-2614f4c682ba@web.de>

On Tue, Apr 28, 2020 at 12:52:59PM +0200, Markus Elfring wrote:
> > And there is no 'Fixes:' tag format checker in checkpatch
> 
> I have taken another look at corresponding implementation details.
> Will programming challenges get any more attention?
> 
> 
> > to check the commit id length too,
> 
> The mentioned script contains the following information.
> https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/tree/scripts/checkpatch.pl?id=b240f960afb900e59112ebcfa5a759bb0a85a14e#n2818
> 
> # Check for git id commit length and improperly formed commit descriptions
> 
> 
> > so let's add dedicated checker to check these conditions for 'Fixes:' tag.
> 
> How do you think about to reconsider the usage of the word “checker”
> at specific places?

Yes, I will use the word "check" only in later version.

> 
> 
> > +		    my $id = '0123456789ab';
> > +		    my $orig_desc = "commit description";
> 
> * Do you try to extend the existing software analysis approach “GIT_COMMIT_ID”?
> 
> * Would you like to avoid the development of duplicate Perl code?

Fixes: lines don't need to have a "commit" prefix before the commit id, the description
in normal commit id could across multiple lines, and we don't need to consider the
$commit_log_possible_stack_dump for 'Fixes:' tag line. I mean it will make the GIT_COMMIT_ID
code become harder to read and maintain.

> 
> Regards,
> Markus

  reply	other threads:[~2020-04-29 14:53 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-28  2:02 [PATCH v3] checkpatch: add dedicated checker for 'Fixes:' tag Wang YanQing
2020-04-28  6:21 ` Markus Elfring
2020-04-28 14:06   ` Wang YanQing
2020-04-28 14:54     ` [v3] " Markus Elfring
2020-04-28 10:52 ` [PATCH v3] " Markus Elfring
2020-04-28 16:18   ` Wang YanQing [this message]
2020-04-29 15:18     ` [v3] " Markus Elfring
2020-04-28 16:10 ` [PATCH v3] " Joe Perches
2020-04-28 23:17   ` Joe Perches
2020-04-29  6:45     ` [v3] " Markus Elfring

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200428161831.GB30042@udknight \
    --to=udknight@gmail.com \
    --cc=Markus.Elfring@web.de \
    --cc=alexei.starovoitov@gmail.com \
    --cc=apw@canonical.com \
    --cc=joe@perches.com \
    --cc=kernel-janitors@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mcroce@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox