From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-11.4 required=3.0 tests=BAYES_00,DKIMWL_WL_MED, DKIM_SIGNED,DKIM_VALID,DKIM_VALID_AU,HEADER_FROM_DIFFERENT_DOMAINS, MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS,USER_IN_DEF_DKIM_WL autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 64CD9C43464 for ; Fri, 18 Sep 2020 09:36:40 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id F149021973 for ; Fri, 18 Sep 2020 09:36:39 +0000 (UTC) Authentication-Results: mail.kernel.org; dkim=pass (2048-bit key) header.d=google.com header.i=@google.com header.b="QxoMVdbJ" Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1726629AbgIRJgj (ORCPT ); Fri, 18 Sep 2020 05:36:39 -0400 Received: from lindbergh.monkeyblade.net ([23.128.96.19]:38898 "EHLO lindbergh.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1726109AbgIRJgi (ORCPT ); Fri, 18 Sep 2020 05:36:38 -0400 Received: from mail-io1-xd44.google.com (mail-io1-xd44.google.com [IPv6:2607:f8b0:4864:20::d44]) by lindbergh.monkeyblade.net (Postfix) with ESMTPS id 3643FC06174A for ; Fri, 18 Sep 2020 02:36:38 -0700 (PDT) Received: by mail-io1-xd44.google.com with SMTP id u6so6111046iow.9 for ; Fri, 18 Sep 2020 02:36:38 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=google.com; s=20161025; h=date:from:to:cc:subject:message-id:references:mime-version :content-disposition:in-reply-to; bh=ofKvXByFD2eTX9fI7pI8+9B6s6meAkUWiXIy9ZfC+QY=; b=QxoMVdbJPeqrTlkx5f/73dhtxLUkgkyN+VruQyO1/DVhy0/tFaAQ+h9OKo3iWOdoAm //wddD5q8p90+WGg+WpJ94zSSO7WSg8M7myvdhtMW/wPMxjbFaUz/VVwVUtohFRSSNzk 1vP3YbOMqaWT/Y8Qpd4XoChQlpnn/p4KVxLPWfl4+D4iZGVaorta3oTQbrw19jtEzHcO aSM/mYkvKe/uZTa17hL1VogxRTEkxyUKkzzpjeZ8MZk1SbbnJ5s5a0WQmGjIpQMkQNJV +bXdtgXRwCXPz/37ckHEp0MSHu3ks74ZlOBL4iTA1vT8q1rReyNciaVTNptTCYHYonx5 GR3w== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:date:from:to:cc:subject:message-id:references :mime-version:content-disposition:in-reply-to; bh=ofKvXByFD2eTX9fI7pI8+9B6s6meAkUWiXIy9ZfC+QY=; b=Ghz9n0vnkfptPAl2bHujULhSdkMsfnGWGc1WR/ig0vFNsDED1wKWaOlK5dR4yZOYI/ 0ItCxAfuAGtySv4IcUJ2yVGkkEUogbRHlhNjPYLY53REqLMbIVsR0cGbw0BNoOmWH4Au oYBWzIVCRNZQ16+XbTZQmy4rHMktH+6JSDzgroxhW+cd11vfXnvrrfqMhztei6LBY+PJ n4Nz0sR3mGIXMQjNtHZkUVIN+LdhNyJQAA+VZrfzHgNQVLnwdxKqDDUZ+8VGVFPziA+D SKW8W0KgylS/LTXF/CjHOy7cg7yoIgWraeJRb6409qHpyT3jv42mCJNEo3s0i+WiFntW EOxA== X-Gm-Message-State: AOAM5311+cTOfYXvbZNcLvh2CADoJJ3C9lrlUdjrBcmtUrOuLrhxGWtk DsMUWkHTrVYYvovPV6uzE2GWtg== X-Google-Smtp-Source: ABdhPJwAlkZO19slkH+E5oDOsW1m+REbN+IIcJ/oxJ2gQ8D4+tsQbVUGfeR7TiaIlDVMQVppOKvA1g== X-Received: by 2002:a6b:590c:: with SMTP id n12mr27341321iob.25.1600421797222; Fri, 18 Sep 2020 02:36:37 -0700 (PDT) Received: from google.com ([2620:15c:183:200:7220:84ff:fe09:2d90]) by smtp.gmail.com with ESMTPSA id x3sm1295974ilq.81.2020.09.18.02.36.35 (version=TLS1_3 cipher=TLS_AES_256_GCM_SHA384 bits=256/256); Fri, 18 Sep 2020 02:36:36 -0700 (PDT) Date: Fri, 18 Sep 2020 03:36:31 -0600 From: Yu Zhao To: Michal Hocko Cc: Andrew Morton , Alex Shi , Steven Rostedt , Ingo Molnar , Johannes Weiner , Vladimir Davydov , Roman Gushchin , Shakeel Butt , Chris Down , Yafang Shao , Vlastimil Babka , Huang Ying , Pankaj Gupta , Matthew Wilcox , Konstantin Khlebnikov , Minchan Kim , Jaewon Kim , cgroups@vger.kernel.org, linux-mm@kvack.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH 00/13] mm: clean up some lru related pieces Message-ID: <20200918093631.GA987554@google.com> References: <20200918030051.650890-1-yuzhao@google.com> <20200918074549.GG28827@dhcp22.suse.cz> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20200918074549.GG28827@dhcp22.suse.cz> Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, Sep 18, 2020 at 09:45:49AM +0200, Michal Hocko wrote: > On Thu 17-09-20 21:00:38, Yu Zhao wrote: > > Hi Andrew, > > > > I see you have taken this: > > mm: use add_page_to_lru_list()/page_lru()/page_off_lru() > > Do you mind dropping it? > > > > Michal asked to do a bit of additional work. So I thought I probably > > should create a series to do more cleanups I've been meaning to. > > > > This series contains the change in the patch above and goes a few > > more steps farther. It's intended to improve readability and should > > not have any performance impacts. There are minor behavior changes in > > terms of debugging and error reporting, which I have all highlighted > > in the individual patches. All patches were properly tested on 5.8 > > running Chrome OS, with various debug options turned on. > > > > Michal, > > > > Do you mind taking a looking at the entire series? > > I have stopped at patch 3 as all patches until then are really missing > any justification. What is the point for all this to be done? The code > is far from trivial and just shifting around sounds like a risk. You are I appreciate your caution, and if you let me know what exactly your concerns are, we could probably work them out together. > removing ~50 LOC which is always nice but I am not sure the resulting > code is better maintainble or easier to read and understand. Just > consider __ClearPageLRU moving to page_off_lru patch. What is the > additional value of having the flag moved and burry it into a function > to have even more side effects? I found the way how __ClearPageLRU is Mind elaborating the side effects? > nicely close to removing it from LRU easier to follow. This is likely > subjective and other might think differently but as it is not clear what > is your actual goal here it is hard to judge pros and cons. I like this specific example from patch 3. Here is what it does: we have three places using the same boilerplate, i.e., page_off_lru() + __ClearPageLRU(), the patch moves __ClearPageLRU() into page_off_lru(), which already does __ClearPageActive() and __ClearPageUnevictable(). Later on, we rename page_off_lru() to __clear_page_lru_flags() (patch 8). Its point seems quite clear to me. Why would *anybody* want to use two helper functions *repeatedly* when the job can be done with just one? Nobody is paid by the number of lines they add, right? :) And for that matter, why would anybody want any boilerplate to be open coded from the same group of helper functions arranged in various ways? I don't think the answer is subjective, but I don't expect everybody to agree with me. Now back to your general question: what's the point of this series? Readability -- less error prone and easier to maintain. This series consolidate open-coded boilerplate like the following in many places. Take lru_lazyfree_fn() as an example: - bool active = PageActive(page); int nr_pages = thp_nr_pages(page); - del_page_from_lru_list(page, lruvec, - LRU_INACTIVE_ANON + active); + del_page_from_lru_list(page, lruvec); ClearPageActive(page); ClearPageReferenced(page); ClearPageSwapBacked(page); - add_page_to_lru_list(page, lruvec, LRU_INACTIVE_FILE); + add_page_to_lru_list(page, lruvec); I hope this helps, but if it doesn't, I'd be more than happy to have more discussions on the details. And not that I don't appreciate your review, but please be more specific than 'sounds like a risk' or 'have even more side effects' so I can address your concerns effectively.