From: Michal Hocko <mhocko@suse.com>
To: Yu Zhao <yuzhao@google.com>
Cc: Andrew Morton <akpm@linux-foundation.org>,
Alex Shi <alex.shi@linux.alibaba.com>,
Steven Rostedt <rostedt@goodmis.org>,
Ingo Molnar <mingo@redhat.com>,
Johannes Weiner <hannes@cmpxchg.org>,
Vladimir Davydov <vdavydov.dev@gmail.com>,
Roman Gushchin <guro@fb.com>, Shakeel Butt <shakeelb@google.com>,
Chris Down <chris@chrisdown.name>,
Yafang Shao <laoar.shao@gmail.com>,
Vlastimil Babka <vbabka@suse.cz>,
Huang Ying <ying.huang@intel.com>,
Pankaj Gupta <pankaj.gupta.linux@gmail.com>,
Matthew Wilcox <willy@infradead.org>,
Konstantin Khlebnikov <koct9i@gmail.com>,
Minchan Kim <minchan@kernel.org>,
Jaewon Kim <jaewon31.kim@samsung.com>,
cgroups@vger.kernel.org, linux-mm@kvack.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 02/13] mm: use page_off_lru()
Date: Mon, 21 Sep 2020 13:16:48 +0200 [thread overview]
Message-ID: <20200921111648.GI12990@dhcp22.suse.cz> (raw)
In-Reply-To: <20200918185358.GA1095986@google.com>
On Fri 18-09-20 12:53:58, Yu Zhao wrote:
> On Fri, Sep 18, 2020 at 01:09:14PM +0200, Michal Hocko wrote:
> > On Fri 18-09-20 04:27:13, Yu Zhao wrote:
> > > On Fri, Sep 18, 2020 at 09:37:00AM +0200, Michal Hocko wrote:
> > > > On Thu 17-09-20 21:00:40, Yu Zhao wrote:
> > > > > This patch replaces the only open-coded __ClearPageActive() with
> > > > > page_off_lru(). There is no open-coded __ClearPageUnevictable()s.
> > > > >
> > > > > Before this patch, we have:
> > > > > __ClearPageActive()
> > > > > add_page_to_lru_list()
> > > > >
> > > > > After this patch, we have:
> > > > > page_off_lru()
> > > > > if PageUnevictable()
> > > > > __ClearPageUnevictable()
> > > > > else if PageActive()
> > > > > __ClearPageActive()
> > > > > add_page_to_lru_list()
> > > > >
> > > > > Checking PageUnevictable() shouldn't be a problem because these two
> > > > > flags are mutually exclusive. Leaking either will trigger bad_page().
> > > >
> > > > I am sorry but the changelog is really hard to grasp. What are you
> > > > trying to achieve, why and why it is safe. This should be a general
> > > > outline for any patch. I have already commented on the previous patch
> > > > and asked you for the explanation why removing __ClearPageActive from
> > > > this path is desirable and safe. I have specifically asked to clarify
> > > > the compound page situation as that is using its oen destructor in the
> > > > freeing path and that might result in page_off_lru to be not called.
> > >
> > > Haven't I explained we are NOT removing __ClearPageActive()? Is my
> > > notion of the code structure above confusing you? Or 'open-coded'
> > > could mean different things?
> >
> > Please read through my reply carefuly. I am not saying what you are
> > doing is wrong. I am expressing a lack of justification which is the
> > case throughout this patch series. You do not explain why we need it and
> > why reviewers should spend time on this. Because the review is not as
> > trivial as looking at the diff.
>
> I appreciate your time. But if you are looking for some grand
> justification, I'm afraid I won't be able to give one, because, as it's
> titled, this is just a series of cleanup patches.
You likely had some reason to do that clean up, right? What was that? An
inconcistency in handling some of the page flags when it is moved around
LRU lists? Was the code too hard to reason about? Was it error prone?
Please do not take me wrong, I am not trying to discourage you from
clean up work. There is a lot of code that would benefit from clean ups.
But it certainly helps to outline your motivation and the goal you would
like to achieve. Without that it would boil down to guessing what you
might have thought or simly moving things around without a very good
long term reason.
Thanks!
--
Michal Hocko
SUSE Labs
next prev parent reply other threads:[~2020-09-21 11:16 UTC|newest]
Thread overview: 30+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-09-18 3:00 [PATCH 00/13] mm: clean up some lru related pieces Yu Zhao
2020-09-18 3:00 ` [PATCH 01/13] mm: use add_page_to_lru_list() Yu Zhao
2020-09-18 7:32 ` Michal Hocko
2020-09-18 10:05 ` Yu Zhao
2020-09-18 3:00 ` [PATCH 02/13] mm: use page_off_lru() Yu Zhao
2020-09-18 7:37 ` Michal Hocko
2020-09-18 10:27 ` Yu Zhao
2020-09-18 11:09 ` Michal Hocko
2020-09-18 18:53 ` Yu Zhao
2020-09-21 11:16 ` Michal Hocko [this message]
2020-09-18 11:24 ` Michal Hocko
2020-09-18 3:00 ` [PATCH 03/13] mm: move __ClearPageLRU() into page_off_lru() Yu Zhao
2020-09-18 7:38 ` Michal Hocko
2020-09-18 3:00 ` [PATCH 04/13] mm: shuffle lru list addition and deletion functions Yu Zhao
2020-09-18 3:00 ` [PATCH 05/13] mm: don't pass enum lru_list to lru list addition functions Yu Zhao
2020-09-18 3:00 ` [PATCH 06/13] mm: don't pass enum lru_list to trace_mm_lru_insertion() Yu Zhao
2020-09-18 3:00 ` [PATCH 07/13] mm: don't pass enum lru_list to del_page_from_lru_list() Yu Zhao
2020-09-18 3:00 ` [PATCH 08/13] mm: rename page_off_lru() to __clear_page_lru_flags() Yu Zhao
2020-09-18 3:00 ` [PATCH 09/13] mm: inline page_lru_base_type() Yu Zhao
2020-09-18 3:00 ` [PATCH 10/13] mm: VM_BUG_ON lru page flags Yu Zhao
2020-09-18 3:00 ` [PATCH 11/13] mm: inline __update_lru_size() Yu Zhao
2020-09-18 3:00 ` [PATCH 12/13] mm: make lruvec_lru_size() static Yu Zhao
2020-09-18 3:00 ` [PATCH 13/13] mm: enlarge the int parameter of update_lru_size() Yu Zhao
2020-09-18 7:45 ` [PATCH 00/13] mm: clean up some lru related pieces Michal Hocko
2020-09-18 9:36 ` Yu Zhao
2020-09-18 20:46 ` Hugh Dickins
2020-09-18 21:01 ` Yu Zhao
2020-09-18 21:19 ` Hugh Dickins
2020-09-19 0:31 ` Alex Shi
2020-10-13 2:30 ` Hugh Dickins
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200921111648.GI12990@dhcp22.suse.cz \
--to=mhocko@suse.com \
--cc=akpm@linux-foundation.org \
--cc=alex.shi@linux.alibaba.com \
--cc=cgroups@vger.kernel.org \
--cc=chris@chrisdown.name \
--cc=guro@fb.com \
--cc=hannes@cmpxchg.org \
--cc=jaewon31.kim@samsung.com \
--cc=koct9i@gmail.com \
--cc=laoar.shao@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=minchan@kernel.org \
--cc=mingo@redhat.com \
--cc=pankaj.gupta.linux@gmail.com \
--cc=rostedt@goodmis.org \
--cc=shakeelb@google.com \
--cc=vbabka@suse.cz \
--cc=vdavydov.dev@gmail.com \
--cc=willy@infradead.org \
--cc=ying.huang@intel.com \
--cc=yuzhao@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox