From: Mathieu Poirier <mathieu.poirier@linaro.org>
To: gregkh@linuxfoundation.org
Cc: coresight@lists.linaro.org, linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org
Subject: [GIT PULL] Coresight changes for v5.17
Date: Mon, 20 Dec 2021 10:38:20 -0700 [thread overview]
Message-ID: <20211220173820.244995-1-mathieu.poirier@linaro.org> (raw)
The following changes since commit fa55b7dcdc43c1aa1ba12bca9d2dd4318c2a0dbf:
Linux 5.16-rc1 (2021-11-14 13:56:52 -0800)
are available in the Git repository at:
git@gitolite.kernel.org:pub/scm/linux/kernel/git/coresight/linux.git tags/coresight-next-v5.17
for you to fetch changes up to efa56eddf5d5c03a90abe708431f16c12c291837:
coresight: core: Fix typo in a comment (2021-12-13 11:54:07 -0700)
----------------------------------------------------------------
Coresight changes for v5.17
Hi Greg,
I'm sending this a little early due to the holiday schedule. There might be
another pull request for rc8 in January - let's see when we get there.
This pull request includes:
- A patch that uses devm_bitmap_zalloc() instead of the open-coded
equivalent.
- Work to make coresight complex configuration loadable via modules.
- Some coresight documentation updates.
Signed-off-by: Mathieu Poirier <mathieu.poirier@linaro.org>
----------------------------------------------------------------
Christophe JAILLET (1):
coresight: Use devm_bitmap_zalloc when applicable
Jason Wang (1):
coresight: core: Fix typo in a comment
Mike Leach (7):
Documentation: coresight: Fix documentation issue
coresight: configuration: Update API to introduce load owner concept
coresight: configuration: Update API to permit dynamic load/unload
coresight: syscfg: Update load API for config loadable modules
coresight: syscfg: Example CoreSight configuration loadable module
coresight: configfs: Allow configfs to activate configuration
Documentation: coresight: Update coresight configuration docs
Documentation/trace/coresight/coresight-config.rst | 78 ++++-
MAINTAINERS | 1 +
.../hwtracing/coresight/coresight-cfg-preload.c | 9 +-
drivers/hwtracing/coresight/coresight-config.h | 9 +-
drivers/hwtracing/coresight/coresight-core.c | 2 +-
drivers/hwtracing/coresight/coresight-etm4x-core.c | 11 +-
drivers/hwtracing/coresight/coresight-stm.c | 10 +-
.../coresight/coresight-syscfg-configfs.c | 87 ++++++
.../coresight/coresight-syscfg-configfs.h | 4 +
drivers/hwtracing/coresight/coresight-syscfg.c | 315 +++++++++++++++++++--
drivers/hwtracing/coresight/coresight-syscfg.h | 39 ++-
samples/Kconfig | 9 +
samples/Makefile | 1 +
samples/coresight/Makefile | 4 +
samples/coresight/coresight-cfg-sample.c | 73 +++++
15 files changed, 595 insertions(+), 57 deletions(-)
create mode 100644 samples/coresight/Makefile
create mode 100644 samples/coresight/coresight-cfg-sample.c
next reply other threads:[~2021-12-20 17:38 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-12-20 17:38 Mathieu Poirier [this message]
2021-12-21 9:09 ` [GIT PULL] Coresight changes for v5.17 Greg KH
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20211220173820.244995-1-mathieu.poirier@linaro.org \
--to=mathieu.poirier@linaro.org \
--cc=coresight@lists.linaro.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox