From: Bjorn Helgaas <helgaas@kernel.org>
To: linux-pci@vger.kernel.org, Fan Fei <ffclaire1224@gmail.com>
Cc: Lorenzo Pieralisi <lorenzo.pieralisi@arm.com>,
Rob Herring <robh@kernel.org>,
linux-kernel@vger.kernel.org,
linux-kernel-mentees@lists.linuxfoundation.org,
Shuah Khan <skhan@linuxfoundation.org>,
Bjorn Helgaas <bhelgaas@google.com>
Subject: [PATCH v2 00/23] PCI: Name structs, functions consistently
Date: Wed, 22 Dec 2021 19:10:31 -0600 [thread overview]
Message-ID: <20211223011054.1227810-1-helgaas@kernel.org> (raw)
From: Bjorn Helgaas <bhelgaas@google.com>
This is a v2 of Fan's patches, previously posted at:
https://lore.kernel.org/r/cover.1637678103.git.ffclaire1224@gmail.com
https://lore.kernel.org/r/cover.1638021831.git.ffclaire1224@gmail.com
I added a few more patches along the same lines and added driver
maintainers to the cc lists.
There should be no functional changes here at all; this is strictly to make
the drivers more consistent so it's easier to see defects and opportunities
for consolidation.
Lorenzo, if this seems OK, I propose that I merge it after all of your
branches so it doesn't get in the way of what you have pending.
This series applies on v5.16-rc1.
Bjorn Helgaas (10):
PCI: j721e: Drop pointless of_device_get_match_data() cast
PCI: j721e: Drop redundant struct device *
PCI: iproc: Rename iproc_pcie_bcma_ to iproc_bcma_pcie_
PCI: iproc: Rename iproc_pcie_pltfm_ to iproc_pltfm_pcie_
PCI: ls-gen4: Rename ls_pcie_g4 to ls_g4_pcie
PCI: microchip: Rename mc_port to mc_pcie
PCI: mt7621: Make pci_ops static
PCI: mt7621: Rename mt7621_pci_ to mt7621_pcie_
PCI: rcar-gen2: Rename rcar_pci_priv to rcar_pci
PCI: xilinx-cpm: Rename xilinx_cpm_pcie_port to xilinx_cpm_pcie
Fan Fei (13):
PCI: altera: Prefer of_device_get_match_data()
PCI: artpec6: Prefer of_device_get_match_data()
PCI: cadence: Prefer of_device_get_match_data()
PCI: designware-plat: Prefer of_device_get_match_data()
PCI: dra7xx: Prefer of_device_get_match_data()
PCI: keystone: Prefer of_device_get_match_data()
PCI: kirin: Prefer of_device_get_match_data()
PCI: intel-gw: Rename intel_pcie_port to intel_pcie
PCI: mediatek-gen3: Rename mtk_pcie_port to mtk_gen3_pcie
PCI: tegra194: Rename tegra_pcie_dw to tegra194_pcie
PCI: uniphier: Rename uniphier_pcie_priv to uniphier_pcie
PCI: xgene: Rename xgene_pcie_port to xgene_pcie
PCI: xilinx: Rename xilinx_pcie_port to xilinx_pcie
drivers/pci/controller/cadence/pci-j721e.c | 18 +-
.../controller/cadence/pcie-cadence-plat.c | 6 +-
drivers/pci/controller/dwc/pci-dra7xx.c | 6 +-
drivers/pci/controller/dwc/pci-keystone.c | 4 +-
drivers/pci/controller/dwc/pcie-artpec6.c | 6 +-
.../pci/controller/dwc/pcie-designware-plat.c | 6 +-
drivers/pci/controller/dwc/pcie-intel-gw.c | 204 +++++-----
drivers/pci/controller/dwc/pcie-kirin.c | 6 +-
drivers/pci/controller/dwc/pcie-tegra194.c | 222 +++++------
drivers/pci/controller/dwc/pcie-uniphier.c | 147 +++----
.../mobiveil/pcie-layerscape-gen4.c | 84 ++--
drivers/pci/controller/pci-rcar-gen2.c | 14 +-
drivers/pci/controller/pci-xgene.c | 46 +--
drivers/pci/controller/pcie-altera.c | 8 +-
drivers/pci/controller/pcie-iproc-bcma.c | 22 +-
drivers/pci/controller/pcie-iproc-platform.c | 16 +-
drivers/pci/controller/pcie-mediatek-gen3.c | 372 +++++++++---------
drivers/pci/controller/pcie-microchip-host.c | 42 +-
drivers/pci/controller/pcie-mt7621.c | 36 +-
drivers/pci/controller/pcie-xilinx-cpm.c | 44 +--
drivers/pci/controller/pcie-xilinx.c | 158 ++++----
21 files changed, 727 insertions(+), 740 deletions(-)
--
2.25.1
next reply other threads:[~2021-12-23 1:11 UTC|newest]
Thread overview: 34+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-12-23 1:10 Bjorn Helgaas [this message]
2021-12-23 1:10 ` [PATCH v2 01/23] PCI: altera: Prefer of_device_get_match_data() Bjorn Helgaas
2021-12-23 1:10 ` [PATCH v2 02/23] PCI: artpec6: " Bjorn Helgaas
2021-12-25 13:30 ` Jesper Nilsson
2021-12-23 1:10 ` [PATCH v2 03/23] PCI: cadence: " Bjorn Helgaas
2021-12-23 1:10 ` [PATCH v2 04/23] PCI: designware-plat: " Bjorn Helgaas
2021-12-23 1:10 ` [PATCH v2 05/23] PCI: dra7xx: " Bjorn Helgaas
2021-12-23 1:10 ` [PATCH v2 06/23] PCI: keystone: " Bjorn Helgaas
2021-12-23 1:10 ` [PATCH v2 07/23] PCI: kirin: " Bjorn Helgaas
2021-12-23 1:10 ` [PATCH v2 08/23] PCI: j721e: Drop pointless of_device_get_match_data() cast Bjorn Helgaas
2021-12-23 1:10 ` [PATCH v2 09/23] PCI: j721e: Drop redundant struct device * Bjorn Helgaas
2021-12-23 1:10 ` [PATCH v2 10/23] PCI: intel-gw: Rename intel_pcie_port to intel_pcie Bjorn Helgaas
2021-12-23 1:10 ` [PATCH v2 11/23] PCI: iproc: Rename iproc_pcie_bcma_ to iproc_bcma_pcie_ Bjorn Helgaas
2022-01-04 18:34 ` Ray Jui
2021-12-23 1:10 ` [PATCH v2 12/23] PCI: iproc: Rename iproc_pcie_pltfm_ to iproc_pltfm_pcie_ Bjorn Helgaas
2022-01-04 18:34 ` Ray Jui
2021-12-23 1:10 ` [PATCH v2 13/23] PCI: ls-gen4: Rename ls_pcie_g4 to ls_g4_pcie Bjorn Helgaas
2021-12-23 1:10 ` [PATCH v2 14/23] PCI: mediatek-gen3: Rename mtk_pcie_port to mtk_gen3_pcie Bjorn Helgaas
2021-12-23 1:10 ` [PATCH v2 15/23] PCI: microchip: Rename mc_port to mc_pcie Bjorn Helgaas
2021-12-23 1:10 ` [PATCH v2 16/23] PCI: mt7621: Make pci_ops static Bjorn Helgaas
2021-12-23 6:04 ` Sergio Paracuellos
2021-12-23 16:40 ` Bjorn Helgaas
2021-12-23 1:10 ` [PATCH v2 17/23] PCI: mt7621: Rename mt7621_pci_ to mt7621_pcie_ Bjorn Helgaas
2021-12-23 6:10 ` Sergio Paracuellos
2021-12-23 16:43 ` Bjorn Helgaas
2021-12-23 1:10 ` [PATCH v2 18/23] PCI: rcar-gen2: Rename rcar_pci_priv to rcar_pci Bjorn Helgaas
2021-12-23 1:10 ` [PATCH v2 19/23] PCI: tegra194: Rename tegra_pcie_dw to tegra194_pcie Bjorn Helgaas
2021-12-23 1:10 ` [PATCH v2 20/23] PCI: uniphier: Rename uniphier_pcie_priv to uniphier_pcie Bjorn Helgaas
2021-12-23 1:10 ` [PATCH v2 21/23] PCI: xgene: Rename xgene_pcie_port to xgene_pcie Bjorn Helgaas
2021-12-23 1:10 ` [PATCH v2 22/23] PCI: xilinx: Rename xilinx_pcie_port to xilinx_pcie Bjorn Helgaas
2022-01-03 8:39 ` Michal Simek
2021-12-23 1:10 ` [PATCH v2 23/23] PCI: xilinx-cpm: Rename xilinx_cpm_pcie_port to xilinx_cpm_pcie Bjorn Helgaas
2022-01-03 8:39 ` Michal Simek
2021-12-26 12:04 ` [PATCH v2 00/23] PCI: Name structs, functions consistently Lorenzo Pieralisi
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20211223011054.1227810-1-helgaas@kernel.org \
--to=helgaas@kernel.org \
--cc=bhelgaas@google.com \
--cc=ffclaire1224@gmail.com \
--cc=linux-kernel-mentees@lists.linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=lorenzo.pieralisi@arm.com \
--cc=robh@kernel.org \
--cc=skhan@linuxfoundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox