The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Jonathan Cameron <jic23@kernel.org>
To: David Lechner <dlechner@baylibre.com>
Cc: "Marcelo Schmitt" <marcelo.schmitt1@gmail.com>,
	"Nuno Sá" <nuno.sa@analog.com>,
	"Michael Hennerich" <Michael.Hennerich@analog.com>,
	"Mark Brown" <broonie@kernel.org>,
	"Liam Girdwood" <lgirdwood@gmail.com>,
	linux-iio@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/5] iio: adc: ad7192: use devm_regulator_get_enable_read_voltage
Date: Mon, 3 Jun 2024 21:10:56 +0100	[thread overview]
Message-ID: <20240603211056.3d297018@jic23-huawei> (raw)
In-Reply-To: <9bcf9ed6-dcba-4e23-9845-a81cf39a3153@baylibre.com>

On Mon, 3 Jun 2024 08:36:51 -0500
David Lechner <dlechner@baylibre.com> wrote:

> On 6/1/24 7:48 AM, Jonathan Cameron wrote:
> > On Fri, 31 May 2024 16:19:32 -0500
> > David Lechner <dlechner@baylibre.com> wrote:
> >   
> >> This makes use of the new devm_regulator_get_enable_read_voltage()
> >> function to reduce boilerplate code.
> >>
> >> Error messages have changed slightly since there are now fewer places
> >> where we print an error. The rest of the logic of selecting which
> >> supply to use as the reference voltage remains the same.
> >>
> >> Also 1000 is replaced by MILLI in a few places for consistency.
> >>
> >> Signed-off-by: David Lechner <dlechner@baylibre.com>  
> > Ouch diff didn't like this one much and it is a bit hard to read.
> > 
> > One case where I think this has an unintended side effect.
> > See below.
> >   
> 
> ...
> 
> >> @@ -1219,74 +1211,54 @@ static int ad7192_probe(struct spi_device *spi)
> >>  	 * Newer firmware should provide a zero volt fixed supply if wired to
> >>  	 * ground.
> >>  	 */
> >> -	aincom = devm_regulator_get_optional(&spi->dev, "aincom");
> >> -	if (IS_ERR(aincom)) {
> >> -		if (PTR_ERR(aincom) != -ENODEV)
> >> -			return dev_err_probe(&spi->dev, PTR_ERR(aincom),
> >> -					     "Failed to get AINCOM supply\n");
> >> -
> >> +	ret = devm_regulator_get_enable_read_voltage(&spi->dev, "aincom");
> >> +	if (ret == -ENODEV)
> >>  		st->aincom_mv = 0;
> >> -	} else {
> >> -		ret = regulator_enable(aincom);
> >> -		if (ret)
> >> -			return dev_err_probe(&spi->dev, ret,
> >> -					     "Failed to enable specified AINCOM supply\n");
> >> +	else if (ret < 0)
> >> +		return dev_err_probe(&spi->dev, ret, "Failed to get AINCOM voltage\n");
> >> +	else
> >> +		st->aincom_mv = ret / MILLI;
> >>  
> >> -		ret = devm_add_action_or_reset(&spi->dev, ad7192_reg_disable, aincom);
> >> +	/* AVDD can optionally be used as reference voltage */
> >> +	ret = devm_regulator_get_enable_read_voltage(&spi->dev, "avdd");
> >> +	if (ret == -EINVAL) {
> >> +		/*
> >> +		 * We get -EINVAL if avdd is a supply with unknown voltage. We
> >> +		 * still need to enable it since it is also a power supply.
> >> +		 */
> >> +		ret = devm_regulator_get_enable(&spi->dev, "avdd");  
> > 
> > What happens if the entry simply isn't there in the DT.
> > Previously I think the regulator framework would supply a stub whereas
> > the devm_regulator_get_enable_read_voltage() returns -ENODEV so isn't
> > caught by the handling and I think it should be.  
> 
> Ah, yes so:
> 
> if (ret == -EINVAL || ret == -ENODEV) {
> 
Yes I think.


  reply	other threads:[~2024-06-03 20:11 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-05-31 21:19 [PATCH 0/5] iio: adc: use devm_regulator_get_enable_read_voltage round 1 David Lechner
2024-05-31 21:19 ` [PATCH 1/5] iio: adc: ad7192: use devm_regulator_get_enable_read_voltage David Lechner
2024-06-01 12:48   ` Jonathan Cameron
2024-06-03 13:36     ` David Lechner
2024-06-03 20:10       ` Jonathan Cameron [this message]
2024-05-31 21:19 ` [PATCH 2/5] iio: adc: ad7266: " David Lechner
2024-06-04 11:19   ` Nuno Sá
2024-06-04 14:10     ` David Lechner
2024-06-05  9:33       ` Nuno Sá
2024-05-31 21:19 ` [PATCH 3/5] iio: adc: ad7292: " David Lechner
2024-06-08  4:28   ` Marcelo Schmitt
2024-05-31 21:19 ` [PATCH 4/5] iio: adc: ad7793: " David Lechner
2024-05-31 21:19 ` [PATCH 5/5] iio: adc: ad7944: " David Lechner
2024-06-01 13:01   ` Jonathan Cameron
2024-06-03 13:38     ` David Lechner

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20240603211056.3d297018@jic23-huawei \
    --to=jic23@kernel.org \
    --cc=Michael.Hennerich@analog.com \
    --cc=broonie@kernel.org \
    --cc=dlechner@baylibre.com \
    --cc=lgirdwood@gmail.com \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=marcelo.schmitt1@gmail.com \
    --cc=nuno.sa@analog.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox