From: Eric Biggers <ebiggers@kernel.org>
To: linux-kernel@vger.kernel.org
Cc: linux-crypto@vger.kernel.org, Ard Biesheuvel <ardb@kernel.org>
Subject: [PATCH 0/5] A few more CRC32 library cleanups
Date: Tue, 4 Feb 2025 16:53:58 -0800 [thread overview]
Message-ID: <20250205005403.136082-1-ebiggers@kernel.org> (raw)
This series makes the CRC32 library functions have consistent
prototypes, and it makes the Castagnoli CRC32 be consistently called
simply crc32c instead of a mix of crc32c, crc32c_le, and __crc32c_le.
Eric Biggers (5):
lib/crc32: use void pointer for data
lib/crc32: don't bother with pure and const function attributes
lib/crc32: standardize on crc32c() name for Castagnoli CRC32
lib/crc32: rename __crc32c_le_combine() to crc32c_combine()
lib/crc32: remove "_le" from crc32c base and arch functions
arch/arm/lib/crc32-glue.c | 12 ++---
arch/arm64/lib/crc32-glue.c | 10 ++--
arch/loongarch/lib/crc32-loongarch.c | 6 +--
arch/mips/lib/crc32-mips.c | 6 +--
arch/powerpc/lib/crc32-glue.c | 10 ++--
arch/riscv/lib/crc32-riscv.c | 17 +++---
arch/s390/lib/crc32-glue.c | 2 +-
arch/sparc/lib/crc32_glue.c | 10 ++--
arch/x86/lib/crc32-glue.c | 6 +--
crypto/crc32c_generic.c | 8 +--
drivers/crypto/stm32/stm32-crc32.c | 2 +-
drivers/infiniband/sw/siw/siw.h | 4 +-
drivers/md/raid5-cache.c | 31 ++++++-----
drivers/md/raid5-ppl.c | 16 +++---
.../net/ethernet/broadcom/bnx2x/bnx2x_sp.c | 2 +-
drivers/thunderbolt/ctl.c | 2 +-
drivers/thunderbolt/eeprom.c | 2 +-
include/linux/crc32.h | 53 +++++++++----------
include/linux/crc32c.h | 8 ---
include/net/sctp/checksum.h | 7 +--
lib/crc32.c | 21 ++++----
lib/crc_kunit.c | 2 +-
sound/soc/codecs/aw88395/aw88395_device.c | 2 +-
23 files changed, 111 insertions(+), 128 deletions(-)
base-commit: 2014c95afecee3e76ca4a56956a936e23283f05b
--
2.48.1
next reply other threads:[~2025-02-05 0:55 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-02-05 0:53 Eric Biggers [this message]
2025-02-05 0:53 ` [PATCH 1/5] lib/crc32: use void pointer for data Eric Biggers
2025-02-05 0:54 ` [PATCH 2/5] lib/crc32: don't bother with pure and const function attributes Eric Biggers
2025-02-05 0:54 ` [PATCH 3/5] lib/crc32: standardize on crc32c() name for Castagnoli CRC32 Eric Biggers
2025-02-07 22:42 ` Nathan Chancellor
2025-02-07 22:49 ` Eric Biggers
2025-02-05 0:54 ` [PATCH 4/5] lib/crc32: rename __crc32c_le_combine() to crc32c_combine() Eric Biggers
2025-02-05 0:54 ` [PATCH 5/5] lib/crc32: remove "_le" from crc32c base and arch functions Eric Biggers
2025-02-05 15:35 ` [PATCH 0/5] A few more CRC32 library cleanups Ard Biesheuvel
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250205005403.136082-1-ebiggers@kernel.org \
--to=ebiggers@kernel.org \
--cc=ardb@kernel.org \
--cc=linux-crypto@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox