From: Sean Christopherson <seanjc@google.com>
To: Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
Dave Hansen <dave.hansen@linux.intel.com>,
x86@kernel.org, Sean Christopherson <seanjc@google.com>,
Paolo Bonzini <pbonzini@redhat.com>
Cc: linux-kernel@vger.kernel.org, kvm@vger.kernel.org,
Zheyun Shen <szy0127@sjtu.edu.cn>,
Tom Lendacky <thomas.lendacky@amd.com>,
Kevin Loughlin <kevinloughlin@google.com>,
Mingwei Zhang <mizhang@google.com>
Subject: [PATCH 0/7] x86, KVM: Optimize SEV cache flushing
Date: Wed, 26 Feb 2025 17:48:51 -0800 [thread overview]
Message-ID: <20250227014858.3244505-1-seanjc@google.com> (raw)
This is the combination of Kevin's WBNOINVD series[1] with Zheyun's targeted
flushing series[2]. This is very, very lightly tested (emphasis on "very").
Note, I dropped Reviewed-by tags for patches to which I made non-trivial
modifications.
[1] https://lore.kernel.org/all/20250201000259.3289143-1-kevinloughlin@google.com
[2] https://lore.kernel.org/all/20250128015345.7929-1-szy0127@sjtu.edu.cn
Relative to those series:
- Name the WBNOINVD opcode macro ASM_WBNOINVD to avoid a conflict with
KVM's CPUID stuff.
- Fix issues with SMP=n.
- Define all helpers in x86/lib.
- Don't return 0 from the helpers.
- Rename the CPU bitmap to avoid a naming collisions with KVM's existing
pCPU bitmap for WBINVD, and to not have WBINVD (versus WBNOINVD) in the
name.
- Fix builds where CPU bitmaps are off-stack.
- Massage comments.
- Mark a CPU as having done VMRUN in pre_sev_run(), but test to see if
the CPU already ran to avoid the locked RMW, i.e. to (hopefully) avoid
bouncing the cache line.
Kevin Loughlin (2):
x86, lib: Add WBNOINVD helper functions
KVM: SEV: Prefer WBNOINVD over WBINVD for cache maintenance efficiency
Sean Christopherson (2):
x86, lib: Drop the unused return value from wbinvd_on_all_cpus()
KVM: x86: Use wbinvd_on_cpu() instead of an open-coded equivalent
Zheyun Shen (3):
KVM: SVM: Remove wbinvd in sev_vm_destroy()
x86, lib: Add wbinvd and wbnoinvd helpers to target multiple CPUs
KVM: SVM: Flush cache only on CPUs running SEV guest
arch/x86/include/asm/smp.h | 23 ++++++--
arch/x86/include/asm/special_insns.h | 19 ++++++-
arch/x86/kvm/svm/sev.c | 79 +++++++++++++++++++---------
arch/x86/kvm/svm/svm.h | 1 +
arch/x86/kvm/x86.c | 11 +---
arch/x86/lib/cache-smp.c | 26 ++++++++-
6 files changed, 119 insertions(+), 40 deletions(-)
base-commit: fed48e2967f402f561d80075a20c5c9e16866e53
--
2.48.1.711.g2feabab25a-goog
next reply other threads:[~2025-02-27 1:49 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-02-27 1:48 Sean Christopherson [this message]
2025-02-27 1:48 ` [PATCH 1/7] KVM: SVM: Remove wbinvd in sev_vm_destroy() Sean Christopherson
2025-02-27 1:48 ` [PATCH 2/7] x86, lib: Drop the unused return value from wbinvd_on_all_cpus() Sean Christopherson
2025-02-27 19:59 ` Sean Christopherson
2025-02-27 1:48 ` [PATCH 3/7] x86, lib: Add WBNOINVD helper functions Sean Christopherson
2025-03-13 10:13 ` Huang, Kai
2025-02-27 1:48 ` [PATCH 4/7] KVM: SEV: Prefer WBNOINVD over WBINVD for cache maintenance efficiency Sean Christopherson
2025-02-27 1:48 ` [PATCH 5/7] KVM: x86: Use wbinvd_on_cpu() instead of an open-coded equivalent Sean Christopherson
2025-03-03 16:49 ` Tom Lendacky
2025-02-27 1:48 ` [PATCH 6/7] x86, lib: Add wbinvd and wbnoinvd helpers to target multiple CPUs Sean Christopherson
2025-02-27 12:45 ` Zheyun Shen
2025-03-13 10:19 ` Huang, Kai
2025-02-27 1:48 ` [PATCH 7/7] KVM: SVM: Flush cache only on CPUs running SEV guest Sean Christopherson
2025-03-03 16:53 ` Tom Lendacky
2025-03-03 16:46 ` [PATCH 0/7] x86, KVM: Optimize SEV cache flushing Tom Lendacky
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250227014858.3244505-1-seanjc@google.com \
--to=seanjc@google.com \
--cc=bp@alien8.de \
--cc=dave.hansen@linux.intel.com \
--cc=kevinloughlin@google.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=mizhang@google.com \
--cc=pbonzini@redhat.com \
--cc=szy0127@sjtu.edu.cn \
--cc=tglx@linutronix.de \
--cc=thomas.lendacky@amd.com \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox