From: Greg KH <gregkh@linuxfoundation.org>
To: tomasz.pakula.oficjalny@gmail.com
Cc: linux-kernel@vger.kernel.org, stable@vger.kernel.org,
sashal@kernel.org, oleg@makarenk.ooo
Subject: Re: Request for backporting hid-pidff driver patches
Date: Tue, 22 Apr 2025 14:35:21 +0200 [thread overview]
Message-ID: <2025042201-cinema-overpay-c3a3@gregkh> (raw)
In-Reply-To: <a0f1dae5eee091781711d3b4ebe812b9a1f8c944.camel@gmail.com>
On Wed, Apr 02, 2025 at 09:21:31PM +0200, tomasz.pakula.oficjalny@gmail.com wrote:
> Hello
>
> Recently AUTOSEL selected some of out patches to hid-pidff and
> hid-universal-pidff. Though I looked over what was selected and
> everything will be working, I'd like to keep the drivers up-to-date at
> least going back to 6.12 as these kernels are widely used and leaving
> said driers in an incomplete state, not up to upstream might lead to
> some false positive bug reports to me and Oleg.
>
> Here's the full list of the hid-pidff related patches from upstream. It
> might look like a lot but some granular changes were recorded as the
> driver was in need of an overhaul for at least 10 years. This mainly
> touches just two files.
>
> I tested it personally and all the patches apply cleanly on top of
> current 6.12.y, 6.13.y and 6.14.y branches.
>
> Thanks in advance!
>
> e2fa0bdf08a7 HID: pidff: Fix set_device_control()
> f98ecedbeca3 HID: pidff: Fix 90 degrees direction name North -> East
> 1a575044d516 HID: pidff: Compute INFINITE value instead of using hardcoded 0xffff
> 0c6673e3d17b HID: pidff: Clamp effect playback LOOP_COUNT value
> bbeface10511 HID: pidff: Rename two functions to align them with naming convention
> 1bd55e79cbc0 HID: pidff: Remove redundant call to pidff_find_special_keys
> 9d4174dc4a23 HID: pidff: Support device error response from PID_BLOCK_LOAD
> e19675c24774 HID: pidff: Comment and code style update
> c385f61108d4 HID: hid-universal-pidff: Add Asetek wheelbases support
> 1f650dcec32d HID: pidff: Make sure to fetch pool before checking SIMULTANEOUS_MAX
> 2c2afb50b50f MAINTAINERS: Update hid-universal-pidff entry
> 5d98079b2d01 HID: pidff: Factor out pool report fetch and remove excess declaration
> 217551624569 HID: pidff: Use macros instead of hardcoded min/max values for shorts
> 4eb9c2ee538b HID: pidff: Simplify pidff_rescale_signed
> 0d24d4b1da96 HID: pidff: Move all hid-pidff definitions to a dedicated header
> 22a05462c3d0 HID: pidff: Fix null pointer dereference in pidff_find_fields
> f7ebf0b11b9e HID: pidff: Factor out code for setting gain
> 8713107221a8 HID: pidff: Rescale time values to match field units
> 1c12f136891c HID: pidff: Define values used in pidff_find_special_fields
> e4bdc80ef142 HID: pidff: Simplify pidff_upload_effect function
> cb3fd788e3fa HID: pidff: Completely rework and fix pidff_reset function
> abdbf8764f49 HID: pidff: Add PERIODIC_SINE_ONLY quirk
> 7d3adb9695ec MAINTAINERS: Add entry for hid-universal-pidff driver
> f06bf8d94fff HID: Add hid-universal-pidff driver and supported device ids
> ce52c0c939fc HID: pidff: Stop all effects before enabling actuators
> 3051bf5ec773 HID: pidff: Add FIX_WHEEL_DIRECTION quirk
> 36de0164bbaf HID: pidff: Add hid_pidff_init_with_quirks and export as GPL symbol
> a4119108d253 HID: pidff: Add PERMISSIVE_CONTROL quirk
> fc7c154e9bb3 HID: pidff: Add MISSING_PBO quirk and its detection
> 2d5c7ce5bf4c HID: pidff: Add MISSING_DELAY quirk and its detection
> f538183e997a HID: pidff: Clamp PERIODIC effect period to device's logical range
> 8876fc1884f5 HID: pidff: Do not send effect envelope if it's empty
> 37e0591fe44d HID: pidff: Convert infinite length from Linux API to PID standard
I think Sasha already got all of these, right? If not, what ones do you
want applied specifically?
thanks,
greg k-h
next prev parent reply other threads:[~2025-04-22 12:35 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-04-02 19:21 Request for backporting hid-pidff driver patches tomasz.pakula.oficjalny
2025-04-22 12:35 ` Greg KH [this message]
2025-04-22 12:37 ` Tomasz Pakuła
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2025042201-cinema-overpay-c3a3@gregkh \
--to=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=oleg@makarenk.ooo \
--cc=sashal@kernel.org \
--cc=stable@vger.kernel.org \
--cc=tomasz.pakula.oficjalny@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox