From: James Morse <james.morse@arm.com>
To: x86@kernel.org, linux-kernel@vger.kernel.org
Cc: Reinette Chatre <reinette.chatre@intel.com>,
Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
H Peter Anvin <hpa@zytor.com>, Babu Moger <Babu.Moger@amd.com>,
James Morse <james.morse@arm.com>,
shameerali.kolothum.thodi@huawei.com,
D Scott Phillips OS <scott@os.amperecomputing.com>,
carl@os.amperecomputing.com, lcherian@marvell.com,
bobo.shaobowang@huawei.com, tan.shaopeng@fujitsu.com,
baolin.wang@linux.alibaba.com,
Jamie Iles <quic_jiles@quicinc.com>,
Xin Hao <xhao@linux.alibaba.com>,
peternewman@google.com, dfustini@baylibre.com,
amitsinght@marvell.com, David Hildenbrand <david@redhat.com>,
Rex Nie <rex.nie@jaguarmicro.com>,
Dave Martin <dave.martin@arm.com>, Koba Ko <kobak@nvidia.com>,
Shanker Donthineni <sdonthineni@nvidia.com>,
fenghuay@nvidia.com, "Yury Norov [NVIDIA]" <yury.norov@gmail.com>
Subject: [PATCH v10 04/30] x86/resctrl: Optimize cpumask_any_housekeeping()
Date: Thu, 8 May 2025 17:18:32 +0000 [thread overview]
Message-ID: <20250508171858.9197-5-james.morse@arm.com> (raw)
In-Reply-To: <20250508171858.9197-1-james.morse@arm.com>
From: "Yury Norov [NVIDIA]" <yury.norov@gmail.com>
With the lack of cpumask_any_andnot_but(), cpumask_any_housekeeping()
has to abuse cpumask_nth() functions.
Update cpumask_any_housekeeping() to use the new cpumask_any_but()
and cpumask_any_andnot_but(). These two functions understand
RESCTRL_PICK_ANY_CPU, which simplifies cpumask_any_housekeeping()
significantly.
Tested-by: James Morse <james.morse@arm.com>
Reviewed-by: James Morse <james.morse@arm.com>
Reviewed-by: Reinette Chatre <reinette.chatre@intel.com>
Signed-off-by: Yury Norov [NVIDIA] <yury.norov@gmail.com>
Signed-off-by: James Morse <james.morse@arm.com>
---
arch/x86/kernel/cpu/resctrl/internal.h | 28 +++++++-------------------
1 file changed, 7 insertions(+), 21 deletions(-)
diff --git a/arch/x86/kernel/cpu/resctrl/internal.h b/arch/x86/kernel/cpu/resctrl/internal.h
index eaae99602b61..25b61e466715 100644
--- a/arch/x86/kernel/cpu/resctrl/internal.h
+++ b/arch/x86/kernel/cpu/resctrl/internal.h
@@ -47,30 +47,16 @@
static inline unsigned int
cpumask_any_housekeeping(const struct cpumask *mask, int exclude_cpu)
{
- unsigned int cpu, hk_cpu;
-
- if (exclude_cpu == RESCTRL_PICK_ANY_CPU)
- cpu = cpumask_any(mask);
- else
- cpu = cpumask_any_but(mask, exclude_cpu);
-
- /* Only continue if tick_nohz_full_mask has been initialized. */
- if (!tick_nohz_full_enabled())
- return cpu;
-
- /* If the CPU picked isn't marked nohz_full nothing more needs doing. */
- if (cpu < nr_cpu_ids && !tick_nohz_full_cpu(cpu))
- return cpu;
+ unsigned int cpu;
/* Try to find a CPU that isn't nohz_full to use in preference */
- hk_cpu = cpumask_nth_andnot(0, mask, tick_nohz_full_mask);
- if (hk_cpu == exclude_cpu)
- hk_cpu = cpumask_nth_andnot(1, mask, tick_nohz_full_mask);
+ if (tick_nohz_full_enabled()) {
+ cpu = cpumask_any_andnot_but(mask, tick_nohz_full_mask, exclude_cpu);
+ if (cpu < nr_cpu_ids)
+ return cpu;
+ }
- if (hk_cpu < nr_cpu_ids)
- cpu = hk_cpu;
-
- return cpu;
+ return cpumask_any_but(mask, exclude_cpu);
}
struct rdt_fs_context {
--
2.39.5
next prev parent reply other threads:[~2025-05-08 17:19 UTC|newest]
Thread overview: 48+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-08 17:18 [PATCH v10 00/30] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl James Morse
2025-05-08 17:18 ` [PATCH v10 01/30] cpumask: relax cpumask_any_but() James Morse
2025-05-08 17:18 ` [PATCH v10 02/30] find: add find_first_andnot_bit() James Morse
2025-05-08 17:18 ` [PATCH v10 03/30] cpumask: add cpumask_{first,next}_andnot() API James Morse
2025-05-08 17:18 ` James Morse [this message]
2025-05-09 8:39 ` [PATCH v10 04/30] x86/resctrl: Optimize cpumask_any_housekeeping() Shaopeng Tan (Fujitsu)
2025-05-09 15:45 ` Yury Norov
2025-05-13 2:42 ` Shaopeng Tan (Fujitsu)
2025-05-08 17:18 ` [PATCH v10 05/30] x86/resctrl: Remove the limit on the number of CLOSID James Morse
2025-05-08 17:18 ` [PATCH v10 06/30] x86/resctrl: Rename resctrl_sched_in() to begin with "resctrl_arch_" James Morse
2025-05-08 17:18 ` [PATCH v10 07/30] x86/resctrl: Check all domains are offline in resctrl_exit() James Morse
2025-05-08 17:51 ` Reinette Chatre
2025-05-09 11:21 ` Catalin Marinas
2025-05-09 16:17 ` Reinette Chatre
2025-05-09 16:28 ` Reinette Chatre
2025-05-13 16:42 ` James Morse
2025-05-08 17:18 ` [PATCH v10 08/30] x86/resctrl: resctrl_exit() teardown resctrl but leave the mount point James Morse
2025-05-08 22:44 ` Reinette Chatre
2025-05-08 17:18 ` [PATCH v10 09/30] x86/resctrl: Drop __init/__exit on assorted symbols James Morse
2025-05-08 17:18 ` [PATCH v10 10/30] x86/resctrl: Move is_mba_sc() out of core.c James Morse
2025-05-08 17:18 ` [PATCH v10 11/30] x86/resctrl: Add end-marker to the resctrl_event_id enum James Morse
2025-05-08 17:18 ` [PATCH v10 12/30] x86/resctrl: Expand the width of domid by replacing mon_data_bits James Morse
2025-05-08 22:44 ` Reinette Chatre
2025-05-08 17:18 ` [PATCH v10 13/30] x86/resctrl: Split trace.h James Morse
2025-05-08 17:18 ` [PATCH v10 14/30] x86/resctrl: Add 'resctrl' to the title of the resctrl documentation James Morse
2025-05-08 17:18 ` [PATCH v10 15/30] fs/resctrl: Add boiler plate for external resctrl code James Morse
2025-05-08 17:18 ` [PATCH v10 16/30] x86/resctrl: Move the filesystem bits to headers visible to fs/resctrl James Morse
2025-05-08 17:18 ` [PATCH v10 17/30] x86/resctrl: Move enum resctrl_event_id to resctrl.h James Morse
2025-05-08 17:18 ` [PATCH v10 18/30] x86/resctrl: Fix types in resctrl_arch_mon_ctx_{alloc,free}() stubs James Morse
2025-05-08 22:45 ` Reinette Chatre
2025-05-13 16:45 ` James Morse
2025-05-08 17:18 ` [PATCH v10 19/30] x86/resctrl: Move pseudo lock prototypes to include/linux/resctrl.h James Morse
2025-05-08 17:18 ` [PATCH v10 20/30] x86/resctrl: Squelch whitespace anomalies in resctrl core code James Morse
2025-05-08 17:18 ` [PATCH v10 21/30] x86/resctrl: Prefer alloc(sizeof(*foo)) idiom in rdt_init_fs_context() James Morse
2025-05-08 17:18 ` [PATCH v10 22/30] x86/resctrl: Relax some asm #includes James Morse
2025-05-08 17:18 ` [PATCH v10 23/30] x86/resctrl: Always initialise rid field in rdt_resources_all[] James Morse
2025-05-08 17:18 ` [PATCH v10 24/30] x86/resctrl: Remove a newline to avoid confusing the code move script James Morse
2025-05-08 17:18 ` [PATCH v10 25/30] x86,fs/resctrl: Move the resctrl filesystem code to live in /fs/resctrl James Morse
2025-05-08 18:18 ` Yury Norov
2025-05-08 18:22 ` Reinette Chatre
2025-05-08 17:18 ` [PATCH v10 26/30] x86,fs/resctrl: Remove duplicated trace header files James Morse
2025-05-08 17:18 ` [PATCH v10 27/30] fs/resctrl: Remove unnecessary includes James Morse
2025-05-08 17:18 ` [PATCH v10 28/30] fs/resctrl: Change internal.h's header guard macros James Morse
2025-05-08 17:18 ` [PATCH v10 29/30] x86,fs/resctrl: Move resctrl.rst to live under Documentation/filesystems James Morse
2025-05-08 22:45 ` Reinette Chatre
2025-05-08 17:18 ` [PATCH v10 30/30] MAINTAINERS: Add reviewers for fs/resctrl James Morse
2025-05-09 11:46 ` [PATCH v10 00/30] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl Shaopeng Tan (Fujitsu)
2025-05-13 16:50 ` James Morse
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250508171858.9197-5-james.morse@arm.com \
--to=james.morse@arm.com \
--cc=Babu.Moger@amd.com \
--cc=amitsinght@marvell.com \
--cc=baolin.wang@linux.alibaba.com \
--cc=bobo.shaobowang@huawei.com \
--cc=bp@alien8.de \
--cc=carl@os.amperecomputing.com \
--cc=dave.martin@arm.com \
--cc=david@redhat.com \
--cc=dfustini@baylibre.com \
--cc=fenghuay@nvidia.com \
--cc=hpa@zytor.com \
--cc=kobak@nvidia.com \
--cc=lcherian@marvell.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=peternewman@google.com \
--cc=quic_jiles@quicinc.com \
--cc=reinette.chatre@intel.com \
--cc=rex.nie@jaguarmicro.com \
--cc=scott@os.amperecomputing.com \
--cc=sdonthineni@nvidia.com \
--cc=shameerali.kolothum.thodi@huawei.com \
--cc=tan.shaopeng@fujitsu.com \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
--cc=xhao@linux.alibaba.com \
--cc=yury.norov@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox