From: "Darrick J. Wong" <djwong@kernel.org>
To: Zizhi Wo <wozizhi@huawei.com>
Cc: cem@kernel.org, dchinner@redhat.com, osandov@fb.com,
john.g.garry@oracle.com, linux-xfs@vger.kernel.org,
linux-kernel@vger.kernel.org, yangerkun@huawei.com,
leo.lilong@huawei.com
Subject: Re: [PATCH] xfs: Remove unnecessary checks in functions related to xfs_fsmap
Date: Mon, 19 May 2025 08:08:54 -0700 [thread overview]
Message-ID: <20250519150854.GB9705@frogsfrogsfrogs> (raw)
In-Reply-To: <20250517074341.3841468-1-wozizhi@huawei.com>
On Sat, May 17, 2025 at 03:43:41PM +0800, Zizhi Wo wrote:
> From: Zizhi Wo <wozizhi@huaweicloud.com>
>
> In __xfs_getfsmap_datadev(), if "pag_agno(pag) == end_ag", we don't need
> to check the result of query_fn(), because there won't be another iteration
> of the loop anyway. Also, both before and after the change, info->group
> will eventually be set to NULL and the reference count of xfs_group will
> also be decremented before exiting the iteration.
>
> The same logic applies to other similar functions as well, so related
> cleanup operations are performed together.
>
> Signed-off-by: Zizhi Wo <wozizhi@huaweicloud.com>
> Signed-off-by: Zizhi Wo <wozizhi@huawei.com>
> ---
> fs/xfs/xfs_fsmap.c | 6 ------
> 1 file changed, 6 deletions(-)
>
> diff --git a/fs/xfs/xfs_fsmap.c b/fs/xfs/xfs_fsmap.c
> index 414b27a86458..792282aa8a29 100644
> --- a/fs/xfs/xfs_fsmap.c
> +++ b/fs/xfs/xfs_fsmap.c
> @@ -579,8 +579,6 @@ __xfs_getfsmap_datadev(
> if (pag_agno(pag) == end_ag) {
> info->last = true;
> error = query_fn(tp, info, &bt_cur, priv);
> - if (error)
> - break;
Removing these statements make the error path harder to follow. Before,
it was explicit that an error breaks out of the loop body. Now you have
to look upwards to the while loop conditional and reason about what
xfs_perag_next_range does when pag-> agno == end_ag to determine that
the loop terminates.
This also leaves a tripping point for anyone who wants to add another
statement into this here if body because now they have to recognize that
they need to re-add the "if (error) break;" statements that you're now
taking out.
You also don't claim any reduction in generated machine code size or
execution speed, which means all the programmers end up having to
perform extra reasoning when reading this code for ... what? Zero gain?
Please stop sending overly narrowly focused "optimizations" that make
life harder for all of us.
NAK.
--D
> }
> info->group = NULL;
> }
> @@ -813,8 +811,6 @@ xfs_getfsmap_rtdev_rtbitmap(
> info->last = true;
> error = xfs_getfsmap_rtdev_rtbitmap_helper(rtg, tp,
> &ahigh, info);
> - if (error)
> - break;
> }
>
> xfs_rtgroup_unlock(rtg, XFS_RTGLOCK_BITMAP_SHARED);
> @@ -1018,8 +1014,6 @@ xfs_getfsmap_rtdev_rmapbt(
> info->last = true;
> error = xfs_getfsmap_rtdev_rmapbt_helper(bt_cur,
> &info->high, info);
> - if (error)
> - break;
> }
> info->group = NULL;
> }
> --
> 2.39.2
>
>
prev parent reply other threads:[~2025-05-19 15:08 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-17 7:43 [PATCH] xfs: Remove unnecessary checks in functions related to xfs_fsmap Zizhi Wo
2025-05-19 6:35 ` Nirjhar Roy (IBM)
2025-05-19 15:08 ` Darrick J. Wong [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250519150854.GB9705@frogsfrogsfrogs \
--to=djwong@kernel.org \
--cc=cem@kernel.org \
--cc=dchinner@redhat.com \
--cc=john.g.garry@oracle.com \
--cc=leo.lilong@huawei.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-xfs@vger.kernel.org \
--cc=osandov@fb.com \
--cc=wozizhi@huawei.com \
--cc=yangerkun@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox