From: "Dmitry V. Levin" <ldv@strace.io>
To: Renzo Davoli <renzo@cs.unibo.it>
Cc: linux-kernel@vger.kernel.org,
Andrew Morton <akpm@linux-foundation.org>,
Oleg Nesterov <oleg@redhat.com>, Shuah Khan <shuah@kernel.org>,
Alexey Gladkov <legion@kernel.org>,
Eugene Syromyatnikov <evgsyr@gmail.com>,
Mike Frysinger <vapier@gentoo.org>,
Davide Berardi <berardi.dav@gmail.com>,
strace-devel@lists.strace.io
Subject: Re: [PATCH v3 1/2] ptrace: PTRACE_SET_SYSCALL_INFO syscall skipping support
Date: Tue, 7 Jul 2026 20:19:32 +0300 [thread overview]
Message-ID: <20260707171932.GA16585@strace.io> (raw)
In-Reply-To: <20260707112107.920752-2-renzo@cs.unibo.it>
On Tue, Jul 07, 2026 at 01:21:06PM +0200, Renzo Davoli wrote:
> This patch extends PTRACE_SET_SYSCALL_INFO with support for skipping a system
> call triggered via seccomp.
>
> When the tracer retrieves a ptrace_syscall_info structure with op ==
> PTRACE_SYSCALL_INFO_SECCOMP, it may choose to skip the system call by changing
> op to PTRACE_SYSCALL_INFO_EXIT and populating the exit union fields (rval and
> is_error) to define the return value and error status for the tracee.
I suggest changing the wording of the commit message as follows:
ptrace: add PTRACE_SET_SYSCALL_INFO syscall skipping support
Extend PTRACE_SET_SYSCALL_INFO to support skipping a system call triggered
via seccomp.
When a tracer retrieves a ptrace_syscall_info structure with 'op' set to
PTRACE_SYSCALL_INFO_SECCOMP, it can now choose to skip the system call.
To do this, the tracer changes 'op' to PTRACE_SYSCALL_INFO_EXIT and
populates the exit union fields (rval and is_error) to define the return
value and error status for the tracee.
> Signed-off-by: Renzo Davoli <renzo@cs.unibo.it>
> ---
> kernel/ptrace.c | 27 ++++++++++++++++++++++-----
> 1 file changed, 22 insertions(+), 5 deletions(-)
>
> diff --git a/kernel/ptrace.c b/kernel/ptrace.c
> index d041645d9d17..8ea807981390 100644
> --- a/kernel/ptrace.c
> +++ b/kernel/ptrace.c
> @@ -1099,7 +1099,7 @@ ptrace_set_syscall_info_seccomp(struct task_struct *child, struct pt_regs *regs,
>
> static int
> ptrace_set_syscall_info_exit(struct task_struct *child, struct pt_regs *regs,
> - struct ptrace_syscall_info *info)
> + struct ptrace_syscall_info *info, bool skip_syscall)
> {
> long rval = info->exit.rval;
>
> @@ -1111,6 +1111,9 @@ ptrace_set_syscall_info_exit(struct task_struct *child, struct pt_regs *regs,
> if (rval != info->exit.rval)
> return -ERANGE;
>
> + if (skip_syscall)
> + syscall_set_nr(child, regs, -1);
> +
> if (info->exit.is_error)
> syscall_set_return_value(child, regs, rval, 0);
> else
> @@ -1125,6 +1128,8 @@ ptrace_set_syscall_info(struct task_struct *child, unsigned long user_size,
> {
> struct pt_regs *regs = task_pt_regs(child);
> struct ptrace_syscall_info info;
> + int child_op;
> + bool skip_syscall = false;
>
> if (user_size < sizeof(info))
> return -EINVAL;
> @@ -1141,15 +1146,27 @@ ptrace_set_syscall_info(struct task_struct *child, unsigned long user_size,
> if (info.flags || info.reserved)
> return -EINVAL;
>
> - /* Changing the type of the system call stop is not supported yet. */
> - if (ptrace_get_syscall_info_op(child) != info.op)
> - return -EINVAL;
> + /*
> + * Changing the type of the system call stop is not allowed, with the
> + * following exception:
> + * PTRACE_SYSCALL_INFO_SECCOMP can be changed to PTRACE_SYSCALL_INFO_EXIT
> + * to skip the system call
> + */
> +
> + child_op = ptrace_get_syscall_info_op(child);
Apparently, Oleg is not quite happy with the name child_op,
so let's rename it to reported_op.
> + if (child_op != info.op) {
> + if (info.op == PTRACE_SYSCALL_INFO_EXIT &&
> + child_op == PTRACE_SYSCALL_INFO_SECCOMP)
Indentation of the last line looks somewhat unusual.
> + skip_syscall = true;
> + else
> + return -EINVAL;
> + }
> switch (info.op) {
> case PTRACE_SYSCALL_INFO_ENTRY:
> return ptrace_set_syscall_info_entry(child, regs, &info);
> case PTRACE_SYSCALL_INFO_EXIT:
> - return ptrace_set_syscall_info_exit(child, regs, &info);
> + return ptrace_set_syscall_info_exit(child, regs, &info, skip_syscall);
> case PTRACE_SYSCALL_INFO_SECCOMP:
> return ptrace_set_syscall_info_seccomp(child, regs, &info);
> default:
Feel free to add:
Reviewed-by: Dmitry V. Levin <ldv@strace.io>
--
ldv
next prev parent reply other threads:[~2026-07-07 17:19 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-07 11:21 [PATCH v3 0/2] ptrace_set_syscall_info: add support for seccomp syscall skipping Renzo Davoli
2026-07-07 11:21 ` [PATCH v3 1/2] ptrace: PTRACE_SET_SYSCALL_INFO syscall skipping support Renzo Davoli
2026-07-07 16:35 ` Oleg Nesterov
2026-07-07 17:19 ` Dmitry V. Levin [this message]
2026-07-07 17:44 ` Oleg Nesterov
2026-07-07 11:21 ` [PATCH v3 2/2] selftests/ptrace: add a test case for PTRACE_SYSCALL_INFO syscall skipping Renzo Davoli
2026-07-08 7:47 ` Dmitry V. Levin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260707171932.GA16585@strace.io \
--to=ldv@strace.io \
--cc=akpm@linux-foundation.org \
--cc=berardi.dav@gmail.com \
--cc=evgsyr@gmail.com \
--cc=legion@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=oleg@redhat.com \
--cc=renzo@cs.unibo.it \
--cc=shuah@kernel.org \
--cc=strace-devel@lists.strace.io \
--cc=vapier@gentoo.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox