The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Taha Narimani <tahanarimani3443@gmail.com>
To: jic23@kernel.org, lars@metafoo.de, Michael.Hennerich@analog.com,
	gregkh@linuxfoundation.org
Cc: dlechner@baylibre.com, nuno.sa@analog.com, andy@kernel.org,
	linux-iio@vger.kernel.org, linux-staging@lists.linux.dev,
	linux-kernel@vger.kernel.org,
	Taha Narimani <tahanarimani3443@gmail.com>
Subject: [PATCH v3] staging: iio: adc: ad7816: Use devm_gpiod_get_optional() for busy GPIO
Date: Fri, 10 Jul 2026 16:00:01 +0000	[thread overview]
Message-ID: <20260710160001.29856-2-tahanarimani3443@gmail.com> (raw)
In-Reply-To: <20260710160001.29856-1-tahanarimani3443@gmail.com>

The driver currently utilizes devm_gpiod_get() for the 'busy' line,
which makes the GPIO mandatory. However, the busy pin is hardware-optional
depending on the specific board configuration.

Switch to devm_gpiod_get_optional() to allow boards that do not have
this pin wired up to still probe the driver successfully. Clean up
the redundant busy_pin conditional checks as gpiod_get_value() safely
handles NULL descriptors. Additionally, use dev_err_probe() to prevent
bootlog spamming during deferred probing.

Fixes: 3e5971b2ddb6 ("base: original ad7816.c")
Signed-off-by: Taha Narimani <tahanarimani3443@gmail.com>
---
Changes in v3:
  - Removed redundant conditional check around gpiod_get_value() as suggested by Andy Shevchenko and Dan Carpenter.
  - Switched to dev_err_probe() to avoid deferred probe spamming.
  - Introduced local struct device *dev pointer in probe and kept the GPIO request on a single line for better readability.
  - Added the missing Fixes tag requested by Jonathan Cameron.

 drivers/staging/iio/adc/ad7816.c | 67 +++++++++++++-------------------
 1 file changed, 28 insertions(+), 39 deletions(-)

diff --git a/drivers/staging/iio/adc/ad7816.c b/drivers/staging/iio/adc/ad7816.c
index 988eee3..807cf57 100644
--- a/drivers/staging/iio/adc/ad7816.c
Changes in v3:
  - Removed redundant conditional check around gpiod_get_value() as suggested by Andy Shevchenko and Dan Carpenter.
  - Switched to dev_err_probe() to avoid deferred probe spamming.
  - Introduced local struct device *dev pointer in probe and kept the GPIO request on a single line for better readability.
  - Added the missing Fixes tag requested by Jonathan Cameron.

+++ b/drivers/staging/iio/adc/ad7816.c
@@ -22,20 +22,20 @@
 /*
  * AD7816 config masks
  */
-#define AD7816_FULL			0x1
-#define AD7816_PD			0x2
-#define AD7816_CS_MASK			0x7
-#define AD7816_CS_MAX			0x4
+#define AD7816_FULL                     0x1
+#define AD7816_PD                       0x2
+#define AD7816_CS_MASK                  0x7
+#define AD7816_CS_MAX                   0x4
 
 /*
  * AD7816 temperature masks
  */
-#define AD7816_VALUE_OFFSET		6
-#define AD7816_BOUND_VALUE_BASE		0x8
-#define AD7816_BOUND_VALUE_MIN		-95
-#define AD7816_BOUND_VALUE_MAX		152
-#define AD7816_TEMP_FLOAT_OFFSET	2
-#define AD7816_TEMP_FLOAT_MASK		0x3
+#define AD7816_VALUE_OFFSET             6
+#define AD7816_BOUND_VALUE_BASE         0x8
+#define AD7816_BOUND_VALUE_MIN          -95
+#define AD7816_BOUND_VALUE_MAX          152
+#define AD7816_TEMP_FLOAT_OFFSET        2
+#define AD7816_TEMP_FLOAT_MASK          0x3
 
 /*
  * struct ad7816_chip_info - chip specific information
@@ -48,7 +48,7 @@ struct ad7816_chip_info {
 	struct gpio_desc *convert_pin;
 	struct gpio_desc *busy_pin;
 	u8  oti_data[AD7816_CS_MAX + 1];
-	u8  channel_id;	/* 0 always be temperature */
+	u8  channel_id; /* 0 always be temperature */
 	u8  mode;
 };
 
@@ -84,10 +84,8 @@ static int ad7816_spi_read(struct ad7816_chip_info *chip, u16 *data)
 		gpiod_set_value(chip->convert_pin, 1);
 	}
 
-if (chip->id == ID_AD7816 || chip->id == ID_AD7817) {
-		while (gpiod_get_value(chip->busy_pin))
-			cpu_relax();
-	}
+	while (gpiod_get_value(chip->busy_pin))
+		cpu_relax();
 
 	gpiod_set_value(chip->rdwr_pin, 0);
 	gpiod_set_value(chip->rdwr_pin, 1);
@@ -254,8 +252,8 @@ static const struct attribute_group ad7816_attribute_group = {
  * temperature bound events
  */
 
-#define IIO_EVENT_CODE_AD7816_OTI IIO_UNMOD_EVENT_CODE(IIO_TEMP,	\
-						       0,		\
+#define IIO_EVENT_CODE_AD7816_OTI IIO_UNMOD_EVENT_CODE(IIO_TEMP,        \
+						       0,               \
 						       IIO_EV_TYPE_THRESH, \
 						       IIO_EV_DIR_FALLING)
 
@@ -351,11 +349,12 @@ static const struct iio_info ad7816_info = {
 
 static int ad7816_probe(struct spi_device *spi_dev)
 {
+	struct device *dev = &spi_dev->dev;
 	struct ad7816_chip_info *chip;
 	struct iio_dev *indio_dev;
 	int i, ret;
 
-	indio_dev = devm_iio_device_alloc(&spi_dev->dev, sizeof(*chip));
+	indio_dev = devm_iio_device_alloc(dev, sizeof(*chip));
 	if (!indio_dev)
 		return -ENOMEM;
 	chip = iio_priv(indio_dev);
@@ -365,31 +364,22 @@ static int ad7816_probe(struct spi_device *spi_dev)
 		chip->oti_data[i] = 203;
 
 	chip->id = spi_get_device_id(spi_dev)->driver_data;
-	chip->rdwr_pin = devm_gpiod_get(&spi_dev->dev, "rdwr", GPIOD_OUT_HIGH);
+	chip->rdwr_pin = devm_gpiod_get(dev, "rdwr", GPIOD_OUT_HIGH);
 	if (IS_ERR(chip->rdwr_pin)) {
 		ret = PTR_ERR(chip->rdwr_pin);
-		dev_err(&spi_dev->dev, "Failed to request rdwr GPIO: %d\n",
-			ret);
+		dev_err(dev, "Failed to request rdwr GPIO: %d\n", ret);
 		return ret;
 	}
-	chip->convert_pin = devm_gpiod_get(&spi_dev->dev, "convert",
-					   GPIOD_OUT_HIGH);
+	chip->convert_pin = devm_gpiod_get(dev, "convert", GPIOD_OUT_HIGH);
 	if (IS_ERR(chip->convert_pin)) {
 		ret = PTR_ERR(chip->convert_pin);
-		dev_err(&spi_dev->dev, "Failed to request convert GPIO: %d\n",
-			ret);
+		dev_err(dev, "Failed to request convert GPIO: %d\n", ret);
 		return ret;
 	}
-	if (chip->id == ID_AD7816 || chip->id == ID_AD7817) {
-		chip->busy_pin = devm_gpiod_get(&spi_dev->dev, "busy",
-						GPIOD_IN);
-		if (IS_ERR(chip->busy_pin)) {
-			ret = PTR_ERR(chip->busy_pin);
-			dev_err(&spi_dev->dev, "Failed to request busy GPIO: %d\n",
-				ret);
-			return ret;
-		}
-	}
+
+	chip->busy_pin = devm_gpiod_get_optional(dev, "busy", GPIOD_IN);
+	if (IS_ERR(chip->busy_pin))
+		return dev_err_probe(dev, PTR_ERR(chip->busy_pin), "Failed to request busy GPIO\n");
 
 	indio_dev->name = spi_get_device_id(spi_dev)->name;
 	indio_dev->info = &ad7816_info;
@@ -397,7 +387,7 @@ static int ad7816_probe(struct spi_device *spi_dev)
 
 	if (spi_dev->irq) {
 		/* Only low trigger is supported in ad7816/7/8 */
-		ret = devm_request_threaded_irq(&spi_dev->dev, spi_dev->irq,
+		ret = devm_request_threaded_irq(dev, spi_dev->irq,
 						NULL,
 						&ad7816_event_handler,
 						IRQF_TRIGGER_LOW | IRQF_ONESHOT,
@@ -407,11 +397,11 @@ static int ad7816_probe(struct spi_device *spi_dev)
 			return ret;
 	}
 
-	ret = devm_iio_device_register(&spi_dev->dev, indio_dev);
+	ret = devm_iio_device_register(dev, indio_dev);
 	if (ret)
 		return ret;
 
-	dev_info(&spi_dev->dev, "%s temperature sensor and ADC registered.\n",
+	dev_info(dev, "%s temperature sensor and ADC registered.\n",
 		 indio_dev->name);
 
 	return 0;
@@ -431,7 +421,6 @@ static const struct spi_device_id ad7816_id[] = {
 	{ "ad7818", ID_AD7818 },
 	{ }
 };
-
 MODULE_DEVICE_TABLE(spi, ad7816_id);
 
 static struct spi_driver ad7816_driver = {
-- 
2.53.0


  reply	other threads:[~2026-07-10 16:00 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-10 16:00 [PATCH v3 RFC v3] dt-bindings: iio: adc: add ad7816/7/8 digital temperature sensor / ADC Taha Narimani
2026-07-10 16:00 ` Taha Narimani [this message]
2026-07-10 16:54   ` [PATCH v3] staging: iio: adc: ad7816: Use devm_gpiod_get_optional() for busy GPIO Dan Carpenter
2026-07-10 17:53   ` Maxwell Doose
2026-07-11  7:48 ` [PATCH v3 RFC v3] dt-bindings: iio: adc: add ad7816/7/8 digital temperature sensor / ADC Krzysztof Kozlowski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260710160001.29856-2-tahanarimani3443@gmail.com \
    --to=tahanarimani3443@gmail.com \
    --cc=Michael.Hennerich@analog.com \
    --cc=andy@kernel.org \
    --cc=dlechner@baylibre.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=jic23@kernel.org \
    --cc=lars@metafoo.de \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-staging@lists.linux.dev \
    --cc=nuno.sa@analog.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox