From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from smtp.kernel.org (aws-us-west-2-korg-mail-alma10-1.taild15c8.ts.net [100.103.45.18]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id D9A67184 for ; Tue, 14 Jul 2026 00:16:50 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=100.103.45.18 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1783988211; cv=none; b=Mv4RXZ4FKa0qfvvLOOmUezUfjS6rrBafJA5/DoVrjV7c49AXa5MrCZ7hgLD5vQclrz8NeOW0yGqAAb6gFMzCScwKFUc+VBFMZGm4lTTsHEJl5nOa8VGx/xbNReC672536quuw/PccqEDLb2gfsiIsI0G5ERueeCdFlJr59+rof8= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1783988211; c=relaxed/simple; bh=IQ2NGDbe9GkgnkDlFl3ZSR3rdjRNKYMJH8b0f1RMZxo=; h=From:To:Cc:Subject:Date:Message-ID:In-Reply-To:References: MIME-Version; b=nO5j45sDnTJAfMe3G8/kLFuTrp35Rx296lSvkiAA7tYmHOgOC9AHKGnPEUqye6lbNYleAYtj2AG18rSbXG2KGyFerzYE5wzAIIIsb3QI62BpXFlo2ySOSJ2bTbL5If2sOypPMoE0e5+Ij/rffxnoqw2KTNkDLuIY0BTq4uAzhLw= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b=e++cUxvx; arc=none smtp.client-ip=100.103.45.18 Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b="e++cUxvx" Received: by smtp.kernel.org (Postfix) with ESMTPSA id D2D181F000E9; Tue, 14 Jul 2026 00:16:49 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=kernel.org; s=k20260515; t=1783988210; bh=D2RRBIAKbXI1A5KhuqvtfHAInMsdKXSK8xayxkBELkc=; h=From:To:Cc:Subject:Date:In-Reply-To:References; b=e++cUxvxNWQaLZ0BBv8TJI2IgqicvGQHtllcl3e8aUrc86UQquG+l6TghhlerW1Xb bJys7LF9kUSNDWsi7UrgNNggvworJmLOqBEbMFcIKWKiH7xQNxDi3smv6FLMefqoZo I9BN6bE4cQC3Ah3Av5dIoQ38P26HWG9pJSSigV0eVrcq32OYYi6wESKu5BUDtxk0fm GlGf9D7CSipCKhcb4CPtRH2Bay8drqbZP8b1HUoiFXO0r4JlszsgcnRFfgNRhGvsvX bJAYytdSczgfeB4k9OOvFf2wKbrlHLBV1COUE/Vj/22nF3it2RiYbehKnw1J0FFTda JmDyRA/Iw8LmA== From: SJ Park To: xu.xin16@zte.com.cn Cc: SJ Park , akpm@linux-foundation.org, david@kernel.org, ljs@kernel.org, ziy@nvidia.com, baolin.wang@linux.alibaba.com, baohua@kernel.org, lance.yang@linux.dev, usama.arif@linux.dev, chengming.zhou@linux.dev, qi.zheng@linux.dev, linux-mm@kvack.org, linux-kernel@vger.kernel.org, npache@redhat.com, ryan.roberts@arm.com, dev.jain@arm.com, wang.yaxin@zte.com.cn Subject: Re: [PATCH v2 1/2] mm/mm_slot.h: add a helper function mm_slot_remove Date: Mon, 13 Jul 2026 17:16:36 -0700 Message-ID: <20260714001636.85603-1-sj@kernel.org> X-Mailer: git-send-email 2.47.3 In-Reply-To: <20260713143707966lCkTinO0i9zYAc1K2ZmqZ@zte.com.cn> References: Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Transfer-Encoding: 8bit On Mon, 13 Jul 2026 14:37:07 +0800 (CST) wrote: > From: xu xin > > Both THP and KSM manage per-mm scanning slots using the mm_slot > structure. The slot is kept in a hash table and a list, and removal from > both containers requires the same two operations: hash_del() and > list_del(). > > Introduce mm_slot_remove() to abstract the common hash_del() + list_del() > sequence used in both khugepaged and KSM. > > No functional change is intended. Looks good and clean to me! > > Signed-off-by: xu xin Reviewed-by: SJ Park [...] > --- a/mm/mm_slot.h > +++ b/mm/mm_slot.h > @@ -52,4 +52,9 @@ static inline void mm_slot_free(struct kmem_cache *cache, void *objp) > hash_add(_hashtable, &_mm_slot->hash, (unsigned long)_mm); \ > }) > > +static inline void mm_slot_remove(struct mm_slot *slot) > +{ > + hash_del(&slot->hash); > + list_del(&slot->mm_node); > +} > #endif /* _LINUX_MM_SLOT_H */ I'd prefer keep having the one blank line bfore the #endif. Definitely not a blocker but just thinking loud. Thanks, SJ [...]