From: Jakub Kicinski <kuba@kernel.org>
To: Jemmy Wong <jemmywong512@gmail.com>
Cc: netdev@vger.kernel.org, linux-kernel@vger.kernel.org,
andrew+netdev@lunn.ch, davem@davemloft.net, edumazet@google.com,
pabeni@redhat.com, horms@kernel.org
Subject: Re: [RESEND PATCH] net/core: consolidate RPS dispatch into netif_rps() helpers
Date: Mon, 20 Jul 2026 16:25:18 -0700 [thread overview]
Message-ID: <20260720162518.38414fa0@kernel.org> (raw)
In-Reply-To: <20260707154855.12134-1-jemmywong512@gmail.com>
On Tue, 7 Jul 2026 23:48:55 +0800 Jemmy Wong wrote:
> The RPS steering logic in netif_rx_internal(), netif_receive_skb_internal()
> and netif_receive_skb_list_internal() was open-coded three times, each with
> its own #ifdef CONFIG_RPS block and manual rcu_read_lock()/unlock() pairs.
>
> Factor it into two helpers, netif_rps() for the single-skb path and
> netif_rps_list() for the list path, and switch the callers to
> guard(rcu)/scoped_guard(rcu). A new internal NET_RX_UNHANDLED sentinel lets
> a helper report "RPS did not take this skb" so the caller falls back to the
> local enqueue / __netif_receive_skb() path; it never escapes to callers.
>
> netif_rps_list() keeps the early static_branch_unlikely(&rps_needed) bail
> out so the list is not needlessly walked and re-spliced when RPS is
> compiled in but disabled.
>
> No functional change intended.
You haven't read Paolo's reply, please go away.
next prev parent reply other threads:[~2026-07-20 23:25 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-02 15:28 [PATCH] net/rps: consolidate RPS dispatch into netif_rps() helpers Jemmy Wong
2026-07-07 15:48 ` [RESEND PATCH] net/core: " Jemmy Wong
2026-07-20 23:25 ` Jakub Kicinski [this message]
2026-07-21 16:05 ` Jemmy Wong
2026-07-10 9:59 ` [PATCH] net/rps: " Paolo Abeni
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260720162518.38414fa0@kernel.org \
--to=kuba@kernel.org \
--cc=andrew+netdev@lunn.ch \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=horms@kernel.org \
--cc=jemmywong512@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox