From: Jack Ma <jack4it@gmail.com>
To: Ido Schimmel <idosch@nvidia.com>,
David Ahern <dsahern@kernel.org>,
netdev@vger.kernel.org
Cc: "David S. Miller" <davem@davemloft.net>,
Eric Dumazet <edumazet@google.com>,
Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>,
Simon Horman <horms@kernel.org>, Shuah Khan <shuah@kernel.org>,
linux-kernel@vger.kernel.org, linux-kselftest@vger.kernel.org,
Jack Ma <jack4it@gmail.com>
Subject: Re: [PATCH net-next v3 1/3] net: nexthop: add NHA_FDB_PORT for fdb nexthops
Date: Thu, 23 Jul 2026 01:43:02 +0000 [thread overview]
Message-ID: <20260723014302.994-1-jack4it@gmail.com> (raw)
In-Reply-To: <20260722152346.GB3022830@shredder>
On Wed, Jul 22, 2026 at 06:23:46PM +0300, Ido Schimmel wrote:
> > No preference on dst_port / DST_PORT versus other options
> > (NHA_FDB_UDP_PORT for example)
> I don't see a reason to make the attribute overly specific (to UDP and
> FDB), which is why I prefer DST_PORT.
Thanks both. Done in v4: the attribute is now NHA_DST_PORT with a
matching "dst_port" keyword in iproute2, and the internal fields
follow suit (nh_config.nh_dst_port, nh_info.dst_port). Validation is
unchanged -- the port is still accepted only together with NHA_FDB and
NHA_GATEWAY -- so the name is generic while the feature stays FDB-only
for now, exactly as you suggested.
v4:
https://lore.kernel.org/netdev/20260723-b4-vxlan-fdb-port-v4-0-46e3a2dd88a3@gmail.com/
Thanks,
Jack
next prev parent reply other threads:[~2026-07-23 1:43 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-21 22:29 [PATCH net-next v3 0/3] net: nexthop: per-nexthop UDP dst port for fdb (VXLAN) nexthops Jack Ma
2026-07-21 22:29 ` [PATCH net-next v3 1/3] net: nexthop: add NHA_FDB_PORT for fdb nexthops Jack Ma
2026-07-22 11:46 ` Ido Schimmel
2026-07-22 14:43 ` David Ahern
2026-07-22 15:23 ` Ido Schimmel
2026-07-23 1:43 ` Jack Ma [this message]
2026-07-21 22:29 ` [PATCH net-next v3 2/3] vxlan: honor per-nexthop fdb destination port Jack Ma
2026-07-21 22:29 ` [PATCH net-next v3 3/3] selftests: net: add coverage for fdb nexthop dst port Jack Ma
2026-07-22 12:58 ` Ido Schimmel
2026-07-22 1:05 ` [PATCH net-next v3 0/3] net: nexthop: per-nexthop UDP dst port for fdb (VXLAN) nexthops Jakub Kicinski
2026-07-22 3:28 ` Jack Ma
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260723014302.994-1-jack4it@gmail.com \
--to=jack4it@gmail.com \
--cc=davem@davemloft.net \
--cc=dsahern@kernel.org \
--cc=edumazet@google.com \
--cc=horms@kernel.org \
--cc=idosch@nvidia.com \
--cc=kuba@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-kselftest@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=shuah@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox