The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Jason Gunthorpe <jgg@nvidia.com>
To: Logan Gunthorpe <logang@deltatee.com>
Cc: "Matt Evans" <matt@ozlabs.org>,
	"Leon Romanovsky" <leon@kernel.org>,
	"Alex Williamson" <alex@shazbot.org>,
	"Alex Mastro" <amastro@fb.com>,
	"Bjorn Helgaas" <bhelgaas@google.com>,
	"Kevin Tian" <kevin.tian@intel.com>,
	"Pranjal Shrivastava" <praan@google.com>,
	"Mahmoud Adam" <mngyadam@amazon.de>,
	"David Matlack" <dmatlack@google.com>,
	"Björn Töpel" <bjorn@kernel.org>,
	"Sumit Semwal" <sumit.semwal@linaro.org>,
	"Ankit Agrawal" <ankita@nvidia.com>,
	"Christian König" <christian.koenig@amd.com>,
	"Alistair Popple" <apopple@nvidia.com>,
	"Vivek Kasireddy" <vivek.kasireddy@intel.com>,
	linux-kernel@vger.kernel.org, linux-media@vger.kernel.org,
	dri-devel@lists.freedesktop.org, linaro-mm-sig@lists.linaro.org,
	kvm@vger.kernel.org, linux-pci@vger.kernel.org,
	"Longfang Liu" <liulongfang@huawei.com>
Subject: Re: [PATCH v5 2/9] PCI/P2PDMA: Add CONFIG_PCI_P2PDMA_CORE
Date: Tue, 4 Aug 2026 21:39:14 -0300	[thread overview]
Message-ID: <20260805003914.GK27883@nvidia.com> (raw)
In-Reply-To: <b30e75d8-37d6-478d-bc72-a9ed0b7e200c@deltatee.com>

On Tue, Aug 04, 2026 at 10:19:11AM -0600, Logan Gunthorpe wrote:

> There's a vague convention for this already: the term 'p2pmem' is often
> used for cases where the driver uses the allocator, etc. (I think I had
> this intention when I wrote the code and have since forgotten about
> it).

I've been calling it the genalloc layer and the core layer. p2pmem
would be OK to refer to the genalloc stuff. So if you want to have
CONFIG_PCI_P2PDMA and CONFIG_PCI_P2PMEM that seem sOk

> code into it's own file, potentially renaming some functions. Then, in
> the end, we would probably have a pcim_p2pdma_supported() function and a
> pcim_p2pmem_supported() function, the latter being used by existing use
> cases.

Not quite sure why we need this?

Matt, the mlx5 stuff is the same as VFIO, it just uses the "core"
layer and does not use the genalloc. So there shouldn't be an issue
here, if the genalloc is off then the mlx5 stuff should still
work. There shouldn't be a case where CONFIG_PCI_P2PDMA=y and mlx5 is
broken?

Did some of APIs get mixed into the genalloc family that should not
have?

Jason

  reply	other threads:[~2026-08-05  0:39 UTC|newest]

Thread overview: 51+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-15 17:47 [PATCH v5 0/9] vfio/pci: Add mmap() for DMABUFs Matt Evans
2026-07-15 17:47 ` [PATCH v5 1/9] PCI/P2PDMA: Split pool-related cleanup out of pci_p2pdma_release() Matt Evans
2026-07-17  8:02   ` Tian, Kevin
2026-07-28 22:33   ` Alex Williamson
2026-07-29 10:08     ` Leon Romanovsky
2026-08-05  0:31       ` Jason Gunthorpe
2026-07-30 16:45   ` Pranjal Shrivastava
2026-07-15 17:47 ` [PATCH v5 2/9] PCI/P2PDMA: Add CONFIG_PCI_P2PDMA_CORE Matt Evans
2026-07-17  8:02   ` Tian, Kevin
2026-07-30 19:37   ` Pranjal Shrivastava
2026-08-04 15:42   ` Matt Evans
2026-08-04 16:19     ` Logan Gunthorpe
2026-08-05  0:39       ` Jason Gunthorpe [this message]
2026-08-05 16:28         ` Matt Evans
2026-08-05 16:40           ` Jason Gunthorpe
2026-08-05 20:50             ` Logan Gunthorpe
2026-07-15 17:47 ` [PATCH v5 3/9] vfio/pci: Add a helper to look up PFNs for DMABUFs Matt Evans
2026-07-17  8:02   ` Tian, Kevin
2026-07-29 17:52   ` Alex Williamson
2026-07-30 17:34     ` Matt Evans
2026-07-30 22:55   ` Pranjal Shrivastava
2026-07-31 17:43     ` Matt Evans
2026-08-03 18:22       ` Matt Evans
2026-08-04 19:01         ` Pranjal Shrivastava
2026-08-05  0:41         ` Jason Gunthorpe
2026-07-15 17:47 ` [PATCH v5 4/9] vfio/pci: Add a helper to create a DMABUF for a BAR-map VMA Matt Evans
2026-07-15 17:47 ` [PATCH v5 5/9] vfio/pci: Convert BAR mmap() to use a DMABUF Matt Evans
2026-07-15 17:47 ` [PATCH v5 6/9] vfio/pci: Provide a user-facing name for BAR mappings Matt Evans
2026-07-17  8:03   ` Tian, Kevin
2026-07-29 17:52   ` Alex Williamson
2026-07-30 14:37     ` Matt Evans
2026-07-15 17:47 ` [PATCH v5 7/9] vfio/pci: Clean up BAR zap and revocation Matt Evans
2026-07-17  8:03   ` Tian, Kevin
2026-07-29 17:52   ` Alex Williamson
2026-07-30 14:47     ` Matt Evans
2026-08-04 20:10       ` Alex Williamson
2026-08-05 13:58         ` Matt Evans
2026-07-30 23:20   ` Pranjal Shrivastava
2026-07-15 17:47 ` [PATCH v5 8/9] vfio/pci: Support mmap() of a VFIO DMABUF Matt Evans
2026-07-17  8:03   ` Tian, Kevin
2026-07-30 23:33   ` Pranjal Shrivastava
2026-07-15 17:47 ` [PATCH v5 9/9] vfio/pci: Permanently revoke a DMABUF on request Matt Evans
2026-07-17  8:03   ` Tian, Kevin
2026-07-30 23:43   ` Pranjal Shrivastava
2026-07-15 18:12 ` [PATCH v5 0/9] vfio/pci: Add mmap() for DMABUFs David Matlack
2026-07-16 14:51   ` Matt Evans
2026-07-16 21:23     ` David Matlack
2026-07-17  8:42       ` David Laight
2026-07-17 16:30         ` David Matlack
2026-07-17 17:12       ` Matt Evans
2026-07-20 21:50         ` David Matlack

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260805003914.GK27883@nvidia.com \
    --to=jgg@nvidia.com \
    --cc=alex@shazbot.org \
    --cc=amastro@fb.com \
    --cc=ankita@nvidia.com \
    --cc=apopple@nvidia.com \
    --cc=bhelgaas@google.com \
    --cc=bjorn@kernel.org \
    --cc=christian.koenig@amd.com \
    --cc=dmatlack@google.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=kevin.tian@intel.com \
    --cc=kvm@vger.kernel.org \
    --cc=leon@kernel.org \
    --cc=linaro-mm-sig@lists.linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=liulongfang@huawei.com \
    --cc=logang@deltatee.com \
    --cc=matt@ozlabs.org \
    --cc=mngyadam@amazon.de \
    --cc=praan@google.com \
    --cc=sumit.semwal@linaro.org \
    --cc=vivek.kasireddy@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox