From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from verein.lst.de (verein.lst.de [213.95.11.211]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 65F033385B6 for ; Mon, 10 Aug 2026 17:35:02 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=213.95.11.211 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1786383304; cv=none; b=Y1CdMJWQWSLxLyLHXfo6MTGadpH8faQinOoiWp7aCKM4wQfBU5Jr79p698VdFcxTNeVjTtu4koOucDWVtrKV5+Qyc/421KlRo/51Q2/fQFqlMMyiKazSS+W3GbQiRiM7lryFeXs3IbRWbkLsS8lBWQZ3+AJTMi05gAORG5Ye/uo= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1786383304; c=relaxed/simple; bh=xISBgWAU9yjx1Q5saqDybEqHxIt65vowxE2YYj+IX+s=; h=Date:From:To:Cc:Subject:Message-ID:References:MIME-Version: Content-Type:Content-Disposition:In-Reply-To; b=ULcM3DX//Qp79or42WBWEtx0gSujzhefZGpgAsy/Pv+xdRj3A5bkbsvmtLiu58XVRam7cCyHUalW7xHGIoC3BD6SDJpfoKXblZR4o6UyYvSev9XgtErr4vhfPNwQpcL+vcqIR7E3/dEFkJWd/Rrs5b7XYuzGkFgmC2giykeYscA= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=lst.de; spf=pass smtp.mailfrom=lst.de; arc=none smtp.client-ip=213.95.11.211 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=lst.de Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=lst.de Received: by verein.lst.de (Postfix, from userid 2407) id 098DC68BEB; Mon, 10 Aug 2026 19:34:55 +0200 (CEST) Date: Mon, 10 Aug 2026 19:34:54 +0200 From: Christoph Hellwig To: Johannes Weiner Cc: Tal Zussman , Andrew Morton , Chris Li , Kairui Song , Kemeng Shi , Nhat Pham , Baoquan He , Barry Song , Youngjun Park , David Hildenbrand , Lorenzo Stoakes , "Liam R. Howlett" , Vlastimil Babka , Mike Rapoport , Suren Baghdasaryan , Michal Hocko , Matthew Wilcox , Christoph Hellwig , Yosry Ahmed , Chengming Zhou , linux-mm@kvack.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH 6/6] mm/swap: rename __swap_writepage() to __swap_writeout() Message-ID: <20260810173454.GA28736@lst.de> References: <20260806-b4-page_io-folios-v1-0-0899bac3b826@columbia.edu> <20260806-b4-page_io-folios-v1-6-0899bac3b826@columbia.edu> Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: User-Agent: Mutt/1.5.17 (2007-11-01) On Fri, Aug 07, 2026 at 01:01:08PM -0400, Johannes Weiner wrote: > [ At the risk of starting something, should the file itself be > renamed? swap_rw.c or swap_io.c or something. ] It needs to be split first. I have an outstanding series for that, and will need more. Please don't rename it while that is in flight.