From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S936347AbcIXIzT (ORCPT ); Sat, 24 Sep 2016 04:55:19 -0400 Received: from mout.kundenserver.de ([212.227.126.130]:57244 "EHLO mout.kundenserver.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932321AbcIXIzQ (ORCPT ); Sat, 24 Sep 2016 04:55:16 -0400 From: Arnd Bergmann To: Baoyou Xie Cc: mac@melware.de, isdn@linux-pingi.de, netdev@vger.kernel.org, linux-kernel@vger.kernel.org, xie.baoyou@zte.com.cn Subject: Re: [PATCH 1/6] isdn/eicon: add function declarations Date: Sat, 24 Sep 2016 10:55:01 +0200 Message-ID: <2111430.P3yaVHAIc2@wuerfel> User-Agent: KMail/5.1.3 (Linux/4.4.0-34-generic; KDE/5.18.0; x86_64; ; ) In-Reply-To: <1474694204-21563-1-git-send-email-baoyou.xie@linaro.org> References: <1474694204-21563-1-git-send-email-baoyou.xie@linaro.org> MIME-Version: 1.0 Content-Transfer-Encoding: 7Bit Content-Type: text/plain; charset="us-ascii" X-Provags-ID: V03:K0:jzty98eaYvdzxQYEPdvJa3g36+EHfpKqdPP9cOhc4lKwWgEwVIK mnyFlY/frRRxHUY2qwNuSsKM9V+R3Gxej01RYe/G+tpQFuaKzOrknY8ZCbP0oIV7xZcwFVI /2EmoQs0tn4SbdITrfp6ot6q2vPHQeAaGK0GLzLc3mh7c2KWy0Zajb5/qqCSRQUz15db34v C4Rc4Bx8aCA/W5nzl0Cbw== X-UI-Out-Filterresults: notjunk:1;V01:K0:wGN1QGlDmS8=:GXmEt67ziGdEZZhwxmegri 1O+4tIf9aLGAf8bDF7OTOZ4ZCzGrz/gWy6dZuMbDECazFDcT7OY6FnniYLYL+Le+g3Wz3WQJI Mwk3BHYNx3KyQsUpcdZ/TsYrDOmaKxzVHi+R7hgLruvoLvBQ8licgvZi0vbJRMwId+Tbqu2M4 OnKY4tac1z0HoiwheqAhjFaIHDA/u+vRgTYDJjdX4Rf93DeRpA8Tjd8nSt484isKg/VvKoUei 9atCLI6fwITdvqELLzq7WawNnsO9OX1tDXoiIm5S3aQsoRkFbZrimudxQJSitzP/TFPKVJ8p9 KnFIi4ioEcIF/b/RoBV3bUjMB52TQsGWnPOhRSx8lY5dBnV/iOrRS6WfVNeKNlZ8C3WDqZ5s0 9YNFM65hqK1VXkjtXiBmW428ClXcFmcdXSfoL0IJjSjRJAu97Pap3q4ixSrvTvp4V70cuF3WQ +Uax+y9eVJBTh/WtdIDHv6KC4dy2GZ5tU5VYuE9dNpuwX0fgOMYjhOPuhrud72ci6Sfb4DRCs OskWG3RTQoxTMDwzdPD6QLpIspLVgjVYu8KXKawvKuV9VY/sXrzUc2UVKpOQi7etLmd332Fth SsZA2CUt9pegzSSiqJOL4zX43eYxCow9udOAN2g4W7WbiZn8aht/2gckHaRUO4WEc0yGMDGCo WNa+pr6IuN2GY7S2w9zpL47MyJsIIsbXgsoBFDtH1mx0QR6uc8SBiqTMj/xx7ihhFIgXSsoUp WE+X65nWxVGY8dSB Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Saturday, September 24, 2016 1:16:44 PM CEST Baoyou Xie wrote: > We get a few warnings when building kernel with W=1: > drivers/isdn/hardware/eicon/diddfunc.c:95:12: warning: no previous prototype for 'diddfunc_init' [-Wmissing-prototypes] > drivers/isdn/hardware/eicon/s_4bri.c:128:6: warning: no previous prototype for 'start_qBri_hardware' [-Wmissing-prototypes] > drivers/isdn/hardware/eicon/idifunc.c:243:12: warning: no previous prototype for 'idifunc_init' [-Wmissing-prototypes] > drivers/isdn/hardware/eicon/capifunc.c:217:6: warning: no previous prototype for 'api_remove_complete' [-Wmissing-prototypes] > .... > > In fact, these functions need be declare in some header files. > > So this patch adds function declarations in > drivers/isdn/hardware/eicon/di_defs.h, > drivers/isdn/hardware/eicon/capifunc.h, > drivers/isdn/hardware/eicon/xdi_adapter.h. > > Signed-off-by: Baoyou Xie Nice cleanup! > > diff --git a/drivers/isdn/hardware/eicon/capifunc.c b/drivers/isdn/hardware/eicon/capifunc.c > index 7a0bdbd..869b98e 100644 > --- a/drivers/isdn/hardware/eicon/capifunc.c > +++ b/drivers/isdn/hardware/eicon/capifunc.c > @@ -55,9 +55,6 @@ static void diva_release_appl(struct capi_ctr *, __u16); > static char *diva_procinfo(struct capi_ctr *); > static u16 diva_send_message(struct capi_ctr *, > diva_os_message_buffer_s *); > -extern void diva_os_set_controller_struct(struct capi_ctr *); > - > -extern void DIVA_DIDD_Read(DESCRIPTOR *, int); > > /* > * debug There are a couple of other 'extern' declarations in this file, please do them at all once. Note that there are also some extern declarations for variables in this .c files of this driver, so it makes sense to do the variables and the function declarations at the same time. > diff --git a/drivers/isdn/hardware/eicon/diva.c b/drivers/isdn/hardware/eicon/diva.c > index d91dd58..9693add 100644 > --- a/drivers/isdn/hardware/eicon/diva.c > +++ b/drivers/isdn/hardware/eicon/diva.c > @@ -28,8 +28,6 @@ > > PISDN_ADAPTER IoAdapters[MAX_ADAPTER]; > extern IDI_CALL Requests[MAX_ADAPTER]; > -extern int create_adapter_proc(diva_os_xdi_adapter_t *a); > -extern void remove_adapter_proc(diva_os_xdi_adapter_t *a); Requests[] is another such example. This is particularly bad, because the name is extremely generic, and can cause conflicts when another driver uses the same identifier for a global symbol. Ideally it should be renamed with to 'diva_requests'. > --- a/drivers/isdn/hardware/eicon/divasproc.c > +++ b/drivers/isdn/hardware/eicon/divasproc.c > @@ -34,8 +34,6 @@ > > > extern PISDN_ADAPTER IoAdapters[MAX_ADAPTER]; > -extern void divas_get_version(char *); > -extern void diva_get_vserial_number(PISDN_ADAPTER IoAdapter, char *buf); > same for IoAdapters. > static void diva_get_extended_adapter_features(DIVA_CAPI_ADAPTER *a); > @@ -224,20 +223,10 @@ static void diva_free_dma_descriptor(PLCI *plci, int nr); > /* external function prototypes */ > /*------------------------------------------------------------------*/ > > -extern byte MapController(byte); > extern byte UnMapController(byte); The comment "external function prototypes" should be removed along with the actual prototypes. > #define MapId(Id)(((Id) & 0xffffff00L) | MapController((byte)(Id))) > #define UnMapId(Id)(((Id) & 0xffffff00L) | UnMapController((byte)(Id))) and probably the macros can get moved as well for consistency. > -extern int diva_card_read_xlog(diva_os_xdi_adapter_t *a); > - > /* > ** IMPORTS > */ > -extern void prepare_pri_functions(PISDN_ADAPTER IoAdapter); > -extern void prepare_pri2_functions(PISDN_ADAPTER IoAdapter); > -extern void diva_xdi_display_adapter_features(int card); > - Another comment that should go. Arnd