The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: "Mukunda,Vijendar" <vijendar.mukunda@amd.com>
To: Mario Limonciello <superm1@kernel.org>, broonie@kernel.org
Cc: alsa-devel@alsa-project.org, lgirdwood@gmail.com, perex@perex.cz,
	tiwai@suse.com, Sunil-kumar.Dommati@amd.com,
	venkataprasad.potturu@amd.com, syed.sabakareem@amd.com,
	linux-sound@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 3/3] ASoC: amd: ps: replace bitwise OR with logical OR in IRQ return check
Date: Wed, 8 Jul 2026 07:35:43 +0530	[thread overview]
Message-ID: <2e9e480c-b235-4c39-9dd3-cea5f600cdee@amd.com> (raw)
In-Reply-To: <22b0795c-64d0-4a39-8f21-c24ee5a5853e@kernel.org>



On 7/7/26 23:19, Mario Limonciello wrote:
>
>
> On 7/7/26 00:59, Vijendar Mukunda wrote:
>> The condition 'irq_flag | wake_irq_flag' uses bitwise OR to combine two
>> integer flags that are used as booleans. Replace with logical OR '||' to
>> correctly express the intended boolean check.
>>
>> Signed-off-by: Vijendar Mukunda <Vijendar.Mukunda@amd.com>
> Fixes: 7f91f012c1df0 ("ASoC: amd: ps: fix for irq handler return status")

This is a style/readability cleanup only.
Since irq_flag and wake_irq_flag are strictly used as boolean values (0/1),
using | or || yields the same runtime behavior.
No functional bug is being fixed here, so a Fixes: tag is not warranted.


>> ---
>>   sound/soc/amd/ps/pci-ps.c | 2 +-
>>   1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/sound/soc/amd/ps/pci-ps.c b/sound/soc/amd/ps/pci-ps.c
>> index 1162d13d8505..729f9aaba69e 100644
>> --- a/sound/soc/amd/ps/pci-ps.c
>> +++ b/sound/soc/amd/ps/pci-ps.c
>> @@ -248,7 +248,7 @@ static irqreturn_t acp63_irq_handler(int irq, 
>> void *dev_id)
>>       if (sdw_dma_irq_flag)
>>           return IRQ_WAKE_THREAD;
>>   -    if (irq_flag | wake_irq_flag)
>> +    if (irq_flag || wake_irq_flag)
>>           return IRQ_HANDLED;
>>       else
>>           return IRQ_NONE;
>


  reply	other threads:[~2026-07-08  2:06 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-07  5:59 [PATCH 0/3] ASoC: amd: ps: bug fixes for ACP PCI driver Vijendar Mukunda
2026-07-07  5:59 ` [PATCH 1/3] ASoC: amd: ps: disable MSI on resume in " Vijendar Mukunda
2026-07-07  5:59 ` [PATCH 2/3] ASoC: amd: ps: fix wrong ACP version string in pci_request_regions() Vijendar Mukunda
2026-07-07  5:59 ` [PATCH 3/3] ASoC: amd: ps: replace bitwise OR with logical OR in IRQ return check Vijendar Mukunda
2026-07-07 17:49   ` Mario Limonciello
2026-07-08  2:05     ` Mukunda,Vijendar [this message]
2026-07-07 17:49 ` [PATCH 0/3] ASoC: amd: ps: bug fixes for ACP PCI driver Mario Limonciello
2026-07-08 23:48 ` Mark Brown

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2e9e480c-b235-4c39-9dd3-cea5f600cdee@amd.com \
    --to=vijendar.mukunda@amd.com \
    --cc=Sunil-kumar.Dommati@amd.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=broonie@kernel.org \
    --cc=lgirdwood@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-sound@vger.kernel.org \
    --cc=perex@perex.cz \
    --cc=superm1@kernel.org \
    --cc=syed.sabakareem@amd.com \
    --cc=tiwai@suse.com \
    --cc=venkataprasad.potturu@amd.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox