From: Pratyush Yadav <pratyush@kernel.org>
To: Mike Rapoport <rppt@kernel.org>
Cc: Pratyush Yadav <pratyush@kernel.org>,
Pasha Tatashin <pasha.tatashin@soleen.com>,
Alexander Graf <graf@amazon.com>,
Muchun Song <muchun.song@linux.dev>,
Oscar Salvador <osalvador@suse.de>,
David Hildenbrand <david@kernel.org>,
Andrew Morton <akpm@linux-foundation.org>,
Jason Miu <jasonmiu@google.com>,
Jork Loeser <jloeser@linux.microsoft.com>,
kexec@lists.infradead.org, linux-mm@kvack.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v5 18/22] kho: extend scratch
Date: Thu, 30 Jul 2026 13:48:36 +0200 [thread overview]
Message-ID: <2vxzqzkk7l63.fsf@kernel.org> (raw)
In-Reply-To: <178540063445.2151126.14089645580528118019.b4-review@b4> (Mike Rapoport's message of "Thu, 30 Jul 2026 11:37:14 +0300")
On Thu, Jul 30 2026, Mike Rapoport wrote:
>> +static void __init kho_extend_scratch(void)
>> +{
>> + const struct kho_radix_walk_cb kho_cb = {
>> + .leaf = kho_ext_walk_leaf,
>> + .node = kho_ext_walk_node,
>> + };
>> + const struct kho_radix_walk_cb ext_cb = {
>> + .leaf = kho_ext_mark_scratch,
>> + };
>> + struct kho_radix_tree radix;
>> + phys_addr_t prev_end = 0;
>> + int err = 0;
>> +
>> + err = kho_radix_init_tree(&radix, NULL);
>> + if (err)
>> + goto print;
>> +
>> + /* Walk the KHO radix tree to find busy blocks. */
>> + err = kho_radix_walk_tree(&kho_in.radix_tree, &kho_cb, &radix);
>
> sashiko: Will this trigger a lockdep recursive locking warning?
>
> I think it will.
It does indeed, but that's a false positive. These are different trees
and so they have different mutexes. So I ignored this when sending the
v5.
But now that you also point it out, I went and did some digging. And I
think I know how to fix this. Setting a different lockdep class for the
local tree makes the warning go away. And from my sampling of other
users of lockdep_set_class(), this does seem to be right right usage of
the API, though I can't find much documentation on it.
While trying to explain in a comment why this is needed, I also realized
"radix" is not a descriptive name at all, and I renamed it to
"busy_blocks".
I'll send a v6 shortly with these changes.
--
Regards,
Pratyush Yadav
next prev parent reply other threads:[~2026-07-30 11:48 UTC|newest]
Thread overview: 29+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-29 14:55 [PATCH v5 00/22] kho: make boot time huge page allocation work nicely with KHO Pratyush Yadav
2026-07-29 14:55 ` [PATCH v5 01/22] kho: generalize radix tree APIs Pratyush Yadav
2026-07-30 8:40 ` Mike Rapoport
2026-07-30 11:50 ` Pratyush Yadav
2026-07-29 14:55 ` [PATCH v5 02/22] kho: make radix max key width more obvious Pratyush Yadav
2026-07-29 14:55 ` [PATCH v5 03/22] kho: disallow wide keys in radix tree Pratyush Yadav
2026-07-29 14:55 ` [PATCH v5 04/22] kho: return virtual address of mem_map from kho_get_mem_map() Pratyush Yadav
2026-07-29 14:55 ` [PATCH v5 05/22] kho: store incoming radix tree in kho_in Pratyush Yadav
2026-07-29 14:55 ` [PATCH v5 06/22] kho: move all memory retrieval logic to kho_mem_retrieve() Pratyush Yadav
2026-07-29 14:55 ` [PATCH v5 07/22] kho: add a struct for radix callbacks Pratyush Yadav
2026-07-29 14:55 ` [PATCH v5 08/22] kho: add callback for table pages Pratyush Yadav
2026-07-29 14:55 ` [PATCH v5 09/22] kho: add data argument to radix walk callback Pratyush Yadav
2026-07-29 14:55 ` [PATCH v5 10/22] kho: allow early-boot usage of the KHO radix tree Pratyush Yadav
2026-07-29 14:55 ` [PATCH v5 11/22] kho: allow destroying " Pratyush Yadav
2026-07-29 14:55 ` [PATCH v5 12/22] kho: add kho_radix_init_tree() Pratyush Yadav
2026-07-29 14:55 ` [PATCH v5 13/22] kho: expose kho_scratch_overlap() to kexec_handover.h Pratyush Yadav
2026-07-29 14:55 ` [PATCH v5 14/22] kho: initialize kho_scratch pointer earlier in boot Pratyush Yadav
2026-07-29 14:56 ` [PATCH v5 15/22] kho: initialize preserved memory map radix tree earlier Pratyush Yadav
2026-07-29 14:56 ` [PATCH v5 16/22] mm/mm_init: simplify deferred_free_pages() migratetype init Pratyush Yadav
2026-07-29 14:56 ` [PATCH v5 17/22] mm/mm_init: don't rely on memblock to get KHO scratch migratetype Pratyush Yadav
2026-07-30 7:23 ` Mike Rapoport
2026-07-30 11:53 ` Pratyush Yadav
2026-07-29 14:56 ` [PATCH v5 18/22] kho: extend scratch Pratyush Yadav
2026-07-30 8:37 ` Mike Rapoport
2026-07-30 11:48 ` Pratyush Yadav [this message]
2026-07-29 14:56 ` [PATCH v5 19/22] memblock: always include KHO headers Pratyush Yadav
2026-07-29 14:56 ` [PATCH v5 20/22] memblock: make HugeTLB bootmem allocation work with KHO Pratyush Yadav
2026-07-29 14:56 ` [PATCH v5 21/22] memblock: add memblock_reserved_hugetlb_size() Pratyush Yadav
2026-07-29 14:56 ` [PATCH v5 22/22] kho: exclude hugetlb memory from scratch size calculation Pratyush Yadav
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2vxzqzkk7l63.fsf@kernel.org \
--to=pratyush@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=david@kernel.org \
--cc=graf@amazon.com \
--cc=jasonmiu@google.com \
--cc=jloeser@linux.microsoft.com \
--cc=kexec@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=muchun.song@linux.dev \
--cc=osalvador@suse.de \
--cc=pasha.tatashin@soleen.com \
--cc=rppt@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox