From: "Arnd Bergmann" <arnd@arndb.de>
To: "Tudor Ambarus" <tudor.ambarus@linaro.org>,
"Rob Herring" <robh@kernel.org>,
krzk+dt@kernel.org, "Conor Dooley" <conor+dt@kernel.org>,
"Alim Akhtar" <alim.akhtar@samsung.com>
Cc: linux-kernel@vger.kernel.org, linux-samsung-soc@vger.kernel.org,
devicetree@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
"André Draszik" <andre.draszik@linaro.org>,
kernel-team@android.com,
"William McVicker" <willmcvicker@google.com>,
"Peter Griffin" <peter.griffin@linaro.org>,
"Javier Martinez Canillas" <javierm@redhat.com>,
"Thomas Zimmermann" <tzimmermann@suse.de>,
"Daniel Lezcano" <daniel.lezcano@linaro.org>,
"Vincent Guittot" <vincent.guittot@linaro.org>,
"Ulf Hansson" <ulf.hansson@linaro.org>
Subject: Re: [PATCH v3 2/3] firmware: add exynos ACPM protocol driver
Date: Fri, 06 Dec 2024 07:47:40 +0100 [thread overview]
Message-ID: <427caa87-b9ba-4797-88bd-a18a96eefdcf@app.fastmail.com> (raw)
In-Reply-To: <20241205175345.201595-3-tudor.ambarus@linaro.org>
On Thu, Dec 5, 2024, at 18:53, Tudor Ambarus wrote:
> +#define exynos_acpm_set_bulk(data, i) \
> + (((data) & ACPM_BULK_MASK) << (ACPM_BULK_SHIFT * (i)))
> +#define exynos_acpm_read_bulk(data, i) \
> + (((data) >> (ACPM_BULK_SHIFT * (i))) & ACPM_BULK_MASK)
Could these be inline functions for readability?
> + cmd[3] = (u32)(sched_clock() / 1000000); /*record ktime ms*/
The comment does not match the implementation, sched_clock()
is probably not what you want here because of its limitiations.
Maybe ktime_to_ms(ktime_get())?
> +/**
> + * acpm_get_rx() - get response from RX queue.
> + * @achan: ACPM channel info.
> + * @xfer: reference to the transfer to get response for.
> + *
> + * Return: 0 on success, -errno otherwise.
> + */
> +static int acpm_get_rx(struct acpm_chan *achan, struct acpm_xfer *xfer)
> +{
> + struct acpm_msg *tx = &xfer->tx;
> + struct acpm_msg *rx = &xfer->rx;
> + struct acpm_rx_data *rx_data;
> + const void __iomem *base, *addr;
> + u32 rx_front, rx_seqnum, tx_seqnum, seqnum;
> + u32 i, val, mlen;
> + bool rx_set = false;
> +
> + rx_front = readl_relaxed(achan->rx.front);
> + i = readl_relaxed(achan->rx.rear);
If you have to use readl_relaxed(), please annotate why,
otherwise just use the normal readl(). Is this access to
the SRAM?
> + spin_lock_irqsave(&achan->tx_lock, flags);
> +
> + tx_front = readl_relaxed(achan->tx.front);
> + idx = (tx_front + 1) % achan->qlen;
> +
> + ret = acpm_wait_for_queue_slots(achan, idx);
> + if (ret) {
> + spin_unlock_irqrestore(&achan->tx_lock, flags);
> + return ret;
> + }
It looks like you are calling a busy loop function inside
of a hardirq handler here, with a 500ms timeout. This is
not ok.
If you may need to wait for a long timeout, I would suggest
changing the interface so that this function is not allowed
to be called from irq-disabled context, change the spinlock
to a mutex and polling read to a sleeping version.
> + /* Advance TX front. */
> + writel_relaxed(idx, achan->tx.front);
> +
> + /* Flush SRAM posted writes. */
> + readl_relaxed(achan->tx.front);
> +
> + spin_unlock_irqrestore(&achan->tx_lock, flags);
I don't think this sequence guarantees the serialization
you want. By making the access _relaxed() you explicitly
say you don't want serialization, so the store does
not have to complete before the unlock.
> +static const struct of_device_id acpm_match[] = {
> + { .compatible = "google,gs101-acpm-ipc" },
> + {},
> +};
> +MODULE_DEVICE_TABLE(of, acpm_match);
> +
> +static struct platform_driver acpm_driver = {
> + .probe = acpm_probe,
> + .driver = {
> + .name = "exynos-acpm-protocol",
> + .of_match_table = of_match_ptr(acpm_match),
Remove the stray of_match_ptr() here.
> diff --git a/drivers/firmware/samsung/exynos-acpm.h
> b/drivers/firmware/samsung/exynos-acpm.h
> new file mode 100644
> index 000000000000..a03adcd260f5
> --- /dev/null
> +++ b/drivers/firmware/samsung/exynos-acpm.h
> @@ -0,0 +1,15 @@
> +#ifndef __EXYNOS_ACPM_H__
> +#define __EXYNOS_ACPM_H__
> +
> +struct acpm_handle;
> +struct acpm_xfer;
> +
> +int acpm_do_xfer(const struct acpm_handle *handle, struct acpm_xfer
> *xfer);
> +
> +#endif /* __EXYNOS_ACPM_H__ */
> diff --git a/include/linux/soc/samsung/exynos-acpm-protocol.h
> b/include/linux/soc/samsung/exynos-acpm-protocol.h
> new file mode 100644
> index 000000000000..762783af7617
> --- /dev/null
> +++ b/include/linux/soc/samsung/exynos-acpm-protocol.h
Why is this in include/linux/soc, and not in the firmware
header?
Arnd
next prev parent reply other threads:[~2024-12-06 6:48 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-12-05 17:53 [PATCH v3 0/3] firmware: add exynos ACPM protocol driver Tudor Ambarus
2024-12-05 17:53 ` [PATCH v3 1/3] dt-bindings: firmware: add samsung,exynos-acpm-ipc bindings Tudor Ambarus
2024-12-09 8:03 ` Krzysztof Kozlowski
2024-12-09 8:19 ` Tudor Ambarus
2024-12-05 17:53 ` [PATCH v3 2/3] firmware: add exynos ACPM protocol driver Tudor Ambarus
2024-12-05 23:39 ` Daniel Lezcano
2024-12-06 13:28 ` Krzysztof Kozlowski
2024-12-06 19:50 ` Daniel Lezcano
2024-12-08 16:38 ` Markuss Broks
2024-12-09 8:29 ` Krzysztof Kozlowski
2024-12-11 12:13 ` Peter Griffin
2024-12-06 6:47 ` Arnd Bergmann [this message]
2024-12-06 11:59 ` Tudor Ambarus
2024-12-06 13:02 ` Arnd Bergmann
2024-12-05 17:53 ` [PATCH v3 3/3] MAINTAINERS: add entry for the samsung exynos ACPM mailbox protocol Tudor Ambarus
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=427caa87-b9ba-4797-88bd-a18a96eefdcf@app.fastmail.com \
--to=arnd@arndb.de \
--cc=alim.akhtar@samsung.com \
--cc=andre.draszik@linaro.org \
--cc=conor+dt@kernel.org \
--cc=daniel.lezcano@linaro.org \
--cc=devicetree@vger.kernel.org \
--cc=javierm@redhat.com \
--cc=kernel-team@android.com \
--cc=krzk+dt@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-samsung-soc@vger.kernel.org \
--cc=peter.griffin@linaro.org \
--cc=robh@kernel.org \
--cc=tudor.ambarus@linaro.org \
--cc=tzimmermann@suse.de \
--cc=ulf.hansson@linaro.org \
--cc=vincent.guittot@linaro.org \
--cc=willmcvicker@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox