From: Manu Abraham <abraham.manu@gmail.com>
To: Markus Rechberger <mrechberger@gmail.com>
Cc: hermann pitton <hermann-pitton@arcor.de>,
Michael Krufky <mkrufky@linuxtv.org>,
linux-dvb@linuxtv.org, linux-kernel@vger.kernel.org
Subject: Re: [linux-dvb] Re: [video4linux-cvs] [hg:v4l-dvb] Add support for Opera S1- DVB-USB
Date: Fri, 20 Apr 2007 02:51:47 +0400 [thread overview]
Message-ID: <4627F283.6030009@gmail.com> (raw)
In-Reply-To: <d9def9db0704191547l49358b74l9d81304f537fe6d6@mail.gmail.com>
Markus Rechberger wrote:
> On 4/20/07, Manu Abraham <abraham.manu@gmail.com> wrote:
>> hermann pitton wrote:
>> > Am Freitag, den 20.04.2007, 00:55 +0400 schrieb Manu Abraham:
>> >> Mauro Carvalho Chehab wrote:
>> >>> Em Qui, 2007-04-19 às 16:41 -0400, Michael Krufky escreveu:
>> >>>> Marco Gittler wrote:
>> >>>>> this patch has applied the hints from mkrufky (dvb_attach,
>> >>>>> firmware-naming)
>> >>>>> and also one working rewrite of the i2c addresses stuff to fit the
>> >>>>> kernel i2c reqs.
>> >>>>>
>> >>>>> Signed-off-by: Marco Gittler<g.marco@freenet.de>
>> >>>>> diff -r c8b73ec18b42 linux/drivers/media/dvb/dvb-usb/opera1.c
>> >>>>> --- a/linux/drivers/media/dvb/dvb-usb/opera1.c Thu Apr 19
>> 12:04:50
>> 2007 -0300
>> >>>>> +++ b/linux/drivers/media/dvb/dvb-usb/opera1.c Thu Apr 19
>> 20:38:01
>> 2007 +0200
>> >>>>> @@ -25,6 +25,13 @@
>> >>>>> #define REG_20_SYMBOLRATE_BYTE1 0x20
>> >>>>> #define REG_21_SYMBOLRATE_BYTE2 0x21
>> >>>>>
>> >>>>> +#define ADDR_C0_TUNER (0xc0>>1)
>> >>>>> +#define ADDR_D0_PLL (0xd0>>1)
>> >>>>>
>> >>>> I don't like these two #define's. These i2c addresses need only be
>> >>>> specified once, in the config structs / frontendfoo_attach calls for
>> the
>> >>>> tuner / demod.
>> >>>>
>> >>>> Better to just put them in as constants like all of the other dvb
>> drivers.
>> >>> I prefer the way it is. We should really avoid having magic numbers
>> >>> inside the code. The alias here helps to know that 0x60 is tuner
>> addres
>> >>> and 0x68 the pll.
>> >>
>> >> Following a project's coding styles and conventions is "respecting" a
>> >> project
>> >>
>> >> Manu
>> >>
>> >
>> > Hi,
>> >
>> > the other natural place for this should be the LKML to get more _good_
>> > arguments, instead of hanging soon in some "respect" stuff again.
>>
>>
>> DVB drivers generally have device addresses such as tuner_addresses and
>> demod_adresses defined in a config struct least to prevent them from
>> being global, wherever the header is included, since the very same
>> device can have multiple addresses and so on, which are non-probable
>> since being behind a repeater which is switched by a demod (private) and
>> hence.
>>
>> Those are some of the reasons to follow a certain coding
>> style/conventions. They are _not_ for fun.
>>
>
> cat *priv.h says something else too...
> there are also many global register defines in DVB drivers, they just
> don't include the register value in the define name.
*_priv.h from what i understand means private .. i don't know what you
make out from that.
HTH,
Manu
next prev parent reply other threads:[~2007-04-19 22:51 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <E1HeXiw-0001Ct-0o@www.linuxtv.org>
[not found] ` <4627858A.6060209@linuxtv.org>
[not found] ` <4627B959.8070601@freenet.de>
[not found] ` <4627D407.10105@linuxtv.org>
[not found] ` <1177015513.6002.40.camel@matwk009568.brasiltelecom.intra.corp>
[not found] ` <4627D74A.4090304@gmail.com>
2007-04-19 21:58 ` [linux-dvb] Re: [video4linux-cvs] [hg:v4l-dvb] Add support for Opera S1- DVB-USB hermann pitton
2007-04-19 22:43 ` Manu Abraham
2007-04-19 22:47 ` Markus Rechberger
2007-04-19 22:51 ` Manu Abraham [this message]
2007-04-19 23:16 ` hermann pitton
2007-04-19 23:19 ` Manu Abraham
2007-04-19 23:35 ` hermann pitton
2007-04-19 23:42 ` Manu Abraham
2007-04-20 0:00 ` hermann pitton
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4627F283.6030009@gmail.com \
--to=abraham.manu@gmail.com \
--cc=hermann-pitton@arcor.de \
--cc=linux-dvb@linuxtv.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mkrufky@linuxtv.org \
--cc=mrechberger@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox