From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752422AbbJPVmc (ORCPT ); Fri, 16 Oct 2015 17:42:32 -0400 Received: from mout.kundenserver.de ([212.227.126.130]:62558 "EHLO mout.kundenserver.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752300AbbJPVma (ORCPT ); Fri, 16 Oct 2015 17:42:30 -0400 From: Arnd Bergmann To: Joe Perches Cc: Sergei Shtylyov , David Laight , huangdaode , "davem@davemloft.net" , "liguozhu@hisilicon.com" , "Yisen.Zhuang@huawei.com" , "netdev@vger.kernel.org" , "linuxarm@huawei.com" , "salil.mehta@huawei.com" , "kenneth-lee-2012@foxmail.com" , "xuwei5@hisilicon.com" , "lisheng011@huawei.com" , "linux-kernel@vger.kernel.org" , "lipeng321@huawei.com" Subject: Re: [PATCH] net: hix5hd2_gmac: avoid integer overload warning Date: Fri, 16 Oct 2015 23:42:13 +0200 Message-ID: <4681621.hJP5TRRIlS@wuerfel> User-Agent: KMail/4.11.5 (Linux/3.16.0-10-generic; KDE/4.11.5; x86_64; ; ) In-Reply-To: <1445030535.22921.73.camel@perches.com> References: <1444967657-107994-1-git-send-email-huangdaode@hisilicon.com> <562146ED.1030308@cogentembedded.com> <1445030535.22921.73.camel@perches.com> MIME-Version: 1.0 Content-Transfer-Encoding: 7Bit Content-Type: text/plain; charset="us-ascii" X-Provags-ID: V03:K0:jLqnULnIMTZj1HkFcAqZXOUV8buqvCXGGFt7d05u/JSkxzfBg67 2kUvBKxKcEnm9FGrSQCU3iVwHWc448D671c48XyXUp3FRVUl11cQxiCvsk14yZzNUeloWo7 41vsFf5n0UJQAXjbKVHCG6DtbUUFAi6KjVbTlfRmJ5BjhkEa7aYRysKN37WDjS9C2XMM9wX r+ZMTxrvXChmVxY5TClag== X-UI-Out-Filterresults: notjunk:1;V01:K0:Tbfddp6DEbg=:+CADjaCkh/bnOudj1lbkTq wuXypx/Wm0Wxp3LMsqf1uHonTBJpr4p8G3ybyCe5zRdihOaC2PZucAd8D6vzLtOB7kYWXqbg/ ppLvtr550d5iPhg3P+4IqGy0iWKDldqnxY1r9LdYWa4MlgCKRfwZ7f2/Bxorkl81rETbAmf/k NsDLAN2z6b1AGq7vq2uEWtwgFxF5HiEKIZlFUrwPf/7XpQEWfropzKYS3JqkcazB0sFgC0N7f AGJBMMIY3xbCiAIgw9XZs0w4PqgnjEBSHaO9innwAbqFd7leq7ccHFQFsjO+PY6IoW0PB2DGP nKw06U2fZOPuTj+A9LpEOPqPSWNS2L9qz8Vwsw/MhxNgNN7ajpNc7/k/UxU/h74QVu8fmnwnf UaRYs1XnHtQ5UTXJlS75nzIAUUsfVtN42x+bhe2hLdC7+tdrMcs8v08n1BsOt3HR1MqF+yAbp Qmmzg22GkWBJ5nrgm2Cdyvm0bb8ymko3tTnFsIjICDbqy5YWiJxiyCq10epEaJ/pyRd2LjuNn QT8IXqDOjK4L1GAv5fjDkYqZ7dQwAb93db+KUvZ3KOkzQb1qkg4gpHyisvEikz40eXgvsmrhK 6WlFKl5nfSIbtTCDTUIUD68Tbme2ZOowpKzoUXMwjFR40hzJBopTIax8HE+0D5ynF3JnzMePz c/RFmscK2mBQPjOt8POYEuTEjMy2VbSVJSkWZebXzdk094ZNwgAGv6J2FHIuu7POAsAHae0Eb 0YaG+Z7q4hqTW4w0 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Friday 16 October 2015 14:22:15 Joe Perches wrote: > On Fri, 2015-10-16 at 21:50 +0300, Sergei Shtylyov wrote: > > On 10/16/2015 09:04 PM, Joe Perches wrote: > > > > >>>> BITS_RX_EN is an 'unsigned long' constant, so the ones complement of that > > >>>> has bits set that do not fit into a 32-bit variable on 64-bit architectures, > > >>>> which causes a harmless gcc warning: > > >>> ... > > >>>> static void hix5hd2_port_disable(struct hix5hd2_priv *priv) > > >>>> { > > >>>> - writel_relaxed(~(BITS_RX_EN | BITS_TX_EN), priv->base + PORT_EN); > > >>>> + writel_relaxed(~(u32)(BITS_RX_EN | BITS_TX_EN), priv->base + PORT_EN); > > >>>> writel_relaxed(0, priv->base + DESC_WR_RD_ENA); > > >>> > > >>> ISTM that just means that the constants shouldn't be 'long'. > > >> > > >> Right, but that would probably mean changing the BIT() macro or not using it > > >> here. In the past I've argued against using that macro, but I've given > > >> up that fight. > > > > > > Fight on... (Somebody must have gone to USC here) Ok, I'll try: Please stop this nonsense! ;-) > > > There might be value in aefin BIT_U32 macro. > > > Maybe BIT_U64 too. > > > > There's BIT_ULL() already. > > I know, but symmetry is good. > I think there'd be no harm in adding it. > Perhaps adding all the sized variants would be useful. > > Something like: > > #define BIT_OF_TYPE(type, nr) \ > ({ \ > typeof(type) rtn; \ > BUILD_BUG_ON(__builtin_constant_p(nr) && \ > ((nr) < 0 || \ > (nr) >= sizeof(type) * BITS_PER_BYTE)); \ > rtn = ((type)1) << (nr); \ > rtn; \ > }) > > #define BIT_U8(nr) BIT_OF_TYPE(u8, nr) > #define BIT_U16(nr) BIT_OF_TYPE(u16, nr) > #define BIT_U32(nr) BIT_OF_TYPE(u32, nr) > #define BIT_U64(nr) BIT_OF_TYPE(u64, nr) As I said, I'd rather see less uses of BIT() instead of more. While using 'BIT(23)' is often than the open-coded '1 << 23', I wish more people would write that as '0x00800000' instead. It's easier to match with data sheets, and to compare to printk output, plus it's non-ambiguous if you are dealing with data sheets that use the IBM convention of counting the bits from the other end. Arnd