The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Dmitry Osipenko <dmitry.osipenko@collabora.com>
To: Thomas Zimmermann <tzimmermann@suse.de>,
	Hardik Phalet <hardik.phalet@pm.me>
Cc: Hardik Phalet <hardik.phalet@gmail.com>,
	David Airlie <airlied@redhat.com>,
	Gerd Hoffmann <kraxel@redhat.com>,
	Gurchetan Singh <gurchetansingh@chromium.org>,
	Chia-I Wu <olvaffe@gmail.com>,
	Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
	Maxime Ripard <mripard@kernel.org>,
	Simona Vetter <simona@ffwll.ch>,
	dri-devel@lists.freedesktop.org, virtualization@lists.linux.dev,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH] drm/virtio: Open-code drm_simple_encoder_init()
Date: Mon, 2 Mar 2026 16:57:32 +0300	[thread overview]
Message-ID: <4fa6bc36-3507-4171-8955-29c90db9254b@collabora.com> (raw)
In-Reply-To: <5cdb4e34-7964-4456-9311-eac8b3d37371@suse.de>

On 3/2/26 16:48, Thomas Zimmermann wrote:
> Hi
> 
> Am 27.02.26 um 11:35 schrieb Hardik Phalet:
>> drm_simple_encoder_init() is a thin wrapper around drm_encoder_init()
>> that only provides a minimal drm_encoder_funcs instance with
>> .destroy = drm_encoder_cleanup.
>>
>> Inline the helper in virtgpu_display.c and provide a local
>> drm_encoder_funcs instance instead. This removes the unnecessary
>> indirection and prepares for the eventual removal of
>> drm_simple_encoder_init().
>>
>> No functional changes intended.
>>
>> Signed-off-by: Hardik Phalet <hardik.phalet@pm.me>
>> ---
>>   drivers/gpu/drm/virtio/virtgpu_display.c | 7 ++++++-
>>   1 file changed, 6 insertions(+), 1 deletion(-)
>>
>> diff --git a/drivers/gpu/drm/virtio/virtgpu_display.c b/drivers/gpu/
>> drm/virtio/virtgpu_display.c
>> index f1dae9569805..8bd6cdc6c16e 100644
>> --- a/drivers/gpu/drm/virtio/virtgpu_display.c
>> +++ b/drivers/gpu/drm/virtio/virtgpu_display.c
>> @@ -232,6 +232,10 @@ static enum drm_mode_status
>> virtio_gpu_conn_mode_valid(struct drm_connector *con
>>       return MODE_BAD;
>>   }
>>   +static const struct drm_encoder_funcs virtio_gpu_enc_cleanup_funcs = {
>> +    .destroy = drm_encoder_cleanup
>> +};
>> +
>>   static const struct drm_encoder_helper_funcs
>> virtio_gpu_enc_helper_funcs = {
>>       .mode_set   = virtio_gpu_enc_mode_set,
>>       .enable     = virtio_gpu_enc_enable,
>> @@ -306,7 +310,8 @@ static int vgdev_output_init(struct
>> virtio_gpu_device *vgdev, int index)
>>       if (vgdev->has_edid)
>>           drm_connector_attach_edid_property(connector);
>>   -    drm_simple_encoder_init(dev, encoder, DRM_MODE_ENCODER_VIRTUAL);
>> +    drm_encoder_init(dev, encoder, &virtio_gpu_enc_cleanup_funcs,
>> +             DRM_MODE_ENCODER_VIRTUAL, NULL);
> 
> This looks correct, but you should also remove the include statement at [1]
> 
> [1] https://elixir.bootlin.com/linux/v6.19/source/drivers/gpu/drm/
> virtio/virtgpu_display.c#L35

The patch adds more lines than removes. What's wrong with
drm_simple_encoder_init() and why it needs to be removed eventually?

-- 
Best regards,
Dmitry

  reply	other threads:[~2026-03-02 13:58 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-02-27 10:35 [PATCH] drm/virtio: Open-code drm_simple_encoder_init() Hardik Phalet
2026-03-02 13:48 ` Thomas Zimmermann
2026-03-02 13:57   ` Dmitry Osipenko [this message]
2026-03-02 14:15     ` Thomas Zimmermann
2026-03-02 15:31       ` Dmitry Osipenko
2026-03-02 15:40         ` Thomas Zimmermann
2026-03-03 23:51           ` Dmitry Osipenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4fa6bc36-3507-4171-8955-29c90db9254b@collabora.com \
    --to=dmitry.osipenko@collabora.com \
    --cc=airlied@redhat.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=gurchetansingh@chromium.org \
    --cc=hardik.phalet@gmail.com \
    --cc=hardik.phalet@pm.me \
    --cc=kraxel@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=maarten.lankhorst@linux.intel.com \
    --cc=mripard@kernel.org \
    --cc=olvaffe@gmail.com \
    --cc=simona@ffwll.ch \
    --cc=tzimmermann@suse.de \
    --cc=virtualization@lists.linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox