The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Jiri Slaby <jirislaby@kernel.org>
To: Sherry Sun <sherry.sun@nxp.com>, gregkh@linuxfoundation.org
Cc: linux-serial@vger.kernel.org, linux-kernel@vger.kernel.org,
	imx@lists.linux.dev, shenwei.wang@nxp.com
Subject: Re: [PATCH 1/2] tty: serial: fsl_lpuart: Use u32 for register variables
Date: Fri, 7 Mar 2025 08:25:31 +0100	[thread overview]
Message-ID: <52c99f0a-670c-4e76-a30d-cdb9cb0e83e7@kernel.org> (raw)
In-Reply-To: <20250307022547.1000293-2-sherry.sun@nxp.com>

On 07. 03. 25, 3:25, Sherry Sun wrote:
> Use u32 rather than unsigned long for register variables for clarity and
> consistency.
> 
> Signed-off-by: Sherry Sun <sherry.sun@nxp.com>
> ---
>   drivers/tty/serial/fsl_lpuart.c | 54 ++++++++++++++++-----------------
>   1 file changed, 27 insertions(+), 27 deletions(-)
> 
> diff --git a/drivers/tty/serial/fsl_lpuart.c b/drivers/tty/serial/fsl_lpuart.c
> index 4dc2f3e2b8e0..888d744494d6 100644
> --- a/drivers/tty/serial/fsl_lpuart.c
> +++ b/drivers/tty/serial/fsl_lpuart.c
> @@ -450,7 +450,7 @@ static void lpuart_stop_tx(struct uart_port *port)
>   
>   static void lpuart32_stop_tx(struct uart_port *port)
>   {
> -	unsigned long temp;
> +	u32 temp;

This patch is fine per se. But could you also rename these temps to 
something sane? (In a separate patch.) Like ctrl in this case.

thanks,
-- 
js
suse labs

  reply	other threads:[~2025-03-07  7:25 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-03-07  2:25 [PATCH 0/2] tty: serial: fsl_lpuart: cleanup lpuart driver Sherry Sun
2025-03-07  2:25 ` [PATCH 1/2] tty: serial: fsl_lpuart: Use u32 for register variables Sherry Sun
2025-03-07  7:25   ` Jiri Slaby [this message]
2025-03-07  8:02     ` Sherry Sun
2025-03-07  2:25 ` [PATCH 2/2] tty: serial: fsl_lpuart: use port struct directly to simply code Sherry Sun

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=52c99f0a-670c-4e76-a30d-cdb9cb0e83e7@kernel.org \
    --to=jirislaby@kernel.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=imx@lists.linux.dev \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-serial@vger.kernel.org \
    --cc=shenwei.wang@nxp.com \
    --cc=sherry.sun@nxp.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox