The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Arnd Bergmann <arnd@arndb.de>
To: Joseph Myers <joseph@codesourcery.com>
Cc: Chris Metcalf <cmetcalf@ezchip.com>,
	linux-arm-kernel@lists.infradead.org,
	bamvor.zhangjian@huawei.com, Andrew Pinski <pinskia@gmail.com>,
	"Kapoor, Prasun" <Prasun.Kapoor@caviumnetworks.com>,
	Andreas Schwab <schwab@suse.de>,
	Nathan Lynch <Nathan_Lynch@mentor.com>,
	LKML <linux-kernel@vger.kernel.org>,
	Alexander Graf <agraf@suse.de>,
	Alexey Klimov <klimov.linux@gmail.com>,
	broonie@kernel.org, Yury Norov <ynorov@caviumnetworks.com>,
	Andrew Pinski <apinski@cavium.com>,
	David Daney <ddaney.cavm@gmail.com>,
	Catalin Marinas <catalin.marinas@arm.com>,
	Jan Dakinevich <jan.dakinevich@gmail.com>,
	Philipp Tomsich <philipp.tomsich@theobroma-systems.com>,
	Andrey Konovalov <andrey.konovalov@linaro.org>,
	christoph.muellner@theobroma-systems.com,
	Mike Frysinger <vapier@gentoo.org>,
	Paul Eggert <eggert@cs.ucla.edu>, Rich Felker <dalias@libc.org>
Subject: Re: [PATCH v6 13/17] arm64:ilp32: add sys_ilp32.c and a separate table (in entry.S) to use it
Date: Mon, 16 Nov 2015 13:12:02 +0100	[thread overview]
Message-ID: <5753873.3bKWvUrKmj@wuerfel> (raw)
In-Reply-To: <alpine.DEB.2.10.1511161159290.25844@digraph.polyomino.org.uk>

On Monday 16 November 2015 12:03:09 Joseph Myers wrote:
> On Mon, 16 Nov 2015, Arnd Bergmann wrote:
> 
> > There are two separate aspects here:
> > 
> > a) leave out the support for all __off_t based syscalls (__ftruncate,
> >    __lseek, __lxstat, __pread, __preadv, __pwrite, __pwritev, __truncate,
> >    __xstat) as they are no longer needed, and change the handling of
> >    _FILE_OFFSET_BITS so that we default to 64 and error out for anything
> >    else.
> >    This needs to be done for all new 32-bit architectures if you think we
> >    should use a 64-bit off_t from now on, it's not arm64 specific.
> 
> It's not a matter of leaving anything out - these would simply use 64-bit 
> off_t (__off_t and __off64_t would be the same type) and the *64 versions 
> would be aliases, exactly the same as on 64-bit architectures.  (And 
> _FILE_OFFSET_BITS handling would also be exactly the same as on 64-bit 
> architectures.)  I see no reason for the set of off_t-related symbols that 
> exist, or which symbols are aliases of which others, to vary between pure 
> 64-bit systems and ILP32 ABIs (for 32-bit or 64-bit architectures) that 
> simply happen to have had 64-bit off_t from the start.

Ok, fair enough. So we just change the global __OFF_T_TYPE definition
in bits/typesizes.h and override it for all the existing 32-bit ports,
correct?

	Arnd

  reply	other threads:[~2015-11-16 12:14 UTC|newest]

Thread overview: 61+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-11-02 23:30 [RFC PATCH v6 00/17] ILP32 for ARM64 Yury Norov
2015-11-02 23:30 ` [PATCH v6 01/17] arm64:ilp32: add documentation on the ILP32 ABI " Yury Norov
2015-11-05 14:33   ` Arnd Bergmann
2015-11-02 23:30 ` [PATCH v6 02/17] arm64: ensure the kernel is compiled for LP64 Yury Norov
2015-11-02 23:30 ` [PATCH v6 03/17] arm64: rename COMPAT to AARCH32_EL0 in Kconfig Yury Norov
2015-11-02 23:30 ` [PATCH v6 04/17] arm64: change some CONFIG_COMPAT over to use CONFIG_AARCH32_EL0 instead Yury Norov
2015-11-02 23:30 ` [PATCH v6 05/17] arm64:ilp32: share signal structures between ILP32 and LP64 ABIs Yury Norov
2015-11-02 23:30 ` [PATCH v6 06/17] arm64: introduce is_a32_task and is_a32_thread (for AArch32 compat) Yury Norov
2015-11-02 23:30 ` [PATCH v6 07/17] arm64:ilp32: add is_ilp32_compat_{task,thread} and TIF_32BIT_AARCH64 Yury Norov
2015-11-02 23:30 ` [PATCH v6 08/17] arm64:ilp32: share HWCAP between LP64 and ILP32 Yury Norov
2015-11-02 23:30 ` [PATCH v6 09/17] arm64:ilp32 use the native LP64 'start_thread' for ILP32 threads Yury Norov
2015-11-02 23:30 ` [PATCH v6 10/17] arm64:ilp32: support core dump generation for ILP32 Yury Norov
2015-11-02 23:30 ` [PATCH v6 11/17] ptrace: Allow compat to use the native siginfo Yury Norov
2015-11-05 13:53   ` Arnd Bergmann
2015-11-02 23:30 ` [PATCH v6 12/17] ilp32: common 32-bit wrappers Yury Norov
2015-11-02 23:30 ` [PATCH v6 13/17] arm64:ilp32: add sys_ilp32.c and a separate table (in entry.S) to use it Yury Norov
2015-11-05 13:50   ` Arnd Bergmann
2015-11-11 17:54   ` Andreas Schwab
2015-11-11 20:40     ` Arnd Bergmann
2015-11-11 23:07       ` Andreas Schwab
2015-11-11 23:23         ` Arnd Bergmann
2015-11-12  8:58           ` Andreas Schwab
2015-11-12  9:22             ` Arnd Bergmann
2015-11-12  9:44               ` Andreas Schwab
2015-11-12 13:24                 ` Arnd Bergmann
2015-11-12 13:47                   ` Andreas Schwab
2015-11-13 15:34                     ` Arnd Bergmann
2015-11-13 15:38                       ` Andrew Pinski
2015-11-13 16:10                         ` Arnd Bergmann
2015-11-15 15:18                           ` Arnd Bergmann
2015-11-15 16:42                             ` Chris Metcalf
2015-11-16 10:16                               ` Joseph Myers
2015-11-16 11:00                                 ` Arnd Bergmann
2015-11-16 11:12                                   ` Joseph Myers
2015-11-16 11:40                                     ` Arnd Bergmann
2015-11-16 12:03                                       ` Joseph Myers
2015-11-16 12:12                                         ` Arnd Bergmann [this message]
2015-11-16 12:34                                           ` Joseph Myers
2015-11-16 13:15                                             ` Arnd Bergmann
2015-11-16 13:34                                               ` Andreas Schwab
2015-11-16 13:54                                                 ` Arnd Bergmann
2015-11-02 23:30 ` [PATCH v6 14/17] aarch64: ilp32: use generic stat64 structure Yury Norov
2015-11-05 14:03   ` Arnd Bergmann
2015-11-02 23:30 ` [PATCH v6 15/17] arm64:ilp32: use the native siginfo instead of the compat siginfo Yury Norov
2015-11-02 23:30 ` [PATCH v6 16/17] arm64:ilp32: change COMPAT_ELF_PLATFORM to report a a subplatform for ILP32 Yury Norov
2015-11-02 23:30 ` [PATCH v6 17/17] arm64:ilp32: add ARM64_ILP32 to Kconfig Yury Norov
2015-11-05 11:36 ` [RFC PATCH v6 00/17] ILP32 for ARM64 Andreas Schwab
2015-11-05 13:39   ` Andrew Pinski
2015-11-05 22:18     ` Yury Norov
2015-11-09 10:01       ` Andreas Schwab
2015-11-11  7:16         ` Zhangjian (Bamvor)
2015-11-11  8:44           ` Andreas Schwab
2015-11-09 13:23       ` Andreas Schwab
2015-11-09 14:21         ` Arnd Bergmann
2015-11-09 14:33           ` Andreas Schwab
2015-11-09 14:36             ` Arnd Bergmann
2015-11-09 14:52               ` pinskia
2015-11-09 15:50                 ` Yury Norov
2015-11-09 16:04                   ` Yury Norov
2015-12-01 22:55 ` Iosif Harutyunov
2015-12-03 17:05   ` Yury Norov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5753873.3bKWvUrKmj@wuerfel \
    --to=arnd@arndb.de \
    --cc=Nathan_Lynch@mentor.com \
    --cc=Prasun.Kapoor@caviumnetworks.com \
    --cc=agraf@suse.de \
    --cc=andrey.konovalov@linaro.org \
    --cc=apinski@cavium.com \
    --cc=bamvor.zhangjian@huawei.com \
    --cc=broonie@kernel.org \
    --cc=catalin.marinas@arm.com \
    --cc=christoph.muellner@theobroma-systems.com \
    --cc=cmetcalf@ezchip.com \
    --cc=dalias@libc.org \
    --cc=ddaney.cavm@gmail.com \
    --cc=eggert@cs.ucla.edu \
    --cc=jan.dakinevich@gmail.com \
    --cc=joseph@codesourcery.com \
    --cc=klimov.linux@gmail.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=philipp.tomsich@theobroma-systems.com \
    --cc=pinskia@gmail.com \
    --cc=schwab@suse.de \
    --cc=vapier@gentoo.org \
    --cc=ynorov@caviumnetworks.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox