From: "David Hildenbrand (Arm)" <david@kernel.org>
To: "Lorenzo Stoakes (ARM)" <ljs@kernel.org>,
Pedro Falcato <pfalcato@suse.de>
Cc: Andrew Morton <akpm@linux-foundation.org>,
"Liam R. Howlett" <liam@infradead.org>,
Vlastimil Babka <vbabka@kernel.org>, Jann Horn <jannh@google.com>,
Alexander Viro <viro@zeniv.linux.org.uk>,
Christian Brauner <brauner@kernel.org>, Jan Kara <jack@suse.cz>,
Kees Cook <kees@kernel.org>, Mike Rapoport <rppt@kernel.org>,
Suren Baghdasaryan <surenb@google.com>,
Michal Hocko <mhocko@suse.com>,
linux-mm@kvack.org, linux-kernel@vger.kernel.org,
linux-fsdevel@vger.kernel.org
Subject: Re: [PATCH 2/3] mm/mseal: limit scope of mseal address zero to address zero
Date: Fri, 17 Jul 2026 11:41:11 +0100 [thread overview]
Message-ID: <58bca89b-e3a8-4207-8ee7-63ab04916443@kernel.org> (raw)
In-Reply-To: <alj1Cyt4JvbVM7tB@lucifer>
>>
>>> {
>>> struct vm_area_struct *vma, *prev;
>>> VMA_ITERATOR(vmi, current->mm, start);
>>> @@ -66,6 +66,38 @@ static int mseal_apply(unsigned long start, unsigned long end)
>>> return 0;
>>> }
>>>
>>> +static int mseal(unsigned long start, unsigned long end)
>>
>> I don't like that you go start - end on a function called "mseal". The actual
>> system call goes start - len. It just looks confusing :) So either rename it
>> to mseal_range(), or make it take a start, length pair.
>
> I'm not sure I really understand the confusion (I suppose you're equally
> confused by the lack of flags parameter?),
>
> I find it silly that we avoid function names because a system call of the same
> name exists.
>
> But I guess I can rename it to mseal_range() since I don't want the series
> blocked on silly naming issues.
I think we typically have a XXX call do_XXX, like with mprotect(). But not sure
if there is a real rule to that, I'm sure there are exceptions. At least it's
only an internal helper.
Just like with the "__*" functions, sometimes it indeed helps to just have a
better description that shows the difference. But sometimes it's just really
hard to name or restructure stuff.
I think the page fault logic is especially hard to follow with things like
do_fault() and __do_fault(), whereby we have another layer of do_read_fault()
etc in-between :)
--
Cheers,
David
next prev parent reply other threads:[~2026-07-17 10:41 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-16 13:43 [PATCH 0/3] mm/mseal: further cleanups Lorenzo Stoakes (ARM)
2026-07-16 13:43 ` [PATCH 1/3] mm/mseal: remove superfluous comments, fix confusion around mm Lorenzo Stoakes (ARM)
2026-07-16 15:00 ` Pedro Falcato
2026-07-17 10:33 ` David Hildenbrand (Arm)
2026-07-17 10:44 ` Lorenzo Stoakes (ARM)
2026-07-16 13:43 ` [PATCH 2/3] mm/mseal: limit scope of mseal address zero to address zero Lorenzo Stoakes (ARM)
2026-07-16 15:06 ` Pedro Falcato
2026-07-16 15:38 ` Lorenzo Stoakes (ARM)
2026-07-17 10:41 ` David Hildenbrand (Arm) [this message]
2026-07-17 10:51 ` Lorenzo Stoakes (ARM)
2026-07-17 10:46 ` David Hildenbrand (Arm)
2026-07-17 10:49 ` David Hildenbrand (Arm)
2026-07-17 10:52 ` Lorenzo Stoakes (ARM)
2026-07-16 13:43 ` [PATCH 3/3] mm/mseal: remove further superfluous comments, do_mseal() Lorenzo Stoakes (ARM)
2026-07-16 15:09 ` Pedro Falcato
2026-07-16 15:13 ` Lorenzo Stoakes (ARM)
2026-07-17 0:33 ` Andrew Morton
2026-07-17 11:06 ` Lorenzo Stoakes (ARM)
2026-07-17 10:50 ` David Hildenbrand (Arm)
2026-07-17 10:55 ` Lorenzo Stoakes (ARM)
2026-07-16 13:48 ` [PATCH 0/3] mm/mseal: further cleanups Lorenzo Stoakes (ARM)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=58bca89b-e3a8-4207-8ee7-63ab04916443@kernel.org \
--to=david@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=brauner@kernel.org \
--cc=jack@suse.cz \
--cc=jannh@google.com \
--cc=kees@kernel.org \
--cc=liam@infradead.org \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=ljs@kernel.org \
--cc=mhocko@suse.com \
--cc=pfalcato@suse.de \
--cc=rppt@kernel.org \
--cc=surenb@google.com \
--cc=vbabka@kernel.org \
--cc=viro@zeniv.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox