From: Bart Van Assche <bvanassche@acm.org>
To: JiangJianJun <jiangjianjun3@huawei.com>,
jejb@linux.ibm.com, martin.petersen@oracle.com,
linux-scsi@vger.kernel.org
Cc: hare@suse.de, linux-kernel@vger.kernel.org,
lixiaokeng@huawei.com, hewenliang4@huawei.com,
yangkunlin7@huawei.com
Subject: Re: [RFC PATCH v3 01/19] scsi: scsi_error: Define framework for LUN/target based error handle
Date: Thu, 13 Mar 2025 18:49:04 -0700 [thread overview]
Message-ID: <58ddc052-039b-4b9f-b0b2-102f16da5d47@acm.org> (raw)
In-Reply-To: <20250314012927.150860-2-jiangjianjun3@huawei.com>
On 3/13/25 6:29 PM, JiangJianJun wrote:
> diff --git a/drivers/scsi/scsi_error.c b/drivers/scsi/scsi_error.c
> index 815e7d63f3e2..f89de23a6807 100644
> --- a/drivers/scsi/scsi_error.c
> +++ b/drivers/scsi/scsi_error.c
> @@ -291,11 +291,48 @@ static void scsi_eh_inc_host_failed(struct rcu_head *head)
> spin_unlock_irqrestore(shost->host_lock, flags);
> }
>
Please move the new-style error handling functions into a new file.
scsi_error.c is already way too big. Mixing host-based and device-based
error handling in a single file is confusing. Please don't do this.
> +#define SCSI_EH_NO_HANDLER 1
This should be a new enumeration type instead of a define.
> /**
> * scsi_eh_scmd_add - add scsi cmd to error handling.
> * @scmd: scmd to run eh on.
> */
> -void scsi_eh_scmd_add(struct scsi_cmnd *scmd)
> +static void __scsi_eh_scmd_add(struct scsi_cmnd *scmd)
Please choose a better name for this function than __scsi_eh_scmd_add().
> +void scsi_eh_scmd_add(struct scsi_cmnd *scmd)
> +{
> + struct scsi_device *sdev = scmd->device;
> + struct scsi_target *starget = scsi_target(sdev);
> + struct Scsi_Host *shost = sdev->host;
> +
> + if (unlikely(scsi_host_in_recovery(shost)))
> + __scsi_eh_scmd_add(scmd);
> +
> + if (unlikely(scsi_target_in_recovery(starget)))
> + if (__scsi_eh_scmd_add_starget(scmd))
> + __scsi_eh_scmd_add(scmd);
> +
> + if (__scsi_eh_scmd_add_sdev(scmd))
> + if (__scsi_eh_scmd_add_starget(scmd))
> + __scsi_eh_scmd_add(scmd);
> +}
Please rename the function __scsi_eh_scmd_add() to make it clear that it
is used for the host-based error handling strategey.
> +static inline int scsi_device_in_recovery(struct scsi_device *sdev)
> +{
> + struct scsi_device_eh *eh = sdev->eh;
> +
> + if (eh && eh->is_busy)
> + return eh->is_busy(sdev);
> + return 0;
> +}
Can the return type of this function be changed into 'bool'? Can the
three statements in the function body be combined into the following
statement?
return eh && eh->is_busy && eh->is_busy(sdev);
> +static inline int scsi_target_in_recovery(struct scsi_target *starget)
> +{
> + struct scsi_target_eh *eh = starget->eh;
> +
> + if (eh && eh->is_busy)
> + return eh->is_busy(starget);
> + return 0;
> +}
Same questions here.
> +struct scsi_device_eh {
> + /*
> + * add scsi command to error handler so it would be handuled by
> + * driver's error handle strategy
> + */
> + void (*add_cmnd)(struct scsi_cmnd *scmd);
> +
> + /*
> + * to judge if the device is busy handling errors, called before
> + * dispatch scsi cmnd
> + *
> + * return 0 if it's ready to accepy scsi cmnd
> + * return 0 if it's in error handle, command's would not be dispatched
> + */
> + int (*is_busy)(struct scsi_device *sdev);
> +
> + /*
> + * wakeup device's error handle
> + *
> + * usually the error handler strategy would not run at once when
> + * error command is added. This function would be called when any
> + * scsi cmnd is finished or when scsi cmnd is added.
> + */
> + int (*wakeup)(struct scsi_device *sdev);
> +
> + /*
> + * data entity for device specific error handler
> + */
> + unsigned long driver_data[];
> +};
Adding unsigned long driver_data[] at the end of a structure is the old
way for extending a structure. Please don't do this. Instead, leave out
the driver_data[] array, embed the scsi_device_eh in a larger data
structure where necessary and use container_of() to convert
scsi_device_eh pointers into a pointer to the containing structure.
Thanks,
Bart.
next prev parent reply other threads:[~2025-03-14 1:49 UTC|newest]
Thread overview: 29+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-03-14 1:29 [RFC PATCH v3 00/19] scsi: scsi_error: Introduce new error handle mechanism JiangJianJun
2025-03-14 1:29 ` [RFC PATCH v3 01/19] scsi: scsi_error: Define framework for LUN/target based error handle JiangJianJun
2025-03-14 1:49 ` Bart Van Assche [this message]
2025-03-14 1:29 ` [RFC PATCH v3 02/19] scsi: scsi_error: Move complete variable eh_action from shost to sdevice JiangJianJun
2025-03-14 1:29 ` [RFC PATCH v3 03/19] scsi: scsi_error: Check if to do reset in scsi_try_xxx_reset JiangJianJun
2025-03-14 1:29 ` [RFC PATCH v3 04/19] scsi: scsi_error: Add helper scsi_eh_sdev_stu to do START_UNIT JiangJianJun
2025-04-24 9:27 ` Diangang Li
2025-03-14 1:29 ` [RFC PATCH v3 05/19] scsi: scsi_error: Add helper scsi_eh_sdev_reset to do lun reset JiangJianJun
2025-03-14 1:29 ` [RFC PATCH v3 06/19] scsi: scsi_error: Add flags to mark error handle steps has done JiangJianJun
2025-03-14 1:29 ` [RFC PATCH v3 07/19] scsi: scsi_error: Add helper to handle scsi device's error command list JiangJianJun
2025-03-14 1:29 ` [RFC PATCH v3 08/19] scsi: scsi_error: Add a general LUN based error handler JiangJianJun
2025-03-14 1:29 ` [RFC PATCH v3 09/19] scsi: core: increase/decrease target_busy without check can_queue JiangJianJun
2025-03-14 1:35 ` Bart Van Assche
2025-03-14 1:29 ` [RFC PATCH v3 10/19] scsi: scsi_error: Add helper to handle scsi target's error command list JiangJianJun
2025-03-14 1:29 ` [RFC PATCH v3 11/19] scsi: scsi_error: Add a general target based error handler JiangJianJun
2025-03-14 1:29 ` [RFC PATCH v3 12/19] scsi: scsi_debug: Add param to control LUN bassed " JiangJianJun
2025-03-14 1:29 ` [RFC PATCH v3 13/19] scsi: scsi_debug: Add param to control target based error handle JiangJianJun
2025-03-14 1:29 ` [RFC PATCH v3 14/19] scsi: mpt3sas: Add param to control LUN " JiangJianJun
2025-03-14 1:29 ` [RFC PATCH v3 15/19] scsi: mpt3sas: Add param to control target " JiangJianJun
2025-03-14 1:29 ` [RFC PATCH v3 16/19] scsi: smartpqi: Add param to control LUN " JiangJianJun
2025-03-14 1:29 ` [RFC PATCH v3 17/19] scsi: megaraid_sas: Add param to control target " JiangJianJun
2025-03-14 1:29 ` [RFC PATCH v3 18/19] scsi: virtio_scsi: Add param to control LUN " JiangJianJun
2025-03-14 1:29 ` [RFC PATCH v3 19/19] scsi: iscsi_tcp: " JiangJianJun
2025-03-14 9:01 ` [RFC PATCH v3 00/19] scsi: scsi_error: Introduce new error handle mechanism Hannes Reinecke
2025-03-14 15:55 ` Bart Van Assche
2025-04-24 9:44 ` Diangang Li
2025-03-20 6:05 ` Christoph Hellwig
2025-03-31 3:10 ` 答复: " Jiangjianjun
2025-03-31 7:50 ` John Garry
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=58ddc052-039b-4b9f-b0b2-102f16da5d47@acm.org \
--to=bvanassche@acm.org \
--cc=hare@suse.de \
--cc=hewenliang4@huawei.com \
--cc=jejb@linux.ibm.com \
--cc=jiangjianjun3@huawei.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
--cc=lixiaokeng@huawei.com \
--cc=martin.petersen@oracle.com \
--cc=yangkunlin7@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox