From: Hans Zhang <18255117159@163.com>
To: "Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>
Cc: lpieralisi@kernel.org, bhelgaas@google.com,
manivannan.sadhasivam@linaro.org, kw@linux.com,
cassel@kernel.org, robh@kernel.org, jingoohan1@gmail.com,
linux-pci@vger.kernel.org, LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v12 2/6] PCI: Clean up __pci_find_next_cap_ttl() readability
Date: Tue, 3 Jun 2025 23:42:16 +0800 [thread overview]
Message-ID: <5ce7f320-7a50-475a-9406-ace4af47192b@163.com> (raw)
In-Reply-To: <987609ec-7a1b-057c-1e3b-8bf564965036@linux.intel.com>
On 2025/6/3 17:30, Ilpo Järvinen wrote:
> On Thu, 15 May 2025, Hans Zhang wrote:
>
>> Refactor the __pci_find_next_cap_ttl() to improve code clarity:
>> - Replace magic number 0x40 with PCI_STD_HEADER_SIZEOF.
>> - Use ALIGN_DOWN() for position alignment instead of manual bitmask.
>> - Extract PCI capability fields via FIELD_GET() with standardized masks.
>> - Add necessary headers (linux/align.h).
>>
>> The changes are purely non-functional cleanups, ensuring behavior remains
>> identical to the original implementation.
>
> If you want a simpler wording for this, this is often used:
>
> No functional changes intended.
Dear Ilpo,
Will change.
>
>>
>> Signed-off-by: Hans Zhang <18255117159@163.com>
>> ---
>> Changes since v11:
>> - None
>>
>> Changes since v10:
>> - Remove #include <uapi/linux/pci_regs.h> and add macro definition comments.
>>
>> Changes since v9:
>> - None
>>
>> Changes since v8:
>> - Split into patch 1/6, patch 2/6.
>> - The
>> ---
>> drivers/pci/pci.c | 9 +++++----
>> include/uapi/linux/pci_regs.h | 2 ++
>> 2 files changed, 7 insertions(+), 4 deletions(-)
>>
>> diff --git a/drivers/pci/pci.c b/drivers/pci/pci.c
>> index e77d5b53c0ce..27d2adb18a30 100644
>> --- a/drivers/pci/pci.c
>> +++ b/drivers/pci/pci.c
>> @@ -9,6 +9,7 @@
>> */
>>
>> #include <linux/acpi.h>
>> +#include <linux/align.h>
>> #include <linux/kernel.h>
>> #include <linux/delay.h>
>> #include <linux/dmi.h>
>> @@ -432,17 +433,17 @@ static u8 __pci_find_next_cap_ttl(struct pci_bus *bus, unsigned int devfn,
>> pci_bus_read_config_byte(bus, devfn, pos, &pos);
>>
>> while ((*ttl)--) {
>> - if (pos < 0x40)
>> + if (pos < PCI_STD_HEADER_SIZEOF)
>> break;
>> - pos &= ~3;
>> + pos = ALIGN_DOWN(pos, 4);
>> pci_bus_read_config_word(bus, devfn, pos, &ent);
>>
>> - id = ent & 0xff;
>> + id = FIELD_GET(PCI_CAP_ID_MASK, ent);
>> if (id == 0xff)
>> break;
>> if (id == cap)
>> return pos;
>> - pos = (ent >> 8);
>> + pos = FIELD_GET(PCI_CAP_LIST_NEXT_MASK, ent);
>> }
>> return 0;
>> }
>> diff --git a/include/uapi/linux/pci_regs.h b/include/uapi/linux/pci_regs.h
>> index ba326710f9c8..35051f9ac16a 100644
>> --- a/include/uapi/linux/pci_regs.h
>> +++ b/include/uapi/linux/pci_regs.h
>> @@ -206,6 +206,8 @@
>> /* 0x48-0x7f reserved */
>>
>> /* Capability lists */
>> +#define PCI_CAP_ID_MASK 0x00ff /* Capability ID mask */
>> +#define PCI_CAP_LIST_NEXT_MASK 0xff00 /* Next Capability Pointer mask */
>>
>> #define PCI_CAP_LIST_ID 0 /* Capability ID */
>
> I'd add those here with the extra space before name and add empty line in
> between them and the capability id list.
>
Will change.
Best regards,
Hans
>> #define PCI_CAP_ID_PM 0x01 /* Power Management */
>>
>
next prev parent reply other threads:[~2025-06-03 15:42 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-14 16:12 [PATCH v12 0/6] Refactor capability search into common macros Hans Zhang
2025-05-14 16:12 ` [PATCH v12 1/6] PCI: Introduce generic bus config read helper function Hans Zhang
2025-06-03 9:18 ` Ilpo Järvinen
2025-06-03 9:21 ` Ilpo Järvinen
2025-06-03 15:41 ` Hans Zhang
2025-06-03 15:40 ` Hans Zhang
2025-05-14 16:12 ` [PATCH v12 2/6] PCI: Clean up __pci_find_next_cap_ttl() readability Hans Zhang
2025-06-03 9:30 ` Ilpo Järvinen
2025-06-03 15:42 ` Hans Zhang [this message]
2025-05-14 16:12 ` [PATCH v12 3/6] PCI: Refactor capability search into common macros Hans Zhang
2025-06-03 9:38 ` Ilpo Järvinen
2025-06-03 15:55 ` Hans Zhang
2025-05-14 16:12 ` [PATCH v12 4/6] PCI: dwc: Use common PCI host bridge APIs for finding the capabilities Hans Zhang
2025-06-03 9:42 ` Ilpo Järvinen
2025-06-03 15:58 ` Hans Zhang
2025-05-14 16:12 ` [PATCH v12 5/6] PCI: cadence: " Hans Zhang
2025-05-14 16:12 ` [PATCH v12 6/6] PCI: cadence: Use cdns_pcie_find_*capability to avoid hardcode Hans Zhang
2025-06-03 9:49 ` Ilpo Järvinen
2025-06-03 16:00 ` Hans Zhang
2025-05-26 14:53 ` [PATCH v12 0/6] Refactor capability search into common macros Hans Zhang
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5ce7f320-7a50-475a-9406-ace4af47192b@163.com \
--to=18255117159@163.com \
--cc=bhelgaas@google.com \
--cc=cassel@kernel.org \
--cc=ilpo.jarvinen@linux.intel.com \
--cc=jingoohan1@gmail.com \
--cc=kw@linux.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=lpieralisi@kernel.org \
--cc=manivannan.sadhasivam@linaro.org \
--cc=robh@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox