From: Reinette Chatre <reinette.chatre@intel.com>
To: James Morse <james.morse@arm.com>, <x86@kernel.org>,
<linux-kernel@vger.kernel.org>
Cc: Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
H Peter Anvin <hpa@zytor.com>, Babu Moger <Babu.Moger@amd.com>,
<shameerali.kolothum.thodi@huawei.com>,
"D Scott Phillips OS" <scott@os.amperecomputing.com>,
<carl@os.amperecomputing.com>, <lcherian@marvell.com>,
<bobo.shaobowang@huawei.com>, <tan.shaopeng@fujitsu.com>,
<baolin.wang@linux.alibaba.com>,
Jamie Iles <quic_jiles@quicinc.com>,
Xin Hao <xhao@linux.alibaba.com>, <peternewman@google.com>,
<dfustini@baylibre.com>, <amitsinght@marvell.com>,
David Hildenbrand <david@redhat.com>,
Rex Nie <rex.nie@jaguarmicro.com>,
"Dave Martin" <dave.martin@arm.com>, Koba Ko <kobak@nvidia.com>,
Shanker Donthineni <sdonthineni@nvidia.com>,
<fenghuay@nvidia.com>
Subject: Re: [PATCH v11 25/30] x86,fs/resctrl: Move the resctrl filesystem code to live in /fs/resctrl
Date: Tue, 13 May 2025 14:26:30 -0700 [thread overview]
Message-ID: <87bc7b73-aed0-4886-bcc5-b025a8444a26@intel.com> (raw)
In-Reply-To: <20250513171547.15194-26-james.morse@arm.com>
Hi James,
On 5/13/25 10:15 AM, James Morse wrote:
> Resctrl is a filesystem interface to hardware that provides cache
> allocation policy and bandwidth control for groups of tasks or CPUs.
>
> To support more than one architecture, resctrl needs to live in /fs/.
>
> Move the code that is concerned with the filesystem interface to
> /fs/resctrl.
>
> Signed-off-by: James Morse <james.morse@arm.com>
> ---
Reviewed-by: Reinette Chatre <reinette.chatre@intel.com>
Reinette
next prev parent reply other threads:[~2025-05-13 21:26 UTC|newest]
Thread overview: 59+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-13 17:15 [PATCH v11 00/30] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl James Morse
2025-05-13 17:15 ` [PATCH v11 01/30] cpumask: relax cpumask_any_but() James Morse
2025-05-14 19:54 ` Fenghua Yu
2025-05-13 17:15 ` [PATCH v11 02/30] find: add find_first_andnot_bit() James Morse
2025-05-14 19:54 ` Fenghua Yu
2025-05-14 19:59 ` Fenghua Yu
2025-05-14 20:19 ` Reinette Chatre
2025-05-14 23:20 ` Fenghua Yu
2025-05-13 17:15 ` [PATCH v11 03/30] cpumask: add cpumask_{first,next}_andnot() API James Morse
2025-05-14 20:01 ` Fenghua Yu
2025-05-13 17:15 ` [PATCH v11 04/30] x86/resctrl: Optimize cpumask_any_housekeeping() James Morse
2025-05-14 20:03 ` Fenghua Yu
2025-05-13 17:15 ` [PATCH v11 05/30] x86/resctrl: Remove the limit on the number of CLOSID James Morse
2025-05-13 17:15 ` [PATCH v11 06/30] x86/resctrl: Rename resctrl_sched_in() to begin with "resctrl_arch_" James Morse
2025-05-13 17:15 ` [PATCH v11 07/30] x86/resctrl: Check all domains are offline in resctrl_exit() James Morse
2025-05-13 21:18 ` Reinette Chatre
2025-05-14 23:37 ` Fenghua Yu
2025-05-13 17:15 ` [PATCH v11 08/30] x86/resctrl: resctrl_exit() teardown resctrl but leave the mount point James Morse
2025-05-14 23:38 ` Fenghua Yu
2025-05-13 17:15 ` [PATCH v11 09/30] x86/resctrl: Drop __init/__exit on assorted symbols James Morse
2025-05-13 17:15 ` [PATCH v11 10/30] x86/resctrl: Move is_mba_sc() out of core.c James Morse
2025-05-13 17:15 ` [PATCH v11 11/30] x86/resctrl: Add end-marker to the resctrl_event_id enum James Morse
2025-05-15 0:09 ` Fenghua Yu
2025-05-13 17:15 ` [PATCH v11 12/30] x86/resctrl: Expand the width of domid by replacing mon_data_bits James Morse
2025-05-15 0:10 ` Fenghua Yu
2025-05-13 17:15 ` [PATCH v11 13/30] x86/resctrl: Split trace.h James Morse
2025-05-13 17:15 ` [PATCH v11 14/30] x86/resctrl: Add 'resctrl' to the title of the resctrl documentation James Morse
2025-05-13 17:15 ` [PATCH v11 15/30] fs/resctrl: Add boiler plate for external resctrl code James Morse
2025-05-13 17:15 ` [PATCH v11 16/30] x86/resctrl: Move the filesystem bits to headers visible to fs/resctrl James Morse
2025-05-13 17:15 ` [PATCH v11 17/30] x86/resctrl: Move enum resctrl_event_id to resctrl.h James Morse
2025-05-15 1:00 ` Fenghua Yu
2025-05-13 17:15 ` [PATCH v11 18/30] x86/resctrl: Fix types in resctrl_arch_mon_ctx_{alloc,free}() stubs James Morse
2025-05-15 1:03 ` Fenghua Yu
2025-05-13 17:15 ` [PATCH v11 19/30] x86/resctrl: Move pseudo lock prototypes to include/linux/resctrl.h James Morse
2025-05-15 1:05 ` Fenghua Yu
2025-05-13 17:15 ` [PATCH v11 20/30] x86/resctrl: Squelch whitespace anomalies in resctrl core code James Morse
2025-05-13 17:15 ` [PATCH v11 21/30] x86/resctrl: Prefer alloc(sizeof(*foo)) idiom in rdt_init_fs_context() James Morse
2025-05-13 17:15 ` [PATCH v11 22/30] x86/resctrl: Relax some asm #includes James Morse
2025-05-15 1:17 ` Fenghua Yu
2025-05-13 17:15 ` [PATCH v11 23/30] x86/resctrl: Always initialise rid field in rdt_resources_all[] James Morse
2025-05-15 1:18 ` Fenghua Yu
2025-05-13 17:15 ` [PATCH v11 24/30] x86/resctrl: Remove a newline to avoid confusing the code move script James Morse
2025-05-13 17:15 ` [PATCH v11 25/30] x86,fs/resctrl: Move the resctrl filesystem code to live in /fs/resctrl James Morse
2025-05-13 21:26 ` Reinette Chatre [this message]
2025-05-14 18:51 ` Fenghua Yu
2025-05-13 17:15 ` [PATCH v11 26/30] x86,fs/resctrl: Remove duplicated trace header files James Morse
2025-05-15 1:19 ` Fenghua Yu
2025-05-13 17:15 ` [PATCH v11 27/30] fs/resctrl: Remove unnecessary includes James Morse
2025-05-13 17:15 ` [PATCH v11 28/30] fs/resctrl: Change internal.h's header guard macros James Morse
2025-05-13 17:15 ` [PATCH v11 29/30] x86,fs/resctrl: Move resctrl.rst to live under Documentation/filesystems James Morse
2025-05-13 17:15 ` [PATCH v11 30/30] MAINTAINERS: Add reviewers for fs/resctrl James Morse
2025-05-13 18:32 ` [PATCH v11 00/30] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl Luck, Tony
2025-05-16 10:24 ` James Morse
2025-05-13 21:19 ` Reinette Chatre
2025-05-14 18:03 ` Fenghua Yu
2025-05-13 21:32 ` Reinette Chatre
2025-05-14 15:30 ` Reinette Chatre
2025-05-16 5:53 ` Ning, Hongyu
2025-05-16 10:24 ` James Morse
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87bc7b73-aed0-4886-bcc5-b025a8444a26@intel.com \
--to=reinette.chatre@intel.com \
--cc=Babu.Moger@amd.com \
--cc=amitsinght@marvell.com \
--cc=baolin.wang@linux.alibaba.com \
--cc=bobo.shaobowang@huawei.com \
--cc=bp@alien8.de \
--cc=carl@os.amperecomputing.com \
--cc=dave.martin@arm.com \
--cc=david@redhat.com \
--cc=dfustini@baylibre.com \
--cc=fenghuay@nvidia.com \
--cc=hpa@zytor.com \
--cc=james.morse@arm.com \
--cc=kobak@nvidia.com \
--cc=lcherian@marvell.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=peternewman@google.com \
--cc=quic_jiles@quicinc.com \
--cc=rex.nie@jaguarmicro.com \
--cc=scott@os.amperecomputing.com \
--cc=sdonthineni@nvidia.com \
--cc=shameerali.kolothum.thodi@huawei.com \
--cc=tan.shaopeng@fujitsu.com \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
--cc=xhao@linux.alibaba.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox