From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753209AbdDMNUj convert rfc822-to-8bit (ORCPT ); Thu, 13 Apr 2017 09:20:39 -0400 Received: from ozlabs.org ([103.22.144.67]:46211 "EHLO ozlabs.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751343AbdDMNUh (ORCPT ); Thu, 13 Apr 2017 09:20:37 -0400 From: Michael Ellerman To: Christophe Leroy , Benjamin Herrenschmidt , Paul Mackerras , Scott Wood , Rashmica Gupta Cc: linux-kernel@vger.kernel.org, linuxppc-dev@lists.ozlabs.org Subject: Re: [PATCH] powerpc/mm: Move page table dump into powerpc subdirectory In-Reply-To: <20170413124148.EB6C76E664@localhost.localdomain> References: <20170413124148.EB6C76E664@localhost.localdomain> User-Agent: Notmuch/0.21 (https://notmuchmail.org) Date: Thu, 13 Apr 2017 23:20:34 +1000 Message-ID: <87fuhc8mvx.fsf@concordia.ellerman.id.au> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 8BIT Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Christophe Leroy writes: > Page table dump is a powerpc specific thing, so it should > appear in powerpc/ subdirectory of debugfs It's not powerpc specific. x86, arm, arm64 and s390 all have it. But, I notice we somehow got the name wrong :} All the other arches call it "kernel_page_tables". > - debugfs_file = debugfs_create_file("kernel_pagetables", 0400, NULL, > - NULL, &ptdump_fops); ¯\_(ツ)_/¯ So we probably should rename it to match the other arches. I would take a patch for that. cheers