The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Thomas Gleixner <tglx@linutronix.de>
To: Gabriele Monaco <gmonaco@redhat.com>,
	linux-kernel@vger.kernel.org,
	Anna-Maria Behnsen <anna-maria@linutronix.de>,
	Frederic Weisbecker <frederic@kernel.org>,
	Waiman Long <longman@redhat.com>
Cc: Gabriele Monaco <gmonaco@redhat.com>
Subject: Re: [PATCH v15 2/7] timers: Add the available mask in timer migration
Date: Wed, 19 Nov 2025 16:56:48 +0100	[thread overview]
Message-ID: <87v7j6kocf.ffs@tglx> (raw)
In-Reply-To: <20251113083324.33490-3-gmonaco@redhat.com>

On Thu, Nov 13 2025 at 09:33, Gabriele Monaco wrote:

Can we please consistently have 'timers/migration:' as prefix like the
other existing commits for this series? 

That allows to write this subject line in a coherent way:

     timers/migration: Provide and use cpumask for available CPUs

or something like that.

Why did I waste time for documenting all of this?

   https://www.kernel.org/doc/html/latest/process/maintainer-tip.html#patch-subject

   "‘git log path/to/file’ should give you a reasonable hint in most cases."

Is it really that hard?

> Keep track of the CPUs available for timer migration in a cpumask. This
> prepares the ground to generalise the concept of unavailable CPUs.
>
> Reviewed-by: Frederic Weisbecker <frederic@kernel.org>
> Signed-off-by: Gabriele Monaco <gmonaco@redhat.com>

Aside of the nit above:

Reviewed-by: Thomas Gleixner <tglx@linutronix.de>

  reply	other threads:[~2025-11-19 15:56 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-11-13  8:33 [PATCH v15 0/7] timers: Exclude isolated cpus from timer migration Gabriele Monaco
2025-11-13  8:33 ` [PATCH v15 1/7] timers: Rename tmigr 'online' bit to 'available' Gabriele Monaco
2025-11-19 15:49   ` Thomas Gleixner
2025-11-13  8:33 ` [PATCH v15 2/7] timers: Add the available mask in timer migration Gabriele Monaco
2025-11-19 15:56   ` Thomas Gleixner [this message]
2025-11-13  8:33 ` [PATCH v15 3/7] timers: Use scoped_guard when setting/clearing the tmigr available flag Gabriele Monaco
2025-11-19 15:57   ` Thomas Gleixner
2025-11-13  8:33 ` [PATCH v15 4/7] cgroup/cpuset: Rename update_unbound_workqueue_cpumask() to update_isolation_cpumasks() Gabriele Monaco
2025-11-13  8:33 ` [PATCH v15 5/7] sched/isolation: Force housekeeping if isolcpus and nohz_full don't leave any Gabriele Monaco
2025-11-13  8:33 ` [PATCH v15 6/7] cpumask: Add initialiser to use cleanup helpers Gabriele Monaco
2025-11-13  8:33 ` [PATCH v15 7/7] timers: Exclude isolated cpus from timer migration Gabriele Monaco
2025-11-19 16:50   ` Thomas Gleixner
2025-11-19 17:14     ` Frederic Weisbecker
2025-11-19 18:15       ` Thomas Gleixner
2025-11-19 20:13         ` Frederic Weisbecker
2025-11-19 21:23           ` Thomas Gleixner
2025-11-19 22:02             ` Frederic Weisbecker
2025-11-19 22:10               ` Thomas Gleixner
2025-11-19 22:31                 ` Frederic Weisbecker
2025-11-19 20:43   ` Waiman Long
2025-11-20 10:48     ` Gabriele Monaco
2025-11-20 21:04       ` Waiman Long
2025-11-13 13:12 ` [PATCH v15 0/7] " Frederic Weisbecker
2025-11-18 10:01   ` Gabriele Monaco

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87v7j6kocf.ffs@tglx \
    --to=tglx@linutronix.de \
    --cc=anna-maria@linutronix.de \
    --cc=frederic@kernel.org \
    --cc=gmonaco@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=longman@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox