The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Dave Hansen <dave.hansen@intel.com>
To: "Edgecombe, Rick P" <rick.p.edgecombe@intel.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"yilun.xu@linux.intel.com" <yilun.xu@linux.intel.com>,
	"x86@kernel.org" <x86@kernel.org>
Cc: "Gao, Chao" <chao.gao@intel.com>,
	"Xu, Yilun" <yilun.xu@intel.com>,
	"dave.hansen@linux.intel.com" <dave.hansen@linux.intel.com>,
	"kas@kernel.org" <kas@kernel.org>,
	"djbw@kernel.org" <djbw@kernel.org>,
	"Fang, Peter" <peter.fang@intel.com>,
	"linux-coco@lists.linux.dev" <linux-coco@lists.linux.dev>
Subject: Re: [PATCH] x86/virt/tdx: Formalize SEAMCALL version encoding support
Date: Wed, 8 Jul 2026 07:46:41 -0700	[thread overview]
Message-ID: <885da2b2-56ec-412a-bffd-d0d6404fab5a@intel.com> (raw)
In-Reply-To: <7d3eba7a5442cf3e84fe3658ae53337a183290b1.camel@intel.com>

On 7/6/26 14:44, Edgecombe, Rick P wrote:
>> Two alternative schemes were considered:
>>
>> 1. Define versioned macros like TDH_VP_INIT_V0, TDH_VP_INIT_V1, etc.
>>    However, this breaks naming consistency unless all existing stable
>>    function macros are changed to TDH_XXX_V0.
>>
>> 2. Add an explicit 'version' parameter to the base seamcall() API. This
>>    unnecessarily forces all stable SEAMCALL helpers to pass a
>>    meaningless '0' argument. Additionally, the magic '0' or '1' values
>>    at caller sites are not descriptive.
>>
> Dave was recently saying something to the effect of "make every word count". I
> think we could lose some filler words.

This can also just go below the --- so it doesn't make it to the final
changelog.

I like the discussion happening so far. I, too, dislike adding another
level of C wrappers. I'm looking forward to v2.

      parent reply	other threads:[~2026-07-08 14:46 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-02 14:46 [PATCH] x86/virt/tdx: Formalize SEAMCALL version encoding support Xu Yilun
2026-07-03  0:00 ` Xiaoyao Li
2026-07-07 15:45   ` Xu Yilun
2026-07-06 21:44 ` Edgecombe, Rick P
2026-07-07 16:18   ` Xu Yilun
2026-07-08 14:46   ` Dave Hansen [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=885da2b2-56ec-412a-bffd-d0d6404fab5a@intel.com \
    --to=dave.hansen@intel.com \
    --cc=chao.gao@intel.com \
    --cc=dave.hansen@linux.intel.com \
    --cc=djbw@kernel.org \
    --cc=kas@kernel.org \
    --cc=linux-coco@lists.linux.dev \
    --cc=linux-kernel@vger.kernel.org \
    --cc=peter.fang@intel.com \
    --cc=rick.p.edgecombe@intel.com \
    --cc=x86@kernel.org \
    --cc=yilun.xu@intel.com \
    --cc=yilun.xu@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox